LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 07-11-2012, 08:12 AM   #1
cooholio
LQ Newbie
 
Registered: Nov 2011
Location: Wabash, IN
Distribution: Slackware Current
Posts: 22

Rep: Reputation: Disabled
Slack and vsftpd


I have searched hi and low and perhaps its lack of experience i dont understand what i am doing wrong.

I am trying to use slackware and vsftpd to set up my ftp server and its all fine and dandy for 1 small detail. I can NOT seem to find out how to make them stay in their folders. when i turn on chroot i can not log in at at and when its turned off they can roam around the entier file system like they own it.

I would higly appreciate if someone could tell me what i am missing or perhaps have a good link to how to get it to work.

I am using the standard vsftpf.conf thats in the distro.
Only changes i have made are as follows:

anonymous_enable=NO
local_enable=YES
nopriv_user=ftpsecure

I have tried upgrading to 3.0.0.0 of vsftpd and still same issues.

any help is higly appreciated.

/Joakim
 
Old 07-11-2012, 08:31 AM   #2
dgrames
LQ Newbie
 
Registered: Jul 2007
Posts: 17

Rep: Reputation: 1
Hi Joakim,

You need to chmod 555 the users home directory,
Make sure you make him some directories to load files into.

Don
 
Old 07-11-2012, 09:03 AM   #3
cooholio
LQ Newbie
 
Registered: Nov 2011
Location: Wabash, IN
Distribution: Slackware Current
Posts: 22

Original Poster
Rep: Reputation: Disabled
SLack and vsftpd

I guess i am doing something wrong with the chmod command.

I type chmod 0555 dumbo <-- test user folder in /home

still when i log in thru ftp i can roam outside that folder.

any advice?

/Joakim
 
Old 07-11-2012, 09:28 AM   #4
dgrames
LQ Newbie
 
Registered: Jul 2007
Posts: 17

Rep: Reputation: 1
Hi Joakim,
You should have this in your vsftpd.conf

chroot_local_user=YES

Don
 
Old 07-11-2012, 09:34 AM   #5
cooholio
LQ Newbie
 
Registered: Nov 2011
Location: Wabash, IN
Distribution: Slackware Current
Posts: 22

Original Poster
Rep: Reputation: Disabled
slackware and vsftpd

Great Don.

Works awesome now.

will try to figure out how to mark this one as solved.
 
Old 07-11-2012, 09:41 AM   #6
cooholio
LQ Newbie
 
Registered: Nov 2011
Location: Wabash, IN
Distribution: Slackware Current
Posts: 22

Original Poster
Rep: Reputation: Disabled
vsftpf and slackware

I celebrated too early.....

i have the folder locked down so they can get out of it but cant upload anything to it....

I created a subfolder under it and even tried to 0777 it but still says permission denied when tryng to upload to it.

Obviusly missing a simple step again but any ideas ?

/Joakim
 
Old 07-11-2012, 12:21 PM   #7
cooholio
LQ Newbie
 
Registered: Nov 2011
Location: Wabash, IN
Distribution: Slackware Current
Posts: 22

Original Poster
Rep: Reputation: Disabled
Got it working.

Had to change the chmod to 0777 on the subfolder created under the user and it works fine now.

/Joakim
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Starting vsftpd for vsftpd: 500 OOPS: SSL: cannot load RSA certificate MisterTickle Linux - Server 2 02-11-2011 07:41 PM
vsftpd settingd and VSFTPD DEAD BUT SUBSYS LOCKED pc_copat Linux - Newbie 15 11-05-2009 10:31 PM
vsftpd.conf/chroot/vsftpd.chroot_list issue Jerman Linux - Security 2 06-01-2007 07:24 PM
vsftpd & ssl - how do I tell if it's actually vsftpd maintaining the connections?? hunterhunter Linux - General 0 03-27-2006 04:41 PM
VSFTPD with 500 oops :vsftpd: missing argv[0] mole_13 Linux - Newbie 0 05-04-2005 01:05 AM


All times are GMT -5. The time now is 09:15 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration