LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 04-29-2003, 10:16 AM   #1
flashingcurser
Member
 
Registered: Jan 2003
Distribution: many win/nix/mac
Posts: 259

Rep: Reputation: 31
Slack 9 trying to load wrong ethernet adapter


I have already commented the auto probe in rc.modules--and uncommented the correct driver. It loads just fine, I'm writing in it now. I reinstalled without having setup detect the card. Still in my dmesg I get:

cmpci: found CM8738 adapter at io 0xec00 irq 7
cmpci: chip version = 055
cmpci: Enable SPDIF loop
8139cp: 10/100 PCI Ethernet driver v0.3.0 (Sep 29, 2002)
usb.c: registered new driver usbdevfs
usb.c: registered new driver hub
uhci.c: USB Universal Host Controller Interface driver v1.1
PCI: Found IRQ 11 for device 00:07.2
PCI: Sharing IRQ 11 with 00:07.3
PCI: Sharing IRQ 11 with 00:10.0
uhci.c: USB UHCI at I/O 0xd400, IRQ 11
usb.c: new USB bus registered, assigned bus number 1
hub.c: USB hub found
hub.c: 2 ports detected
PCI: Found IRQ 11 for device 00:07.3
PCI: Sharing IRQ 11 with 00:07.2
PCI: Sharing IRQ 11 with 00:10.0
uhci.c: USB UHCI at I/O 0xd800, IRQ 11
usb.c: new USB bus registered, assigned bus number 2
hub.c: USB hub found
hub.c: 2 ports detected
parport0: PC-style at 0x278 [PCSPP,EPP]
parport_pc: Via 686A parallel port: io=0x278
8139cp: 10/100 PCI Ethernet driver v0.3.0 (Sep 29, 2002)
8139cp: 10/100 PCI Ethernet driver v0.3.0 (Sep 29, 2002)
8139cp: 10/100 PCI Ethernet driver v0.3.0 (Sep 29, 2002)
8139cp: 10/100 PCI Ethernet driver v0.3.0 (Sep 29, 2002)
8139cp: 10/100 PCI Ethernet driver v0.3.0 (Sep 29, 2002)
8139cp: 10/100 PCI Ethernet driver v0.3.0 (Sep 29, 2002)
8139cp: 10/100 PCI Ethernet driver v0.3.0 (Sep 29, 2002)
8139cp: 10/100 PCI Ethernet driver v0.3.0 (Sep 29, 2002)
8139cp: 10/100 PCI Ethernet driver v0.3.0 (Sep 29, 2002)
usb-uhci.c: $Revision: 1.275 $ time 15:38:38 Mar 11 2003
usb-uhci.c: High bandwidth mode enabled
usb-uhci.c: v1.275:USB Universal Host Controller Interface driver
root@duron1300:~#


It tries to load 8139cp module 10 TIMES, what is trying to load this driver?

BTW: the correct driver is 3139too.o--and it loads just fine.

My gut reaction is that it is trying to load a usb ethernet driver because of all the usb stuff going on before and after it tries to load the 9 times.

One more thought, I could sym link 8139cp to 3139too, but that would be a real lame fix.

Any thoughts would be well recieved, thanks
 
Old 04-29-2003, 10:18 AM   #2
jharris
Senior Member
 
Registered: May 2001
Location: Bristol, UK
Distribution: Slackware, Fedora, RHES
Posts: 2,243

Rep: Reputation: 46
what do you get when you
Code:
grep 8139cp /etc/rc.d/*
Also, are you using the so called "Hot Plug" feature at boot time?

cheers

Jamie...
 
Old 04-29-2003, 10:33 AM   #3
flashingcurser
Member
 
Registered: Jan 2003
Distribution: many win/nix/mac
Posts: 259

Original Poster
Rep: Reputation: 31
The grep only pulls up what I already know:

/etc/rc.d/rc.modules:#/sbin/modprobe 8139cp

However the hotplug sounds like it may be the trouble maker, any ideas of what I need to comment to turn off hot plug devices for a little test---I may just keep it that way because this is just a workstation.

Thanks
 
Old 04-29-2003, 09:05 PM   #4
flashingcurser
Member
 
Registered: Jan 2003
Distribution: many win/nix/mac
Posts: 259

Original Poster
Rep: Reputation: 31
Hay that was easy! For any one having a similar problem---

cd /etc/hotplug/blacklist

vim ./blacklist

then simply add the driver that you dont want slackware to load to the blacklist--easy!

New slackware goodies
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Cannot configure ethernet adapter soumyadas Linux - Networking 3 08-25-2005 02:06 AM
Configure ethernet adapter rec Linux - Newbie 12 03-17-2004 12:35 AM
Nforce2 Ethernet Adapter Shad.. Linux - Newbie 10 03-16-2004 03:46 PM
Slackware uses wrong video adapter elitecodex Slackware 1 02-25-2004 03:19 PM
Ethernet Adapter mprice74 Linux - Laptop and Netbook 2 09-09-2003 11:40 AM


All times are GMT -5. The time now is 07:15 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration