LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   Slack 9.1/10.1 fails to mount CDROM (http://www.linuxquestions.org/questions/slackware-14/slack-9-1-10-1-fails-to-mount-cdrom-329258/)

brianko 06-01-2005 01:49 PM

Slack 9.1/10.1 fails to mount CDROM
 
For some reason, kernels shipping with Slack 9.1/10.1 recognize, but fail to mount, some CDROMs. The mount will appear to work, but is followed by an "Not a directory" messages (even though the mount point is most certainly a directory). These same drives mount fine under Slack 8.1. Searching for a solution led me to a RH forum, where users apparently have the same issues. The trick seems to be to disable DMA on the CD device:

hdparm -d0 -X /dev/hdc

For a Slack 9.1/10.1, do this prior to invoking the setup script. Your CDROM will now be auto-detected when you start the install process.

--Brian

Bruce Hill 06-05-2005 09:26 AM

I've never seen or heard of such behavior. And I don't think that
DMA is enabled by default for CD-ROM drives in a default Slackware
kernel. Could you post an actual error message, including the command
you issued to mount the device, and what type of data you tried to mount?

brianko 06-05-2005 06:01 PM

These were drives on old Dell GX-1s. The Slack 9.1 disks were burned from ISOs from various Slack mirrors. I don't have access to them at the moment (they're in a lab behind a firewall), but I can tell you that the devices are recognized during the boot sequence, but are unmountable after booting. The Slack setup can't/won't mount them, and standard mount directives, i.e.

mount -t iso9660 /dev/hdc /cdrom

result in

mount: Not a directory

error.

Running the hdparm command "hdparm -d0 -X /dev/hdc" is the only workaround we've found to being able to continue installation from both 9.1 and 10.1.

I did a pretty exhaustive search on this topic in my attempt to resolve the issue, and I've come across several instance of others who have the same issues. Unfortunately, the resolution is often sidetracked by those meaning well who bring /etc/fstab into the picture, which really has nothing to do with the problem.

--Brian

Bruce Hill 06-05-2005 07:26 PM

Quote:

Originally posted by brianko
These were drives on old Dell GX-1s. The Slack 9.1 disks were burned from ISOs from various Slack mirrors. I don't have access to them at the moment (they're in a lab behind a firewall), but I can tell you that the devices are recognized during the boot sequence, but are unmountable after booting. The Slack setup can't/won't mount them, and standard mount directives, i.e.

mount -t iso9660 /dev/hdc /cdrom

result in

mount: Not a directory

error.

Running the hdparm command "hdparm -d0 -X /dev/hdc" is the only workaround we've found to being able to continue installation from both 9.1 and 10.1.

I did a pretty exhaustive search on this topic in my attempt to resolve the issue, and I've come across several instance of others who have the same issues. Unfortunately, the resolution is often sidetracked by those meaning well who bring /etc/fstab into the picture, which really has nothing to do with the problem.
--Brian
That does sound strange, unless the drive doesn't have support in the
kernel you booted with; but then, it doesn't seem as if it would have
loaded the kernel without it.

Have you tried to choose boot: old_cd.i when you start? I don't know if
that CD-ROM might be an older one or not. I don't understand unless
support for that CD-ROM isn't in the kernel you're using.

I'd be curious to know what the actual CD-ROM device is, and to know
which kernel you chose at boot: to see if lack of support in that kernel
contributed to this. You can determine the CD-ROM and driver from:
Code:

mingdao@titus:~$ cat /proc/ide/hdc/model
UJDA760 DVD/CDRW
mingdao@titus:~$ cat /proc/ide/hdc/driver
ide-cdrom version 4.61

if you've now got a working installation.

I know this probably isn't any help, and it may be something as simple
as DMA is enabled in the later kernels, and not in the earlier one, so
that work around is the necessary fix. I'm just dialoging and exploring
the little I know...how you don't mind.


All times are GMT -5. The time now is 11:38 PM.