LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   slack 14 won't run in runlevel 4 without monitor connected (http://www.linuxquestions.org/questions/slackware-14/slack-14-won%27t-run-in-runlevel-4-without-monitor-connected-4175433431/)

damgar 10-22-2012 01:00 AM

slack 14 won't run in runlevel 4 without monitor connected
 
I installed 14 on a machine that I want to run headless. However I will occasionally XDMCP into it so I want it to run in runlevel 4, also it sounds like a jet taking off if it's not in runlevel 4. Something about this machine without the video card simply won't boot, and without the monitor connected the video card fan kicks right back on after it enters runlevel 4. I've never experienced any of this with a headless machine before. Usually I just have to edit inittab and lilo to boot immediately and I'm done. The machine actually stays in runlevel 4, but the video card acts like it's not. It's an NVIDIA gt220 if that matters. Any help is appreciated.

wildwizard 10-22-2012 03:47 AM

Have your tried using Xvfb?

Should only require changing /etc/X11/xdm/Xservers

shotswell21 10-22-2012 08:53 AM

Quote:

Originally Posted by damgar (Post 4811848)
I installed 14 on a machine that I want to run headless. However I will occasionally XDMCP into it so I want it to run in runlevel 4, also it sounds like a jet taking off if it's not in runlevel 4. Something about this machine without the video card simply won't boot, and without the monitor connected the video card fan kicks right back on after it enters runlevel 4. I've never experienced any of this with a headless machine before. Usually I just have to edit inittab and lilo to boot immediately and I'm done. The machine actually stays in runlevel 4, but the video card acts like it's not. It's an NVIDIA gt220 if that matters. Any help is appreciated.

I do this with my media server connected to a TV. Add the following the Device section of your xorg.conf

Option "ConnectedMonitor" "DFP-1"
Option "CustomEDID" "DFP-1: /etc/X11/edid.bin"

You will need to run nvidia-settings select the monitor and use the Acquire EDID button and then save that EDID file under /etc/X11/edid.bin

Now with the monitor disconnected X or runlevel 4 will start just fine. You may need to change the "ConnectedMonitor" setting to match your setup, IE, CRT-0, HDMI-1 etc.

damgar 10-24-2012 09:14 PM

Quote:

Originally Posted by shotswell21 (Post 4812131)
I do this with my media server connected to a TV. Add the following the Device section of your xorg.conf

Option "ConnectedMonitor" "DFP-1"
Option "CustomEDID" "DFP-1: /etc/X11/edid.bin"

You will need to run nvidia-settings select the monitor and use the Acquire EDID button and then save that EDID file under /etc/X11/edid.bin

Now with the monitor disconnected X or runlevel 4 will start just fine. You may need to change the "ConnectedMonitor" setting to match your setup, IE, CRT-0, HDMI-1 etc.

You, sir, are a fantastic Slacker! Thank You. I have waited days because I didn't want to unplug my monitor from my new system and mess with all that, when it dawned on me to just pull the EDID on the "desktop" machine and ssh into the other. A quick init 3 <> init 4 and it got QUIET in here! Thank you very much! Everything in this house except the sledgehammer that was about to get some play time thank you!


All times are GMT -5. The time now is 04:33 AM.