LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   Slack-14.0/x86_64, Xfce4, Sony Vaio: No Sound (http://www.linuxquestions.org/questions/slackware-14/slack-14-0-x86_64-xfce4-sony-vaio-no-sound-4175444296/)

rshepard 01-05-2013 03:29 PM

Slack-14.0/x86_64, Xfce4, Sony Vaio: No Sound
 
I've been fighting this ever since upgrading the Sony Vaio to 14.0 from 13.37. Sound worked just fine on the earlier versions but fails to work on the latest. Alsamixer is properly configured. The Xfce4 mixer icon has the volume at maximum.

lspci reports the audio chip is Intel Corp. 6 Series/C200 Series chipset family high definition audio controller(rev 04).

lsmod shows oss modules loaded; I don't know if _all_ required modules are loaded.

Here are the messages when I try to play an mp3 file with mpg123:

[oss.c:172] error: Can't open default sound device!
[audio.c:630] error: failed to open audio device
[audio.c:180] error: Unable to find a working output module in this list: alsa,oss
[audio.c:532] error: Failed to open audio output module
[mpg123.c:897] error: Failed to initialize output, goodbye.

Please suggest how I can get the system to open the audio device. If more information is needed, ask and ye shall be answered.

TIA,

Rich

allend 01-05-2013 05:05 PM

What is the model of your Sony Vaio?
Does this help? http://docs.slackware.com/howtos:har..._snd-hda-intel
As this is an upgrade, is it possible that you have an old configuration file in /etc/modprobe.d/ that is causing a problem?

zrdc28 01-05-2013 05:28 PM

I had the same problem because i did not "install-new" that could be your case!

rshepard 01-13-2013 12:17 PM

AllenD,

Sorry for the week's delay but it's been an overly-busy week for me. To answer your first question: it's a Sony Vaio PCG-1A14L. Reading the URL you sent, adding a snd-hda-intel.conf in /etc/modprobe.d/ made no difference. Following their suggestion to search the Web I found a ubuntu page with additional solutions, but they did not work on this Sony, either.

The two Codecs found with 'cat /proc/asound/card*/codec* | grep Codec' are Conextant CX20590 and Intel CougarPoint HDMI. Neither is found in /usr/src/linux/Documentation/sound/alsa/HD-Audio-Models.txt.

Any suggestions where to go from here?

Thanks,

Rich

rshepard 01-13-2013 12:19 PM

zrdc28:

No, that is not likely the problem. I've been upgrading slackware distributions on all the hosts here since 8.0 (2003). This issue is related to the laptop, soundchip, or driver and would not be resolved with a clean install.

Thanks,

Rich

enorbet 01-13-2013 01:21 PM

Narrow Down
 
What sound manager are you using and have you tried others? Pulseaudio, for example is (to be exceedingly kind) a "work in progress",and it sounds as if Alsa is being preempted..

allend 01-13-2013 06:44 PM

You have two sound devices and I suspect that alsa is trying to use the wrong one for you.
You can look at this http://docs.slackware.com/howtos:har...s_on_slackware

rshepard 01-14-2013 02:43 PM

allend:

Thanks for the URL <http://docs.slackware.com/howtos:hardware:sound_problems_on_slackware>. I had run aplay -l yesterday but had no idea what to do with the results. Following that page's suggestion I tried to run atest but there is no such file on the system and I don't find one in the 14.0/x86_64 file list. A Web search did not find a tool named atest, either.

Another factor that may relate to the lack of sound is that a user cannot invoke alsamixer, only root can. Yet the permissions on /usr/bin/alsamixer are 755, the same as on my server/workstation and I can invoke alsamixer on this host. Might this permission issue be what needs to be resolved? Because /usr/ and /usr/bin/ have 755 perms I am puzzled why a user cannot invoke alsamixer. Any thoughts on this?

Thanks,

Rich

rshepard 01-14-2013 02:58 PM

Is alsa a 32-bit application? I've not yet installed AlienBob's multilib/compat32 libraries for 14.0. Is this my problem?

Rich

NeoMetal 01-14-2013 03:00 PM

Not sure about atest but I think you should be able to do: aplay -D plughw:1,3 <soundfile>

(substituting the numbers from aplay -l )
to test which device you want

allend 01-14-2013 10:02 PM

What is the output of 'aplay -l'?

My apologies. It appears that the SlackDocs page referred to in post #7 needs some work. I have created an entry on the discussion page.

rshepard 03-15-2013 01:12 PM

Sorry for the long delay but I've been overly busy this past couple of months.

The sound now works! Allend's pointer in post #7 above showed me how to find the problem and fix it. I have not before done more with alsamixer other than to adjust volumnes. Using the F6 key, I changed the driver from the 'default' to the Intel chip, saved the settings and tried a test .mp3. It does work now.

I learned more about both system sound and alsamixer thanks to all of you.

Regards,

Rich

angryfirelord 03-15-2013 01:39 PM

Just as a follow-up, if your user isn't part of the audio group, alsamixer might be blocked from that user.


All times are GMT -5. The time now is 12:37 AM.