LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 01-09-2008, 04:29 AM   #31
svar
Member
 
Registered: Jul 2003
Posts: 352

Original Poster
Rep: Reputation: 30

Not yet, I first tried Hominid's suggestion
Quote:
Code:
modprobe ppp_generic
lsmodagain

Then try kppp or pppsetup. If it doesn't work, try gnashley suggestion.
I though I was getting somewhere, e.g. I found that I did not have /sbin/modprobe ppp_generic
and ppp_async in /etc/rc.d/rc.modules, also fixed the modem link.

I will try your suggestion next. Just to be sure how I do this:

1. remove tcp/ip package
How:
ls /var/adm/packages | grep tcp
removpkg -warn (whatever I find with tcp)
2. remove kde package which contains kppp
Same as above
3. remove /etc/ppp directory (or change the name to something else)
mv /etc/ppp /etc/ppporiginal
4. re-install tcp/ip and the kppp package
mv /var/adm/removed_packages/tcp* /var/adm/packages/
installpkg
same for kppp
Is that correct, or should I get the packages from th CD

5. re-run kppp setup *without running pppsetup*
just start kppp from KDE or from a terminal?
 
Old 01-09-2008, 07:12 AM   #32
gnashley
Amigo developer
 
Registered: Dec 2003
Location: Germany
Distribution: Slackware
Posts: 4,764

Rep: Reputation: 472Reputation: 472Reputation: 472Reputation: 472Reputation: 472
NUmber 4 is wrong. You should not move or remove files from /var/adm/removed_packages/ -these are just database files anyway. Just re-install the packages from the CD. Once you use removepkg on a pcakage it is gone.
My point about ppsetup/kppp is that they don't get along -once you have used pppsetup kppp never seems to work correctly, so any other suggestions you try will probably be in vain until you re-install the packages. The thing is that both programs write files to /etc/ppp, but they don't write them the same so you should not try to use both programs. choose one or the other -but remember that either way the tcp/ip package needs to be installed as kppp uses tcp/ip and so do other programs.
 
Old 01-09-2008, 07:42 AM   #33
svar
Member
 
Registered: Jul 2003
Posts: 352

Original Poster
Rep: Reputation: 30
Ok, thanks, clear enough. Just for safety I will copy the files from the
CD to a temporary directory and then do installpkg from the hard disk
 
Old 01-09-2008, 03:57 PM   #34
svar
Member
 
Registered: Jul 2003
Posts: 352

Original Poster
Rep: Reputation: 30
Gnashley, I tried your prescription and got to the same place I was before, i.e. same result
i.e.

ppp: Use --help to get a list of available command line options.
bash-3.1# ls -l /dev/modem
lrwxrwxrwx 1 root root 10 2008-01-09 20:25 /dev/modem -> /dev/ttyS0
bash-3.1# kppp
bash-3.1# kppp
Opener: received SetSecret
Opener: received SetSecret
sh: atz: command not found
Opener: received OpenLock

Opener: received OpenDevice

So let me make sure I undertand you correctly:

First, I copied from the first Slack 12 CD
/mnt/cdrom/slckware/n/tcp_wrapper... and tcpdump... to /root/packages
and form the second CD
/mnt/cdrom/slackware/kde/kdenetwork... to /root/packages

Second, removepkg (these three packages)
Third, mv /etc/ppp /etc/pppold
Last, cd /root/packages
installpkg kdenetwork..., tcpdump and tcp_wrapper

Note that there is no longer a /etc/ppp directory. None has been created.
Not sure if I should rename /etc/pppold /etc/ppp

Then, I fired up kppp (from the command line) and used first The Configure option
(I assume this is what you mean by setup, or am I wrong?)

So still no cigar and the two questions are
a) whether by kppp setup you mean something different from The Configure button
and
b) whether I should cp /etc/pppold /etc/ppp

or whether I am missing something else
Note I forgot all about pppsetup
-did not even think about using it
 
Old 01-09-2008, 08:13 PM   #35
blackhole54
Senior Member
 
Registered: Mar 2006
Posts: 1,896

Rep: Reputation: 61
svar,

Given what you reported in post #29, I suggest you use minicom to verify that you can successfully talk to the modem. Specifically that the modem will initialize and that you can dial your ISP. (If you reach your ISP, you can hit three plus signs (+) rapidly to get control back and then type ATH0 -- that is the numeral zero -- to "hang up" the modem and terminate the call.) Before running minicom as a regular user, you need to run minicom -s as root to configure it. See the man page for details.
 
Old 01-10-2008, 12:30 AM   #36
svar
Member
 
Registered: Jul 2003
Posts: 352

Original Poster
Rep: Reputation: 30
As in post 29, I get modem ready and kppp prints Initializing modem.. before hanging.
So I guess the modem never got initialized-hence no question of ever reaching the ISP.
Or am I wrong?
I am also toying with the idea of using some program with finer control
over the modem than kppp (maybe wvdial or something like Device::Modem from Perl)
just to debug-right now it is far form clear to me what the problem is, unless
I have misunderstood gnashely's suggestions.
I will try minicom first though.
BTW, all these trys are done as root
 
Old 01-10-2008, 03:30 AM   #37
blackhole54
Senior Member
 
Registered: Mar 2006
Posts: 1,896

Rep: Reputation: 61
Quote:
Originally Posted by svar View Post
As in post 29, I get modem ready and kppp prints Initializing modem.. before hanging.
So I guess the modem never got initialized-hence no question of ever reaching the ISP.
Or am I wrong?
I am not sure how to interpret those messages. With minicom you can make sure you have the basics (i.e. talking to the modem, initializing it, having it dial) working before you throw in the complexities of ppp and the additional software to handle it. In other words, a divide and conquer stategy.

Quote:
I am also toying with the idea of using some program with finer control
over the modem than kppp (maybe wvdial or something like Device::Modem from Perl)
just to debug-right now it is far form clear to me what the problem is, unless
I have misunderstood gnashely's suggestions.
Hence using minicom to check the basics first.

Quote:
I will try minicom first though.
BTW, all these trys are done as root
Just FYI, if permissions are set up as I expect, after configuring minicom as root you should be able to run it as a normal user.

Last edited by blackhole54; 01-10-2008 at 03:32 AM.
 
Old 01-10-2008, 08:42 AM   #38
gnashley
Amigo developer
 
Registered: Dec 2003
Location: Germany
Distribution: Slackware
Posts: 4,764

Rep: Reputation: 472Reputation: 472Reputation: 472Reputation: 472Reputation: 472
Sorry, I should have checked the package list -the tcp/ip package has been split up into many small packages. You need to uninstall and re-install the ppp package from the /n series, same way as you did the others. that should get your /etc/ppp dir back.
Did you do a full install of Slackware when you installed?
 
Old 01-10-2008, 01:07 PM   #39
svar
Member
 
Registered: Jul 2003
Posts: 352

Original Poster
Rep: Reputation: 30
Thanks blackhole and gnashley

I tried minicom, as suggested by blackhole and it looks like all is (almost)ok:
Welcome to minicom 2.1

OPTIONS: History Buffer, F-key Macros, Search History Buffer, I18n
Compiled on Sep 18 2004, 16:54:29.

Press CTRL-A Z for help on special keys

AT S7=45 S0=0 L1 V1 X4 &c1 E1 Q0
OK
atz.
OK
atx
OK
atdt(myisp number)
CONNECT


User Access Verification

Username: myusername
Password:
Login succefull.
Entering PPP mode.
Async interface address is unnumbered (FastEthernet0/0)
MTU is 1500 bytes

~}#.!}!.} }4}"}&} }*} } }%}&..�'}"}(}"}>E~~}#.!}!.} }4}"}&} }*} } }%}&..�~
NO CARRIER

ok, the NO CARRIER is, I suppose because I was supposed to hit Ctrl-something
, but did not remember quite what(does anyone. I think it is not Ctrl-D, C or Z, but I do not
recall what it should be)
Meanwhile, kppp shows the same behavior(hang at initialize modem)
I'll retry with ppp from n
The point is looks like everything is ok exceot ppp-hopefully gnashley's suggestion will cure it
 
Old 01-10-2008, 01:58 PM   #40
svar
Member
 
Registered: Jul 2003
Posts: 352

Original Poster
Rep: Reputation: 30
gnashley, I did
removepkg (ppp_package)
and then installpkg (ppp_package)
Kppp still behaves the same way, i.e. hangs on Installing
when run from the command line all it says is:

bash-3.1# kppp
Opener: received SetSecret
Opener: received SetSecret
sh: atz: command not found
Opener: received OpenLock

Opener: received OpenDevice

BTW, Slack 12 was installed from scratch
 
Old 01-10-2008, 08:56 PM   #41
blackhole54
Senior Member
 
Registered: Mar 2006
Posts: 1,896

Rep: Reputation: 61
Quote:
Originally Posted by svar View Post
ok, the NO CARRIER is, I suppose because I was supposed to hit Ctrl-something
, but did not remember quite what(does anyone. I think it is not Ctrl-D, C or Z, but I do not
recall what it should be)

The other end had alread started Point-to-Point Protocol and was expecting you to do the same. My guess is it just dropped the line when you didn't do so after a certain period of time. But it looks like the basics are working, which I think is good info to have as you go forward.

FWIW, I have some experience with WvDial, but only as it has been called from within ifup-ppp scripts on RH.
 
Old 01-11-2008, 12:50 AM   #42
svar
Member
 
Registered: Jul 2003
Posts: 352

Original Poster
Rep: Reputation: 30
Need to hit Ctrl-a q , when I get the funny characters, I guess, see
http://www.linuxquestions.org/questi...uration-11683/
(last time I had done that was about 10 years ago...)
So yes, we have established ppp is working, but kppp is not. I have no clue now why this is so.
 
Old 01-17-2008, 08:00 AM   #43
svar
Member
 
Registered: Jul 2003
Posts: 352

Original Poster
Rep: Reputation: 30
With kppp I opened up terminal, connected, authenticated myself to the ISP,
then I got the same lines with funny charactes, like braces and so on
and Control A Z did not do anything, so I got back a no carrier thing.
The same thing I get with minicom). On the other hand if I do not open terminal window in kppp->modem, it just shuts down the the kppp window and I am not connected.
Maybe I do not remember correctly and I need some different escape sequence when I get the funny characters after authentication?
 
Old 01-17-2008, 03:32 PM   #44
blackhole54
Senior Member
 
Registered: Mar 2006
Posts: 1,896

Rep: Reputation: 61
minicom is great for troubleshooting, but I think it would be rather inconvenient to routinely use to get on the internet. But if you want to try ... All those "funny characters" is your ISP's server talking PPP. If you want to proceed, you should get out of minicom with Ctl-a followed by q followed by answering yes when it asks you if you want to exit w/o resetting (or something like that; I am going from memory here). You then need to manually start pppd before the other end drops the line. I have never actually followed through with starting pppd -- I stopped when I saw I could talk to my ISP.

I was hoping gnashley could help you get kppp working. If that is not working out I am wondering if you should just try ppp-go. I really don't have much experience with kppp and I've never used Slackware. Did you ever get pppsetup to work? If so, I suggest backing everything out like you did before to assure you don't have the conflict between packages that gnashley was talking about, and then run pppsetup and use ppp-go and ppp-off to control your connection.
 
Old 01-22-2008, 03:50 AM   #45
svar
Member
 
Registered: Jul 2003
Posts: 352

Original Poster
Rep: Reputation: 30
Ctrl-a and q do not seem to work(others say Ctrl-a and z, I think I tried all conceivable combinations of a, q and z)
One of gnashley's point was not to use kppp and pppsetup, so I'm avoiding this.
The fact that with kppp I can bring up a terminal(as in minicom) and connect(go past authentication and up to the Ctrl-a z stage) means kppp
is not incompatible with something else, but that for some reason it cannot perform some step along the sequence of commands it has to perform;
the bad thing with a gui like kppp is it does not tell me where and why it fails.

Your suggestion is simple -give up on kppp,
try pppsetup instead
but I feel I must be close, sinc eI can connect.

The other thing is how about wvdial? Any experience with that?

I may also try my own connect script, something like Perl's
Device::SerialPort
and look at the messages or
maybe from a command line
kppp and redirect errors to some file(assuming kppp gives any errors)

But I would hope kppp would run (out of the box....)
 
  


Reply

Tags
modem


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
xorg issue in slack 11 mm0204 Slackware 7 03-29-2007 10:35 AM
Slack 11, mouse issue itsjustme Slackware 5 10-09-2006 09:57 PM
Slack 10.1 with 2.6.12 pcmcia issue byondrch Slackware 3 08-23-2005 07:21 PM
Slack 10.1 -- Mouse issue / X11 issue Pozican Linux - General 4 04-19-2005 03:44 AM
cpu issue w/ slack 9.0 RIgimp75 Slackware 8 06-16-2003 09:14 PM


All times are GMT -5. The time now is 08:19 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration