LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   Slack 12.2 mouse trap whack... (http://www.linuxquestions.org/questions/slackware-14/slack-12-2-mouse-trap-whack-742582/)

ash1ar 07-24-2009 06:50 PM

Slack 12.2 mouse trap whack...
 
For some reason, each time I boot up from a shutdown, I must login as root and run: modprobe psmouse

Has anyone else had this issue? I'm having it on two machines with two different mice (one laser ps/2, the other a plain jane ps/2)?

Is there a solution, or do I just need to add this command to a startup script? If I need to add it to the startup, would someone please be so kind as to remind me where the script is, because it's been awhile and I've forgotten.

xflow7 07-24-2009 07:44 PM

Can't tell from your post whether you have to modprobe psmouse because it's not loaded automatically at all when you boot, or because it needs to be re-initialized.

Regarding the latter, Slackware defaults to loading psmouse with the "proto=imps" option because of certain KVM problems if psmouse is started with its default ("proto=any"). However, this occasionally can cause things not to work (for example the synaptics touchpad module doesn't work with proto=imps).

Try editing /etc/modprobe.d/psmouse and changing "proto=imps" to "proto=any" and see what happens.

dive 07-24-2009 10:12 PM

The modprobe commands are in /etc/rc.d/rc.modules-`uname -r`

ash1ar 07-25-2009 08:51 AM

Quote:

Originally Posted by xflow7 (Post 3619404)
Can't tell from your post whether you have to modprobe psmouse because it's not loaded automatically at all when you boot, or because it needs to be re-initialized.
"proto=any" and see what happens.

THanks for the suggestion. The issue is it does not seem to be loading at all when I start up. I was aware of the /etc/modprobe.d/psmouse situation and via another users suggestion I commented out the proto option entirely and reloaded psmouse. This worked at the time, and continues to, however even with the proto option commented out i still have to login as root after start up and reload the psmouse.

I did try un-commenting the proto option and substituting the imps option with any, gave a power down and power up, and I still have the same result.

In other news, which may or may not be related, when I get to the slackware splash screen at boot up my keyboard has all three lights on, but is unresponsive. I have to unplug and plug it back in to get it to work. Only then can I hit enter and proceed. I was going to do a search for that issue later, but thought I'd mention it in case there is a relationship between the two issues.

ash1ar 07-25-2009 08:58 AM

Quote:

Originally Posted by dive (Post 3619464)
The modprobe commands are in /etc/rc.d/rc.modules-`uname -r`

Dive, thank you for the info. I ran that command with the following result:

/etc/rc.d> rc.modules -'uname -r'
Module dependencies up to date (no new kernel modules found).
FATAL: Error inserting pcspkr (/lib/modules/2.6.27.7-smp/kernel/drivers/input/misc/pcspkr.ko): Operation not permitted
FATAL: Module capability not found.

onebuck 07-25-2009 09:35 AM

Hi,

You could be experiencing the following;

Quote:

excerpt from 'CHANGES_AND_HINTS.TXT';

On many systems, the xf86-input-synaptics driver requires the psmouse kernel
kernel module be loaded without any special options. This poses a problem on a
default Slackware installation, as /etc/modprobe.d/psmouse causes the psmouse
module to load with the imps protocol. This is easily fixed though :-)
First, edit /etc/modprobe.d/psmouse so that it looks like this (note
that we're simply commenting out the last line):
# PS/2 mouse support:
# The default options when the psmouse module is loaded will completely
# break the mouse if you change consoles with several models of KVM
# switches. Therefore, we'll have it use the imps protocol here, which
# is a more basic protocol that is less likely to cause problems with
# the mouse. If you'd rather use the kernel default options, just
# comment out the line below. If you'd rather choose your own options,
# then edit the line below as desired.
#options psmouse proto=imps
Next, unload and reload the psmouse module (do this as root):
modprobe -r psmouse
modprobe psmouse


ash1ar 07-25-2009 11:02 AM

Quote:

Originally Posted by onebuck (Post 3619873)
Hi,

You could be experiencing the following;

Indeed, but I shouldn't have to run the modprobe psmouse command every time I start up. That's the situation.

conundrum07 07-25-2009 11:31 AM

You can add the modprobe command to your rc.local script if you want it to be loaded when you boot the system.

manwichmakesameal 07-25-2009 01:52 PM

Quote:

FATAL: Error inserting pcspkr (/lib/modules/2.6.27.7-smp/kernel/drivers/input/misc/pcspkr.ko): Operation not permitted
FATAL: Module capability not found.
Did you rebuild your kernel, or are you using a custom one? This error is kinda funky for a stock Slack kernel. Are you running the 2.6.27.2-smp kernel?

ash1ar 07-25-2009 03:12 PM

Quote:

Originally Posted by manwichmakesameal (Post 3620052)
Did you rebuild your kernel, or are you using a custom one? This error is kinda funky for a stock Slack kernel. Are you running the 2.6.27.2-smp kernel?

I had Slack 12 before hand, then reinstalled with 12.2/upgraded. I just used the default hugesmp kernel that was recommended when I installed.

manwichmakesameal 07-25-2009 04:02 PM

Quote:

I had Slack 12 before hand, then reinstalled with 12.2/upgraded.
I'm not sure what you mean there. Did you format and do a fresh install, or did you just upgrade? Try using the generic kernel, and make an initrd. There is /boot/README.initrd that you should take a look at.

rworkman 07-26-2009 01:46 AM

It sounds like the psmouse module is blacklisted, which implies that the system was upgraded from 12.0 to 12.2 (as the OP later stated), and that the OP needs to read http://slackware.osuosl.org/slackwar..._AND_HINTS.TXT

ash1ar 08-10-2009 06:28 PM

Quote:

Originally Posted by rworkman (Post 3620438)
It sounds like the psmouse module is blacklisted, which implies that the system was upgraded from 12.0 to 12.2 (as the OP later stated), and that the OP needs to read http://slackware.osuosl.org/slackwar..._AND_HINTS.TXT

Bingo. You were absolutely correct sir. You're a gentleman and a scholar.


All times are GMT -5. The time now is 08:06 PM.