LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices



Reply
 
Search this Thread
Old 05-06-2008, 10:38 PM   #1
shepper
Member
 
Registered: Mar 2003
Location: Dry, Dusty and Conservative
Distribution: OpenBSD, Debian Wheezy/Jessie
Posts: 449

Rep: Reputation: 33
Slack 12.1 Atheros Wireless on gbook


I am posting this via an Everex gbook via the eth0 interface. I have installed the Madwifi SlackBuild for 12.1 and but have spent the better part of the day trying to get wireless working

Followed Aliens Directions at Madwifi and tried both editing rc.wireless.conf and rc.inet1.conf.

Code:
# Multiband Atheros based 802.11a/b/g universal NIC cards
00:16:44:*)
    INFO="Multiband Atheros based 802.11a/b/g universal NIC"
    # ESSID (extended network name) : My Network, any
    ESSID="Shepnet"
    # Operation mode : Ad-Hoc, Managed, Master, Repeater, Secondary, auto
    MODE="Managed"
    # Frequency or channel : 1, 2, 3 (channel) ; 2.422G, 2.46G (frequency)
    FREQ=""
    CHANNEL="5"
    # Bit rate : auto, 1M, 11M,54M
    RATE="54m auto"
    # Encryption key : 4567-89AB-CD, s:password
    # Example for 40-bit encryption:
    #KEY="883e-aa67-21 [1] key 5501-d0da-87 [2] key 91f5-3368-6b [3] key 2d73-31
b7-96 [4]"
    # Example for 104-bit encryption (aka 128-bit WEP):
    #KEY="d5ad2f05abd048ecf10b1c80c7"
    KEY="XXXXXXXXXXXXXXXXXXXXXXXXX"
    # Other iwconfig parameters : power off, ap 01:23:45:67:89:AB
    IWCONFIG=""
    # iwspy parameters : + 01:23:45:67:89:AB
    IWSPY=""

I can scan my access point

Code:
          Cell 05 - Address: 00:1A:70:D1:4B:E9
                    ESSID:"Shepnet"
                    Mode:Master
                    Frequency:2.432 GHz (Channel 5)
                    Quality=34/70  Signal level=-61 dBm  Noise level=-95 dBm
                    Encryption key:on
                    Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 18 Mb/s
                              24 Mb/s; 36 Mb/s; 54 Mb/s; 6 Mb/s; 9 Mb/s
                              12 Mb/s; 48 Mb/s
I have seen a dmesg that ath0 can find no IVP6 routers and have tried blacklisting ivp6 although it still comes up in lsmod and I get the same ivp6 warning with eth0 and it works fine.

My lspci
Code:
bash-3.1# lspci
00:00.0 Host bridge: VIA Technologies, Inc. P4M900 Host Bridge (rev 80)
00:00.1 Host bridge: VIA Technologies, Inc. P4M900 Host Bridge
00:00.2 Host bridge: VIA Technologies, Inc. P4M900 Host Bridge
00:00.3 Host bridge: VIA Technologies, Inc. P4M900 Host Bridge
00:00.4 Host bridge: VIA Technologies, Inc. P4M900 Host Bridge
00:00.5 PIC: VIA Technologies, Inc. P4M900 I/O APIC Interrupt Controller
00:00.6 Host bridge: VIA Technologies, Inc. P4M900 Security Device
00:00.7 Host bridge: VIA Technologies, Inc. P4M900 Host Bridge
00:01.0 PCI bridge: VIA Technologies, Inc. VT8237 PCI Bridge
00:02.0 PCI bridge: VIA Technologies, Inc. P4M900 PCI to PCI Bridge Controller
00:03.0 PCI bridge: VIA Technologies, Inc. P4M900 PCI to PCI Bridge Controller (rev 80)
00:0f.0 IDE interface: VIA Technologies, Inc. VT8237A SATA 2-Port Controller (rev 80)
00:0f.1 IDE interface: VIA Technologies, Inc. VT82C586A/B/VT82C686/A/B/VT823x/A/C PIPC Bus Master IDE (rev 07)
00:10.0 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller (rev a0)
00:10.1 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller (rev a0)
00:10.2 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller (rev a0)
00:10.3 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller (rev a0)
00:10.4 USB Controller: VIA Technologies, Inc. USB 2.0 (rev 86)
00:11.0 ISA bridge: VIA Technologies, Inc. VT8237A PCI to ISA Bridge
00:11.7 Host bridge: VIA Technologies, Inc. VT8251 Ultra VLINK Controller
00:12.0 Ethernet controller: VIA Technologies, Inc. VT6102 [Rhine-II] (rev 7c)
00:13.0 PCI bridge: VIA Technologies, Inc. VT8237A Host Bridge
00:13.1 PCI bridge: VIA Technologies, Inc. VT8237A PCI to PCI Bridge
01:00.0 VGA compatible controller: VIA Technologies, Inc. Chrome9 HC IGP (rev 01)
04:01.0 Audio device: VIA Technologies, Inc. VIA High Definition Audio Controller (rev 10)
05:01.0 Ethernet controller: Atheros Communications Inc. AR2413 802.11bg NIC (rev 01)
This is the last hurdle in getting this EL Cheapo notebook up and running
(the video settings required the openchrome driver and modeline in xorg.conf)
Any advice appreciated.

Last edited by shepper; 05-07-2008 at 12:07 AM. Reason: code tags
 
Old 05-06-2008, 11:01 PM   #2
Bruce Hill
HCL Maintainer
 
Registered: Jun 2003
Location: Tupelo, MS
Distribution: Gentoo
Posts: 6,926

Rep: Reputation: 124Reputation: 124
Why do you say your wireless doesn't work?

Please post the output of:
Code:
iwconfig ath0
ifconfig -a
lsmod | grep -i ath
cat /etc/resolv.conf
ping -c2 www.google.com
 
Old 05-06-2008, 11:18 PM   #3
C-Sniper
Member
 
Registered: Dec 2006
Distribution: Slackware
Posts: 507

Rep: Reputation: 33
You need the madwifi drivers for Atheros to get it working (at least on my machine it is that way). Checkout www.madwifi.org
 
Old 05-06-2008, 11:43 PM   #4
shepper
Member
 
Registered: Mar 2003
Location: Dry, Dusty and Conservative
Distribution: OpenBSD, Debian Wheezy/Jessie
Posts: 449

Original Poster
Rep: Reputation: 33
Bruce

I am unable to ping google and when I attemp to start a browser it is unable to connect
My lsmod
Code:
bash-3.1$ lsmod | grep -i ath
ath_rate_sample        11904  1 
ath_pci                88992  0 
wlan                  188144  5 wlan_wep,wlan_scan_sta,ath_rate_sample,ath_pci
ath_hal               189392  3 ath_rate_sample,ath_pci
My resolv.conf - Think this may be the problem
Code:
bash-3.1$ cat /etc/resolv.conf
# Generated by dhcpcd for interface eth0
nameserver 205.171.3.65
nameserver 205.171.2.65
My ifconfig (still on eth0)
Code:
bash-3.1# iwconfig ath0
ath0      IEEE 802.11g  ESSID:"Shepnet"  Nickname:"Mule"
          Mode:Managed  Frequency:2.432 GHz  Access Point: 00:1A:70:D1:4B:E9   
          Bit Rate:54 Mb/s   Tx-Power:17 dBm   Sensitivity=1/1  
          Retry:off   RTS thr:off   Fragment thr:off
          Encryption key:key removed   Security mode:restricted
          Power Management:off
          Link Quality=63/70  Signal level=-32 dBm  Noise level=-95 dBm
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0
Thanks for your help

Last edited by shepper; 05-08-2008 at 01:13 AM. Reason: code tags
 
Old 05-06-2008, 11:53 PM   #5
Bruce Hill
HCL Maintainer
 
Registered: Jun 2003
Location: Tupelo, MS
Distribution: Gentoo
Posts: 6,926

Rep: Reputation: 124Reputation: 124
shepper,

Use code tags instead of quotes for command output, and you'll get rid of
those smileys and format the output nicer.

Can you post the output of "ping -c2 www.google.com" and "ifconfig -a" ?

What do you get for "host www.google.com 4.2.2.1" ?
 
Old 05-07-2008, 12:14 AM   #6
shepper
Member
 
Registered: Mar 2003
Location: Dry, Dusty and Conservative
Distribution: OpenBSD, Debian Wheezy/Jessie
Posts: 449

Original Poster
Rep: Reputation: 33
ifconfig -a
Code:
bash-3.1# ifconfig -a
ath0      Link encap:Ethernet  HWaddr 00:16:44:9c:83:31  
          inet6 addr: fe80::216:44ff:fe9c:8331/64 Scope:Link
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:5 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:0 (0.0 B)  TX bytes:378 (378.0 B)

eth0      Link encap:Ethernet  HWaddr 00:14:0b:41:a3:ae  
          inet addr:192.168.1.7  Bcast:192.168.1.255  Mask:255.255.255.0
          inet6 addr: fe80::214:bff:fe41:a3ae/64 Scope:Link
          UP BROADCAST NOTRAILERS RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:826 errors:0 dropped:0 overruns:0 frame:0
          TX packets:957 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:502014 (490.2 KiB)  TX bytes:203023 (198.2 KiB)
          Interrupt:9 Base address:0x8400 

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:8 errors:0 dropped:0 overruns:0 frame:0
          TX packets:8 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:400 (400.0 B)  TX bytes:400 (400.0 B)

wifi0     Link encap:UNSPEC  HWaddr 00-16-44-9C-83-31-61-74-00-00-00-00-00-00-00-00  
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:627 errors:0 dropped:0 overruns:0 frame:3338
          TX packets:932 errors:1 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:199 
          RX bytes:56290 (54.9 KiB)  TX bytes:46082 (45.0 KiB)
          Interrupt:10
I can ping google fine when I'm hooked up via eth0
Code:
bash-3.1# ping -c2 www.google.com
PING www.l.google.com (209.85.173.103) 56(84) bytes of data.
64 bytes from mh-in-f103.google.com (209.85.173.103): icmp_seq=1 ttl=241 time=51.8 ms
64 bytes from mh-in-f103.google.com (209.85.173.103): icmp_seq=2 ttl=241 time=51.5 ms

--- www.l.google.com ping statistics ---
2 packets transmitted, 2 received, 0% packet loss, time 999ms
rtt min/avg/max/mdev = 51.554/51.717/51.881/0.280 ms
When I am on ath0 I can't ping google or my router: ping 192.168.1.1

No smiley's this time
 
Old 05-07-2008, 12:19 AM   #7
Bruce Hill
HCL Maintainer
 
Registered: Jun 2003
Location: Tupelo, MS
Distribution: Gentoo
Posts: 6,926

Rep: Reputation: 124Reputation: 124
You will have to stop eth0 and start ath0 for us to help you,
because you're not posting output of your ath0. You can start
ath0 at the same time eth0 is running ...

Also you should post the output of /etc/rc.d/rc.inet1.conf
and /etc/rc.d/rc.wireless.conf
 
Old 05-07-2008, 12:44 AM   #8
shepper
Member
 
Registered: Mar 2003
Location: Dry, Dusty and Conservative
Distribution: OpenBSD, Debian Wheezy/Jessie
Posts: 449

Original Poster
Rep: Reputation: 33
The edited portion of my rc.wireless.conf is in the first post but if you need the whole thing. As mentioned earlier I tried the configuration settings in both rc.wireless.conf and rc.inet1.conf. I will post the results of iwconfig ath0 and ifconfig -a shortly
Code:
# Wireless LAN adapter configuration
#
# Theory of operation : 
#
# The script attempts to match a block of settings to the specific wireless
# card inserted, the *first* block matching the card is used.
# The address format is "hwaddr", with * as a wildcard.
# 'hwaddr' is the unique MAC address identifier of the wireless card.
# The MAC address is usually printed on the card, or can be found via ifconfig.
# Some examples here use only half of the MAC address with a wildcard to
# match a whole family of cards...
#
# All the Wireless specific configuration is done through the Wireless
# Extensions, so we will just call 'iwconfig' with the right parameters
# defined below.
# Of course, you need to have iwconfig installled on your system.
# To download iwconfig, or for more info on Wireless Extensions :
#       http://www.hpl.hp.com/personal/Jean_Tourrilhes/Linux/Tools.html
#
# Note : you don't need to fill all parameters, leave them blank, in most
# cases the driver will initialise itself with sane defaults values or
# automatically figure out the value... And no drivers do support all
# possible settings...
#
# -- This is a modified '/etc/pcmcia/wireless.opts' script --
# -- I added sections for Prism/GT and Atheros based cards --
# --    (supported by the prism54 and madwifi drivers)     --
# --              16/sep/2004 * Eric Hameleers             --
#

VERBOSE=1

case "$HWADDR" in

## NOTE : Comment out the following five lines to activate the samples below ...
## --------- START SECTION TO REMOVE -----------
## Pick up any Access Point, should work on most 802.11 cards
#*)
#    INFO="Any ESSID"
#    ESSID="any"
#    ;;
## ---------- END SECTION TO REMOVE ------------


# Here are a few examples with a few Wireless LANs supported...
# The matching is done on the first 3 bytes of the MAC address

# SMC2835W EZ Connect g 2.4GHz 54 Mbps Wireless Cardbus Adapter 
00:04:E2:*)
    INFO="SMC2835W EZ Connect g 2.4GHz 54 Mbps Wireless Cardbus Adapter"
    # ESSID (extended network name) : My Network, any
    ESSID="any"
    # NWID/Domain (cell identifier) : 89AB, 100, off
    NWID=""
    # Operation mode : Ad-Hoc, Managed, Master, Repeater, Secondary, auto
    MODE="Managed"
    # Frequency or channel : 1, 2, 3 (channel) ; 2.422G, 2.46G (frequency)
    FREQ=""
    CHANNEL="7"
    # Sensitivity (cell size + roaming speed) : 1, 2, 3 ; -70 (dBm)
    SENS=""
    # Bit rate : auto, 1M, 11M,54M
    RATE="auto"
    # Encryption key : 4567-89AB-CD, s:password
    # Example for 40-bit encryption:
    #KEY="883e-aa67-21 [1] key 5501-d0da-87 [2] key 91f5-3368-6b [3] key 2d73-31b7-96 [4]"
    # Example for 104-bit encryption (aka 128-bit WEP):
    #KEY="d5ad2f05abd048ecf10b1c80c7"
    KEY=""
    # RTS threshold : off, 500
    RTS=""
    # Fragmentation threshold : off, 1000
    FRAG=""
    # Other iwconfig parameters : power off, ap 01:23:45:67:89:AB
    IWCONFIG=""
    # iwspy parameters : + 01:23:45:67:89:AB
    IWSPY=""
    # iwpriv parameters : set_port 2, set_histo 50 60
    IWPRIV=""
;;

# Multiband Atheros based 802.11a/b/g universal NIC cards
00:16:44:*)
    INFO="Multiband Atheros based 802.11a/b/g universal NIC"
    # ESSID (extended network name) : My Network, any
    ESSID="Shepnet"
    # Operation mode : Ad-Hoc, Managed, Master, Repeater, Secondary, auto
    MODE="Managed"
    # Frequency or channel : 1, 2, 3 (channel) ; 2.422G, 2.46G (frequency)
    FREQ=""
    CHANNEL="5"
    # Bit rate : auto, 1M, 11M,54M
    RATE="54m auto"
    # Encryption key : 4567-89AB-CD, s:password
    # Example for 40-bit encryption:
    #KEY="883e-aa67-21 [1] key 5501-d0da-87 [2] key 91f5-3368-6b [3] key 2d73-31b7-96 [4]"
    # Example for 104-bit encryption (aka 128-bit WEP):
    #KEY="d5ad2f05abd048ecf10b1c80c7"
    KEY="key removed"
    # Other iwconfig parameters : power off, ap 01:23:45:67:89:AB
  # Other iwconfig parameters : power off, ap 01:23:45:67:89:AB
    IWCONFIG=""
    # iwspy parameters : + 01:23:45:67:89:AB
    IWSPY=""
    # iwpriv parameters : set_port 2, set_histo 50 60
    IWPRIV=""
    ;;
    ----------
    Below this are other wireless cards that I did not touch
# Lucent Wavelan IEEE (+ Orinoco, RoamAbout and ELSA)
# Note : wvlan_cs driver only, and version 1.0.4+ for encryption support
00:60:1D:*|00:02:2D:*)
INFO="Wavelan IEEE example (Lucent default settings)"
ESSID="Wavelan Network"
MODE="Managed"
#RATE="auto"
KEY="s:secu1"
# To set all four keys, use :
#KEY="s:secu1 [1] key s:secu2 [2] key s:secu3 [3] key s:secu4 [4] key [1]"
# For the RG 1000 Residential Gateway: The ESSID is the identifier on
# the unit, and the default key is the last 5 digits of the same.
#ESSID="084d70"
#KEY="s:84d70"
;;




My rc.inet1.conf
Code:
# /etc/rc.d/rc.inet1.conf
#
# This file contains the configuration settings for network interfaces.
# If USE_DHCP[interface] is set to "yes", this overrides any other settings.
# If you don't have an interface, leave the settings null ("").

# You can configure network interfaces other than eth0,eth1... by setting
# IFNAME[interface] to the interface's name. If IFNAME[interface] is unset
# or empty, it is assumed you're configuring eth<interface>.

# Several other parameters are available, the end of this file contains a
# comprehensive set of examples.

# =============================================================================

# Config information for eth0:
IPADDR[0]=""
NETMASK[0]=""
USE_DHCP[0]="yes"
DHCP_HOSTNAME[0]=""

# Config information for eth1:
IPADDR[1]=""
NETMASK[1]=""
USE_DHCP[1]=""
DHCP_HOSTNAME[1]=""

# Config information for eth2:
IPADDR[2]=""
NETMASK[2]=""
USE_DHCP[2]=""
DHCP_HOSTNAME[2]=""

# Config information for eth3:
IPADDR[3]=""
NETMASK[3]=""
USE_DHCP[3]=""
DHCP_HOSTNAME[3]=""

# Default gateway IP address:
GATEWAY=""

# Change this to "yes" for debugging output to stdout.  Unfortunately,
# /sbin/hotplug seems to disable stdout so you'll only see debugging output
# when rc.inet1 is called directly.
DEBUG_ETH_UP="no"

## Example config information for wlan0.  Uncomment the lines you need and fill
## in your info.  (You may not need all of these for your wireless network)
#IFNAME[4]="wlan0"
#IPADDR[4]=""
#NETMASK[4]=""
#USE_DHCP[4]="yes"
#DHCP_HOSTNAME[4]="icculus-wireless"
#DHCP_KEEPRESOLV[4]="yes"
#DHCP_KEEPNTP[4]="yes"
#DHCP_KEEPGW[4]="yes"
#DHCP_IPADDR[4]=""
#WLAN_ESSID[4]=BARRIER05
#WLAN_MODE[4]=Managed
##WLAN_RATE[4]="54M auto"
##WLAN_CHANNEL[4]="auto"
##WLAN_KEY[4]="D5AD1F04ACF048EC2D0B1C80C7"
##WLAN_IWPRIV[4]="set AuthMode=WPAPSK | set EncrypType=TKIP | set WPAPSK=96389dc66eaf7e6efd5b5523ae43c7925ff4df2f8b7099495192d44a774fda16"
#WLAN_WPA[4]="wpa_supplicant"
#WLAN_WPADRIVER[4]="ndiswrapper"

## Some examples of additional network parameters that you can use.
## Config information for wlan0:
#IFNAME[4]="wlan0"              # Use a different interface name nstead of
                                # the default 'eth4'
#HWADDR[4]="00:01:23:45:67:89"  # Overrule the card's hardware MAC address
#MTU[4]=""                      # The default MTU is 1500, but you might need
                                # 1360 when you use NAT'ed IPSec traffic.
#DHCP_KEEPRESOLV[4]="yes"       # If you dont want /etc/resolv.conf overwritten
#DHCP_KEEPNTP[4]="yes"          # If you don't want ntp.conf overwritten
#DHCP_KEEPGW[4]="yes"           # If you don't want the DHCP server to change
                                # your default gateway
#DHCP_IPADDR[4]=""              # Request a specific IP address from the DHCP
                                # server
#WLAN_ESSID[4]=DARKSTAR         # Here, you can override _any_ parameter
                                # defined in rc.wireless.conf, by prepending
                                # 'WLAN_' to the parameter's name. Useful for
                                # those with multiple wireless interfaces.
#WLAN_IWPRIV[4]="set AuthMode=WPAPSK | set EncrypType=TKIP | set WPAPSK=thekey"
                                # Some drivers require a private ioctl to be
                                # set through the iwpriv command. If more than
                                # one is required, you can place them in the
                                # IWPRIV parameter (separated with the pipe (|)
                                # character, see the example).
 
Old 05-07-2008, 01:05 AM   #9
shepper
Member
 
Registered: Mar 2003
Location: Dry, Dusty and Conservative
Distribution: OpenBSD, Debian Wheezy/Jessie
Posts: 449

Original Poster
Rep: Reputation: 33
He is what I get with the nic (eth0) unplugged and trying to connect via ath0. I have another FreeBSD box running fine on wireless as I write this.

Code:
bash-3.1# ping www.google.com
ping: unknown host www.google.com
bash-3.1# ifconfig -a
ath0      Link encap:Ethernet  HWaddr 00:16:44:9c:83:31  
          inet6 addr: fe80::216:44ff:fe9c:8331/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:6 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:0 (0.0 B)  TX bytes:468 (468.0 B)

eth0      Link encap:Ethernet  HWaddr 00:14:0b:41:a3:ae  
          BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)
          Interrupt:9 Base address:0x400 

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:8 errors:0 dropped:0 overruns:0 frame:0
          TX packets:8 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:400 (400.0 B)  TX bytes:400 (400.0 B)

wifi0     Link encap:UNSPEC  HWaddr 00-16-44-9C-83-31-61-74-00-00-00-00-00-00-00-00  
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:352 errors:0 dropped:0 overruns:0 frame:2753
          TX packets:49 errors:1 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:199 
          RX bytes:31823 (31.0 KiB)  TX bytes:2680 (2.6 KiB)
          Interrupt:10 

bash-3.1# iwconfig ath0
ath0      IEEE 802.11g  ESSID:"Shepnet"  Nickname:"Mule"
          Mode:Managed  Frequency:2.432 GHz  Access Point: 00:1A:70:D1:4B:E9   
          Bit Rate:54 Mb/s   Tx-Power:17 dBm   Sensitivity=1/1  
          Retry:off   RTS thr:off   Fragment thr:off
          Encryption key:key removed   Security mode:restricted
          Power Management:off
          Link Quality=56/70  Signal level=-40 dBm  Noise level=-96 dBm
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0

bash-3.1# dhcpcd ath0
bash-3.1# ping www.google.com
.............wait a long time and no output

Last edited by shepper; 05-08-2008 at 01:11 AM.
 
Old 05-07-2008, 11:02 PM   #10
Alstare
Member
 
Registered: Jul 2003
Distribution: Slackware
Posts: 79

Rep: Reputation: 15
Looking at your "ifconfig -a" output you dont have an IP configured for your wireless card, there inlies the major problem.

I noticed in your "rc.inet1.conf" you dont have anything edited...?

You should uncomment and edit the lines you need for your connection.

For example:

Code:
# Default gateway IP address:
GATEWAY="www.xxx.yyy.zzz"

# Change this to "yes" for debugging output to stdout.  Unfortunately,
# /sbin/hotplug seems to disable stdout so you'll only see debugging output
# when rc.inet1 is called directly.
DEBUG_ETH_UP="no"

## Example config information for wlan0.  Uncomment the lines you need and fill
## in your info.  (You may not need all of these for your wireless network)
IFNAME[4]="ath0"
IPADDR[4]="www.xxx.yyy.zzz"
NETMASK[4]="www.xxx.yyy.zzz"
Or comment out the DHCP stuff to use a dynamic IP instead...

Last edited by Alstare; 05-07-2008 at 11:15 PM.
 
Old 05-07-2008, 11:06 PM   #11
Alstare
Member
 
Registered: Jul 2003
Distribution: Slackware
Posts: 79

Rep: Reputation: 15
Also in your "rc.wireless.conf" file you could try the <catch all> setting to test for simplicity sake, althought by the output of your "iwconfig" your card is associating with the ESSID correctly from your input in the "rc.wireless.conf" file.

Code:
## --------- START SECTION TO REMOVE -----------
# Pick up any Access Point, should work on most 802.11 cards
*)
    INFO="Shepnet"
    ESSID="shepnet"
    ;;
## ---------- END SECTION TO REMOVE ------------

Last edited by Alstare; 05-07-2008 at 11:17 PM.
 
Old 05-08-2008, 01:07 AM   #12
shepper
Member
 
Registered: Mar 2003
Location: Dry, Dusty and Conservative
Distribution: OpenBSD, Debian Wheezy/Jessie
Posts: 449

Original Poster
Rep: Reputation: 33
Alstare

Thanks for the reply. My configs were to use dhcp but they did not automatically obtain the address. Later on in the log I posted I ran dhcpcd manually and did get an IP (192.168.1.7) but it would not ping google or my wireless router (192.168.1.1)

I just finished trying Windows and it does run so I have ruled out a hardware issue. Of course putting windows on blew away my Slackware install so I will have to reinstall after some more research.

Of the many things I tried an updated kernel as my dmesg would always show a memory leak and a disable IRQ. Kernel 2.6.25.2 now has an atheros driver (ath5k) that is supposed to be 100% FOSS.
 
Old 05-08-2008, 02:41 AM   #13
Alstare
Member
 
Registered: Jul 2003
Distribution: Slackware
Posts: 79

Rep: Reputation: 15
If you wanted to use DHCP to automatically configure your IP for your wireless, you will have to uncomment the DHCP related lines to make them work.

The "rc.inet1.conf" you posted still had them commented <# in front of the line> so that would definitly cause an issue with it trying to get an IP automatically.

When you ran DHCPD manually it gave you an IP which is good news, but I suspect your connection problems still were partially attributed to having no gateway listed in the "rc.inet1.conf" file, as I am not sure if that gets updated via dhcp.

So I'd suggest when you get your machine back up and running, un-comment the dhcp lines and add a gateway IP to the "rc.inet1.conf" file. And configure the "rc.wireless.conf" file as you had it as it seemed ok and was getting an essid.

You also may want to temporarily disable the encryption on your router well trying to get everything working, might help rule out some connection and IP problems.

Good luck and have fun.
 
Old 05-08-2008, 02:44 AM   #14
Alstare
Member
 
Registered: Jul 2003
Distribution: Slackware
Posts: 79

Rep: Reputation: 15
Ooops, double post...

Last edited by Alstare; 05-08-2008 at 02:47 AM.
 
Old 05-08-2008, 10:08 PM   #15
shepper
Member
 
Registered: Mar 2003
Location: Dry, Dusty and Conservative
Distribution: OpenBSD, Debian Wheezy/Jessie
Posts: 449

Original Poster
Rep: Reputation: 33
Thanks Alstare

The second time around I left everything stock with the generic-smp kernel and got the wireless connection up before doing anything else.

The Via C7 processor is relatively new and my unfamiliarity with it may have been part of the problem. I have some older C3 systems that ran great with a C3 stripped and optimized kernel. I remember reading somewhere in the Documentation that an SMP kernel is recommended even for non-smp processors as some devices may require it. Previously madwifi ran fine on my non-SMP C3 systems.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Wireless can't get an IP Atheros AR5005G chip madwifi Slack 12.0 acummings Slackware 2 01-16-2008 02:45 AM
LXer: CES 2008: Everex Cloudbook UMPC and Gbook Laptop LXer Syndicated Linux News 0 01-11-2008 01:41 AM
Wifi Atheros 54 slack mirto Slackware 5 11-23-2005 05:34 AM
intel wireless pro 2200 detected as atheros wireless card? whf Suse/Novell 5 08-29-2005 07:04 PM
Slack, Atheros, and Hell. sclebo05 Linux - Wireless Networking 4 03-25-2004 02:15 AM


All times are GMT -5. The time now is 04:16 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration