LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 06-08-2007, 08:14 PM   #1
dayers
LQ Newbie
 
Registered: Jun 2007
Posts: 9

Rep: Reputation: 0
Slack 11.0 mouse config


I am dual-booting Slack 11.0 on a ThinkPad T42P. My mouse is a Microsoft Wheel Mouse Optical USB. I've tried USB mouse, PS/2 and Microsoft PS/2 without success. What should go in xorg.conf?

Thanks for your help.

Dave
 
Old 06-08-2007, 09:16 PM   #2
Old_Fogie
Senior Member
 
Registered: Mar 2006
Distribution: SLACKWARE 4TW! =D
Posts: 1,515

Rep: Reputation: 62
Can you post your kernel version & your /etc/X11/xorg.conf file .
 
Old 06-09-2007, 12:29 PM   #3
tronayne
Senior Member
 
Registered: Oct 2003
Location: Northeastern Michigan, where Carhartt is a Designer Label
Distribution: Slackware 32- & 64-bit Stable
Posts: 3,074

Rep: Reputation: 777Reputation: 777Reputation: 777Reputation: 777Reputation: 777Reputation: 777Reputation: 777
In the mouse InputDevice section, try:
Code:
Section "InputDevice"
        Identifier  "Mouse0"
        Driver      "mouse"
        Option      "Protocol" "IMPS/2"
        Option      "Device" "/dev/mouse"
        Option      "ZAxisMapping" "4 5 6 7"
EndSection
You really only need "4 5" in the ZAxisMapping; mine gets configured with "4 5 6 7" by the ATI configuration (and it works just fine).

Also, be sure to check what /dev/mouse is pointing at - it should, with a USB mouse,look like this:
Code:
ls -al /dev/mouse
lrwxrwxrwx 1 root root 10 2007-06-09 08:44 /dev/mouse -> input/mice
Be sure to stop and restart X when you change things.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
LILO config for Slack 10.0 and XP Permaximus Linux - General 15 08-20-2005 10:10 PM
Slack 10 network config ronanio Linux - Networking 1 09-13-2004 05:27 PM
dhcp config help on slack 9.1 (default) sqn Slackware 5 05-07-2004 06:09 AM
Debian install use .config from slack? powadha Debian 2 01-28-2004 06:56 AM
slack 8.1 config question slacking Slackware 1 11-29-2002 03:47 AM


All times are GMT -5. The time now is 12:39 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration