LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices



Reply
 
Search this Thread
Old 04-09-2007, 06:46 PM   #1
Van Der Berg
LQ Newbie
 
Registered: May 2006
Posts: 11

Rep: Reputation: 0
Slack 11.0 & Laptop & USB stick


hi everyone!

i am kinda linux novice that just enjoys playing with distributions. i have tried a dozens of linux distributions, but it seems that
i always return to good old slackware. a few days ago i have downloaded the slackware 11.0, installed it, compiled a 2.6.18 kernel with usb support, and everything is working just fine except that linux won't recognise my USB stick!

i have a usb mouse and kernel don't have any problems using it (well, it did have problems before i enabled support for usb hotplug (or something like that ) in kernel), but i just don't know how to mount USB stick! on previous versions, on desktops, i would just enter

mount -t vfat /dev/sda1 /mnt/usb

and everything worked just fine. but now, when i enter that, it says something like '/dev/sda1 is not known'.

so, how can i find out which is the device for my USB stick and how can i fix that linux automatically mount USB stick when i insert one.

just to mention, i have a HP ZV6000 laptop, 4 usb ports, on one is usb mouse that is working just fine!

and big salutation to all slack fans!
 
Old 04-09-2007, 06:55 PM   #2
erklaerbaer
Member
 
Registered: Mar 2006
Posts: 381

Rep: Reputation: 30
you'll need support for scsi devices, usb storage and a host controller(uhci/ohci + ehci for usb2.0) in your kernel.

why don't you just use the 2.6.17.13 kernel, that shipped with slackware?
 
Old 04-09-2007, 07:22 PM   #3
Nem
Member
 
Registered: Mar 2007
Location: United States
Distribution: Slackware 11.0
Posts: 88

Rep: Reputation: 15
You can try run command tail -f /var/log/messages
and dmesg when you plug in your usb stick.

Make sure you have a usb line in your /etc/fstab
file.
Code:
/dev/sda1       /mnt/memory        auto            users,rw        0       0
You can then just mount the usb with kdiskfree
if you're using KDE.
I cna mount it too through command line
like this
Code:
mount -t vfat /dev/sda1 /mnt/memory]
 
Old 04-09-2007, 07:53 PM   #4
GamerX
Member
 
Registered: Nov 2006
Location: Vancouver, BC
Distribution: Slackware
Posts: 102

Rep: Reputation: Disabled
I compiled 2.6.18.8 kernel and it works fine with my USB stick, here's a few things to make live easier:
Device Drivers -> USB Support and include:
- USB device filesystem
- USB Mass Storage support

Device Drivers -> SCSI device support -> SCSI disk support
When you format your USB drive probably want to make it FAT16, this way you can read it on pretty much any OS and add a label to it! This helps you ion the following way, when you add SCSI disks they will become sda, sdb, sdc, etc... it only depends on the order they were plugged in/discovered by the system. When you label a disk you get the following handle to the corresponding device:
/dev/disks/by-label/FAT16-LABEL
so then you can something like this in fstab:
Code:
/dev/disk/by-label/USB-ARC01    /media/archive01        ntfs            defaults,umask=222,ro   1       3
/dev/disk/by-label/SERGE-USB01  /media/serge-usb01      vfat            defaults,user,dev,exec  1       3
the 1st one is an external USB HDD and the second one is my USB stick and no matter which way they are plugged in they get mounted to the expected place =)

To label FAT partitions you will need to install the package dosfstools, available in slackware's repository.

EDIT: O and don't forget to include the appropriate file system in the kernel =)

Last edited by GamerX; 04-09-2007 at 07:58 PM.
 
Old 04-10-2007, 03:40 AM   #5
Van Der Berg
LQ Newbie
 
Registered: May 2006
Posts: 11

Original Poster
Rep: Reputation: 0
ouch, i have probably forgot to add a SCSI disk support in kernel, i'll try that...
btw, kernel 2.6.18 also comes with slack 11.0, on testing directiry...that is where i have installed it from
 
Old 04-10-2007, 08:28 AM   #6
Van Der Berg
LQ Newbie
 
Registered: May 2006
Posts: 11

Original Poster
Rep: Reputation: 0
no, it's not that...scsi support is enabled, also a support for usb mass storage, but still
when i try to mount it, it says
'sda1 block device doesn't exist'
 
Old 04-10-2007, 08:30 AM   #7
Van Der Berg
LQ Newbie
 
Registered: May 2006
Posts: 11

Original Poster
Rep: Reputation: 0
when i enter 'tail -f /var/log/messages', if i insert usb disk, it says
'usb 1-4 : new high speed USB device using ehci_hcd and adress 4'
'usb 1-4 : configuration #1 chosen from 1 choice'

but where is it?
 
Old 04-10-2007, 12:37 PM   #8
GamerX
Member
 
Registered: Nov 2006
Location: Vancouver, BC
Distribution: Slackware
Posts: 102

Rep: Reputation: Disabled
My /var/log/messages says so
Code:
Apr 10 09:31:05 sm-linux kernel: usb 1-3: new high speed USB device using ehci_hcd and address 3
Apr 10 09:31:06 sm-linux kernel: usb 1-3: configuration #1 chosen from 1 choice
Apr 10 09:31:06 sm-linux kernel: scsi0 : SCSI emulation for USB Mass Storage devices
Apr 10 09:31:11 sm-linux kernel:   Vendor: OCZ       Model: ET1208AD          Rev: 1.0 
Apr 10 09:31:11 sm-linux kernel:   Type:   Direct-Access                      ANSI SCSI revision: 02
Apr 10 09:31:11 sm-linux kernel: SCSI device sda: 4095999 512-byte hdwr sectors (2097 MB)
Apr 10 09:31:11 sm-linux kernel: sda: Write Protect is off
Apr 10 09:31:11 sm-linux kernel: SCSI device sda: 4095999 512-byte hdwr sectors (2097 MB)
Apr 10 09:31:11 sm-linux kernel: sda: Write Protect is off
Apr 10 09:31:11 sm-linux kernel:  sda: sda1
Apr 10 09:31:11 sm-linux kernel: sd 0:0:0:0: Attached scsi removable disk sda
Apr 10 09:31:11 sm-linux kernel: sd 0:0:0:0: Attached scsi generic sg0 type 0
Probably you need SCSI emulation enabled as well (under Device Drivers -> ATA/ATAPI/MFM/RLL support)

Last edited by GamerX; 04-10-2007 at 12:39 PM.
 
Old 04-10-2007, 04:00 PM   #9
pitachok
LQ Newbie
 
Registered: Sep 2006
Distribution: Slackware
Posts: 10

Rep: Reputation: 0
Since you are using laptop and 2.6 kernel that supports scsi, your system(s) on the hard drive must be mounted as sda* (at least it is so on my laptop). In this case the usb devices are mounted on /dev/uba1 and /dev/ubb1 (I have 2 usb ports).
In addition when you insert flash disk, for example, the dmesg can show you the name of the device. So, I'd suggest you to try
mount /dev/uba1 /mnt/...
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
SD card & USB stick format chaos JohnKFT Slackware 5 10-04-2006 07:31 PM
USB Stick = no mount & errors fogcat Suse/Novell 1 02-27-2006 04:06 AM
MDK 2005LE & Freecom DVB-T USB Stick slothpuck Linux - Hardware 0 11-23-2005 05:45 PM
Phục hồi dữ liệu bị mất???, cứ pollsite General 1 06-27-2005 01:39 PM
Mandrake 9.1/IOGear ION External USB 2.0 hdd && Laptop LCD Display Prismatic Linux - Hardware 8 02-09-2004 09:17 PM


All times are GMT -5. The time now is 07:08 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration