LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 01-14-2006, 10:26 AM   #1
techentral
LQ Newbie
 
Registered: Jan 2006
Posts: 10

Rep: Reputation: 0
Question slack 10.2 install ..missing things like ping,ifconfig


hello folks:
I have just installed Slack 10.2 with its 2.4.31 kernel. I haven't did any changes to the kernel as of yet.
Trying to setup network cards. The system don't seem to have stuff I am used to like ifconfig, ping, netconfig. As "root" get command not found when i try to run them. I looked in their respective directories, used "locate" and "which" even looked manually for them and their not to be found anywhere. My 5 yr old linux box and distros had them. Is the copy of this distro I have broken or have there been changes I cant seem to find out about. I admit I am a bit rusty. HELP PLEASE??
 
Old 01-14-2006, 10:42 AM   #2
cwwilson721
Senior Member
 
Registered: Dec 2004
Location: In my house.
Distribution: Ubuntu 10.10 64bit, Slackware 13.1 64-bit
Posts: 2,649
Blog Entries: 1

Rep: Reputation: 65
Sounds more like the net package didnot install. try to reinstall it with pkgtool (I don't remember what the package letter is, a little help?)
 
Old 01-14-2006, 10:42 AM   #3
Alien Bob
Slackware Contributor
 
Registered: Sep 2005
Location: Eindhoven, The Netherlands
Distribution: Slackware
Posts: 5,270

Rep: Reputation: Disabled
This sounds like you did not install the tcpip package.
This package is located in the "n" directory.

Eric
 
Old 01-14-2006, 11:20 AM   #4
techentral
LQ Newbie
 
Registered: Jan 2006
Posts: 10

Original Poster
Rep: Reputation: 0
Unhappy thanks for the fast response

if it was ONLY that easy .. covered all the basics already.. bit nic are being recognized during boot ..Eth0 and Eth1 .. i have tried ifconfig as root ..even did su- from root and tried .. still no ifconfig. N package has been reinstall completely to be sure also. any other ideas..start clean with an new copy of the distro? maybe??
 
Old 01-14-2006, 02:59 PM   #5
btmiller
Senior Member
 
Registered: May 2004
Location: In the DC 'burbs
Distribution: Arch, Scientific Linux, Debian, Ubuntu
Posts: 4,118

Rep: Reputation: 315Reputation: 315Reputation: 315Reputation: 315
The ifconfig binary is usually in /sbin -- can you do "ls -l /sbin/ifconfig" to verify that it is indeed missing?
 
Old 01-14-2006, 08:32 PM   #6
techentral
LQ Newbie
 
Registered: Jan 2006
Posts: 10

Original Poster
Rep: Reputation: 0
like i have said up there ^^^^ its not there ..this copy must be broken .. getting other copy distro 10.0 see if its there when i install

Last edited by techentral; 01-14-2006 at 08:34 PM.
 
Old 01-14-2006, 09:31 PM   #7
techentral
LQ Newbie
 
Registered: Jan 2006
Posts: 10

Original Poster
Rep: Reputation: 0
I will also add that i was not prompted for any network information duing the install of the 10.2 distro .. It must be very broken.. thanks for the help ppl
 
Old 01-15-2006, 03:38 AM   #8
gbonvehi
Senior Member
 
Registered: Jun 2004
Location: Argentina (SR, LP)
Distribution: Slackware
Posts: 3,145

Rep: Reputation: 51
When you need to find a file or package: http://slackware.it/en/pb/
In this case, you need: http://slackware.it/en/pb/search.php...t=2&q=ifconfig
 
Old 01-15-2006, 10:58 AM   #9
techentral
LQ Newbie
 
Registered: Jan 2006
Posts: 10

Original Poster
Rep: Reputation: 0
success at last

thanks for the links ..I have managed to install distro 10.0 and all seems normal so far.. 4 partition delete sessions later.. got to love slackware .. perhaps i will try 10.2 again using an iso this time.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
ifconfig missing Acronyms Linux - Networking 3 04-15-2005 07:16 AM
using ping and ifconfig in C program Menestrel Programming 2 12-20-2004 08:52 AM
NTLDR missing after slack install ? e1000 Slackware 6 09-27-2004 12:06 AM
ifconfig is missing Zvi Linux - Software 3 12-10-2003 12:56 PM
ifconfig missing?? MCSquared Linux - Networking 12 02-21-2003 03:42 PM


All times are GMT -5. The time now is 06:10 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration