LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
LinkBack Search this Thread
Old 02-08-2005, 06:36 PM   #1
light_QQ
LQ Newbie
 
Registered: Sep 2004
Distribution: Slackware 10.0 K 2.6.8.1
Posts: 16

Rep: Reputation: 0
Slack 10.1 K2.6.10 ALSA


Hi there fellow Slackers.

I spent an entire night upgrading to Slack 10.1, and using the kernel 2.6.10 that came on the second CD (I did a make menuconfig on my old 2.6.8.1 .config).

All seems to work ok, but I have some ALSA weirdness. First of all, ALSA Works! I can play Mp3's listen to sound...use alsamixer however ...

If I login as root, and do a 'startx' (with no .gn* / .gc* folders) - I get a OAFIDD:GNOME_MixerApplet error. Now if i login as 'light' my normal user (I did a home directory transplant so all my gnome settings were saved over) the volume control thing is there, but changing the volume has no effect and right click -> properties returns :

ERROR : Sorry, no mixer elements and or devices found

:CRY:

I've tried altering the permissions of /dev/dsp etc so I don't think its that. My Alsa support is all built into the kernel (so no modules at all). Alsaconf does not detect my soundcard for some reason ?


1:21PM UPDATE : RE INSTALLED ALSA PACKAGES -> ALSACONF NOW WORKS, GNOME APPLET STILL FAULTY THOUGH :-(

If I can just sort out this problem I'll be a happy bunny and will be able to continue configruing my machine, but this is really bugging me and I just can't seem to get to the route of it.

Light

Last edited by light_QQ; 02-08-2005 at 07:22 PM.
 
Old 02-08-2005, 08:36 PM   #2
ruidh
LQ Newbie
 
Registered: Jan 2005
Posts: 24

Rep: Reputation: 15
FWIW, I have the same problem with Slack 10.0 and kernel 2.6.7. Sound does work and I can adjust volume levels with alsamixer. The Gnome panel applet reports no mixer elements and/or devices found. But there does exist a /dev/mixer simlinked to /dev/sound/mixer. Permissions are appropriate so that the user should be able to set the volume. Indeed, I can set the volume with alsamixer.
 
Old 02-08-2005, 10:34 PM   #3
killerbob
Member
 
Registered: Oct 2004
Location: Ottawa, ON
Distribution: Slackware
Posts: 662

Rep: Reputation: 30
Forgive my ignorance, but was the 2.6.10 kernel on the 2nd CD a precompiled kernel, or was it a source that you compiled on your own? I'm running 10.1 with 2.6.10, but I took the 2.6.10 source off my fileserver and compiled it from scratch. I'm probably not running the same sound card as you are, but FWIW, it seems to be working fine for me. I compiled ALSA in the kernel, with sequencer support, and module support for OSS.

It sounds to me like the ALSA driver that's compiled into the 2.6.10 doesn't have the right mixer for your sound card. What card do you have? And do the volume mixers in other DE's/WM's work properly? (XFCE has its own volume mixer, as does KDE)

Have you tried removing the ALSA packages, and recompiling 1.0.8 from alsa-project.org?
 
Old 02-09-2005, 04:14 AM   #4
light_QQ
LQ Newbie
 
Registered: Sep 2004
Distribution: Slackware 10.0 K 2.6.8.1
Posts: 16

Original Poster
Rep: Reputation: 0
The 2.6.10 kernel is actually a package on the 2nd CD (no idea why), but it seemed to build and run within /usr/src/linux-2.6.10/
I think this is a gnome problem, but I'm not sure.. I tried aux/amux? which is a different mixer and that worked fine. Alsamixer works fine, and XMMS / MP3's play fine. OSS support as modules.. why not inbuilt support - isn't that something that will be constantly used ?

Haven't tried recompiling alsa - though as far as I'm concerned this is a gnome problem...

Last edited by light_QQ; 02-09-2005 at 04:22 AM.
 
Old 02-09-2005, 09:24 AM   #5
killerbob
Member
 
Registered: Oct 2004
Location: Ottawa, ON
Distribution: Slackware
Posts: 662

Rep: Reputation: 30
It might not be a gnome problem, is the thing. Just because alsamixer works doesn't mean you're going to have sound. You might have all channels muted in alsamixer, or you might have a bad driver in alsa. My desktop computer has an SB Live! 24-bit, and I'm too lazy to get sound working, because it's dualbooting in Windows and I use Win for gaming on the weekends. However, alsamixer claims it should be working properly. In my case, that's an alsa problem, even though alsamixer "works".

The only way to be certain that it's a gnome problem is to try a different mixer in a different DE. If gnome is running, it could mess up your results. GDM lets you choose which DE to use for this session, so you might want to set the default runlevel to 4 for this experiment.



As for OSS, theoretically you won't need it at all under most circumstances. My mother's computer was the only one I ever saw that actually required OSS support: her soundcard is a C-Media 8738. (As an aside, she didn't even notice that I had installed Linux/KDE, except to thank me for adding more games, and ask what I did to stop it from crashing....) When I compiled the 1.0.8 alsa driver, it gakked, telling me to enable OSS in the kernel.
 
Old 02-09-2005, 09:38 AM   #6
light_QQ
LQ Newbie
 
Registered: Sep 2004
Distribution: Slackware 10.0 K 2.6.8.1
Posts: 16

Original Poster
Rep: Reputation: 0
What we were referring to was OSS compatibility, not OSS. People keep getting these confused. Alsa has some OSS back compatibility code which allows old OSS stuff to use new ALSA stuff.

As I said, alsamixer, mp3's aumix etc works perfectly.. I have no reason to think that my sound is at fault, clearly Gnome is not managing to access the mixer, despite the fact that 'alsamixer' can. I suppose I could try some different ALSA packages, or even compile it from source, but frankly it's a gnome 2.6 problem and I see many people have come up against this problem when upgrading to it.

Type in OAFIID:GNOME_Mixer-Applet in google

Thanks for the advice though, but I'm confident that the problem lies with gnome rather than alsa, as I've tried a separate mixer under gnome (aumix), alsamixer, mp3's run fine, aplay runs fine, Quake3 sound works .. everything ALSA works.. but GNOME_MIXER_APPLET does not work.. problem...

GNOME 2.6 -> Mixer APPLET...

I think...
 
Old 02-09-2005, 11:11 AM   #7
light_QQ
LQ Newbie
 
Registered: Sep 2004
Distribution: Slackware 10.0 K 2.6.8.1
Posts: 16

Original Poster
Rep: Reputation: 0
Surely someone can suggest trying something ?
 
Old 02-09-2005, 11:31 AM   #8
egag
Senior Member
 
Registered: Jul 2004
Location: Netherlands
Distribution: Slackware
Posts: 2,721

Rep: Reputation: 52
well....the 2.6.10 kernel doesn't make all /dev-devices at startup.
maybe try to run " /etc/rc.d/rc.udev "; that will make all nodes ( here... )

egag
 
Old 02-09-2005, 07:48 PM   #9
Danus ex
LQ Newbie
 
Registered: Oct 2004
Location: Ramsey, Minnesota
Distribution: Slackware 10.1
Posts: 16

Rep: Reputation: 0
You guys with problems haven't said what sound card you're running!

I spent a lot of time dealing with similar problems on my machine. I would uninstall all the ALSA packages and make my own, and still have trouble. I even had three different ALSA 1.0.8 driver packages installed at one point (generic 2.4.29, generic 2.6.10, compiled/checkinstalled package) in hope of getting some sound.

But, of course, I was being an idiot. I run an Audigy 2, and if you guys are, follow along. The real problem was something I spotted only in KMix. Under the 'Switches' tab, you'll see a switch marked 'Audigy Analog'. Turn it on for sound!

I also remembered in the Windows installation that the Audigy series defaults to digital output, and you have to specify analog in the setup.
 
Old 02-09-2005, 10:11 PM   #10
ruidh
LQ Newbie
 
Registered: Jan 2005
Posts: 24

Rep: Reputation: 15
Quote:
Originally posted by Danus ex
You guys with problems haven't said what sound card you're running!
I think you're misunderstanding the problem. We have sound. We can adjust the volume with alsamixer. We just can't adjust the volume with the Gnome volume control applet.

I may have to resort to stracing the applet executable to see what it's trying when it reports it can't find a /dev file.
 
Old 02-10-2005, 05:22 AM   #11
light_QQ
LQ Newbie
 
Registered: Sep 2004
Distribution: Slackware 10.0 K 2.6.8.1
Posts: 16

Original Poster
Rep: Reputation: 0
Yes indeed.

This is a GNOME problem. I have tried XFCE (very nice btw - very simple and polished looking! - under slackware type xwmconfig to try it), then startx......

Mixer in XFCE works perfectly.
 
Old 02-10-2005, 08:19 AM   #12
noxious
Member
 
Registered: May 2004
Location: Ohio, USA
Distribution: LinuxMint Gloria, Ubuntu 9.10
Posts: 299

Rep: Reputation: 30
The gnome mixer, under a root login, is hosed. I've been deleting it and adding kmix to the menu bar in it's place - works great!

I just wish the display manager after a root login wasn't broken (still!).
 
Old 02-10-2005, 12:40 PM   #13
light_QQ
LQ Newbie
 
Registered: Sep 2004
Distribution: Slackware 10.0 K 2.6.8.1
Posts: 16

Original Poster
Rep: Reputation: 0
To be honest, it's pathetic.
 
Old 02-13-2005, 10:59 AM   #14
slipperynips
LQ Newbie
 
Registered: Feb 2005
Location: NY
Posts: 1

Rep: Reputation: 0
I am suffering the exact same issue. (When I log in as root ((root only))and startx I get the error message: OAFIID:GNOME_MixerApplet encountered a problem while loading.

Hardware: NForce 2 MB w/ onboard sound ((Biostar M7NCD))
SW: Slackware 10.1 Default Kernel

When I log on as another user all is well only root is hosed.
 
Old 02-13-2005, 04:36 PM   #15
light_QQ
LQ Newbie
 
Registered: Sep 2004
Distribution: Slackware 10.0 K 2.6.8.1
Posts: 16

Original Poster
Rep: Reputation: 0
Well I definately recommend trying XFCE - I kina realised I didn't use a lot of the features in GNOME (and the features that were there seemed a bit bloaty, error prone and arbitary.. (like the menu system seems so crazy).

To do this simply logout of X, type :

&xwmconfig
Select XFCE
&startx

If you don't like it, repeat the process and re-select gnome.

TO me XFCE seems simple, nice and things seem really polished !
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
slack 10 +alsa kosmos Slackware 10 02-04-2005 06:33 PM
Slack 10, kernel 2.6.7, alsa (1.0.7) SocialEngineer Linux - Hardware 6 01-06-2005 07:04 PM
Slack 9.1 and alsa errors cholzsc1 Linux - Hardware 1 03-01-2004 06:28 PM
Slack 9.1, ALSA 0.9.6 and ALSA 0.9.7 MsMittens Slackware 17 10-16-2003 04:00 AM
alsa for slack 9 //alias Slackware 1 05-24-2003 09:52 AM


All times are GMT -5. The time now is 11:04 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration