LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices



Reply
 
Search this Thread
Old 04-30-2010, 10:24 AM   #1
kris108
Member
 
Registered: Sep 2009
Distribution: Slackware
Posts: 32

Rep: Reputation: 2
Skype versions and webcam support in CURRENT


I failed to get webcam support on CURRENT with Skype version 2.1.0.81, Skype did not see the device at all (using libv4l).

Downgraded Skype to version 2.0.0.72 and webcam works well. I have not much idea what might be the reason.

I hope the information will be useful for others.

Regards

kris *_^O^_*
 
Old 04-30-2010, 12:31 PM   #2
marrowsuck
Member
 
Registered: Sep 2006
Posts: 84

Rep: Reputation: 25
You could try
Code:
LD_PRELOAD=/usr/lib/libv4l/v4l1compat.so skype
since skype has some issues with v4l2 and certain webcam drivers.

Last edited by marrowsuck; 04-30-2010 at 12:38 PM.
 
Old 05-01-2010, 12:09 AM   #3
kris108
Member
 
Registered: Sep 2009
Distribution: Slackware
Posts: 32

Original Poster
Rep: Reputation: 2
marrowsuck,

I wrote above:

Quote:
Skype version 2.1.0.81, Skype did not see the device at all (using libv4l).
Skype was well configured in both cases.
 
Old 05-01-2010, 06:21 AM   #4
willysr
Senior Member
 
Registered: Jul 2004
Location: Jogja, Indonesia
Distribution: Slackware-Current
Posts: 2,630

Rep: Reputation: 449Reputation: 449Reputation: 449Reputation: 449Reputation: 449
i believe this is due to changes in libpng or libjpeg
 
Old 05-01-2010, 01:26 PM   #5
kris108
Member
 
Registered: Sep 2009
Distribution: Slackware
Posts: 32

Original Poster
Rep: Reputation: 2
Quote:
Originally Posted by willysr View Post
i believe this is due to changes in libpng or libjpeg
willysr,

by all respect, how should I "say" it better, there was NO /dev/video0 in Skype 2.1.0.81. It is not so that I did not get an output from the device as there was no device. I did not reconfigure the system, just downgraded to Skype 2.0.0.72. which solved the problem.
I was hoping to be able to write it down in one post only ;-)
 
Old 05-01-2010, 03:02 PM   #6
marrowsuck
Member
 
Registered: Sep 2006
Posts: 84

Rep: Reputation: 25
You should be a little more communicative about your specific problem, otherwise you only get general advice.
What type of webcam, which driver, which kernel...

To clarify my previous post:
If you are using a "current"-kernel with video4linux2 and your webcam uses that API, then you could try to use an v4l1 abstraction layer via

LD_PRELOAD=/usr/lib/libv4l/v4l1compat.so skype
 
0 members found this post helpful.
Old 05-01-2010, 08:56 PM   #7
kris108
Member
 
Registered: Sep 2009
Distribution: Slackware
Posts: 32

Original Poster
Rep: Reputation: 2
Quote:
Originally Posted by marrowsuck View Post
You should be a little more communicative about your specific problem
Ok, sorry. My fault. More communicative than: I do not have a problem and did not meant to request help how to configure the system. In this case either CURRENT has a problem or Skype.

The kernel is 2.6.33.2, the webcam is Philips SPC 200NC using video4linux2.

I did setup skype by renaming the skype to skype.bin and replace it with a script:
Code:
!#bin/bash
LD_PRELOAD=/usr/lib/libv4l/v4l1compat.so skype.bin
exit
On the webcam config page of Skype 2.1.0.81. it stated that there are no webcams at all (I also tried without v4l1compat.so), downgrading Skype to 2.0.0.72 solved my problem :-)

Sorry for the misunderstanding.
 
Old 05-02-2010, 05:56 AM   #8
marrowsuck
Member
 
Registered: Sep 2006
Posts: 84

Rep: Reputation: 25
Googleing
"Philips SPC 200NC" linux skype
turned up this link first

http://forum.skype.com/topic/561971-...nc-ubuntu-910/

Same skype and webcam and same v4l1compat-advice but different kernel and distribution and with happy end.

Last edited by marrowsuck; 05-02-2010 at 06:26 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Skype no video from webcam lunardragon Linux - Software 6 05-13-2012 04:29 PM
Webcam and Skype moshebagelfresser Linux - Hardware 5 04-11-2010 03:23 PM
CrystalEye webcam on Skype Jimage Linux - Hardware 2 07-22-2009 10:50 AM
Skype problem on webcam yuchankit Slackware 26 06-22-2009 10:44 AM
Which webcam for linux and skype ? zghh Linux - Hardware 1 04-13-2008 02:33 PM


All times are GMT -5. The time now is 02:22 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration