LinuxQuestions.org
Did you know LQ has a Linux Hardware Compatibility List?
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 05-29-2013, 04:31 AM   #1
ChrisAbela
Member
 
Registered: Mar 2008
Location: Malta
Distribution: Slackware 14.1
Posts: 467

Rep: Reputation: 87
Skype Segmentation Fault


I have a shiny new Slackware64-current installation. I simply created my own DVD ISO image with a mirror-slackware-current.sh script by Eric Hameleers. I also have full multilib packages also from Eric Hameleers http://slackware.com/~alien/multilib/current/

Traditionally I run Slackware32 stable with no issues but bad company (actually a friend who claims to boot Fedora in seconds), and a new UEFI laptop with a 20GB SSD drive and a mysterious wifi problem intrigued me to meddle with the darker flavors of Slack. I am fully aware that SlackBuilds are only tested on stable and Skype runs only only on 32bit installations, but thanks to Alien Bob's multilib I even run google-earth without any problems, so I was optimistic.

Back to my problem, this is all I can submit:

Quote:
chris@acer:~$ skype
Segmentation fault
chris@acer:~$
As I happened to have built skype from slackbuilds.org, I contacted the maintainer of the script who promptly replied that he runs it on Slack64-current + multilib without any issues and there is nothing to it.

Any suggestions would be welcome.

Last edited by ChrisAbela; 05-29-2013 at 04:35 AM.
 
Old 05-29-2013, 06:07 AM   #2
Bindestreck
Member
 
Registered: Jul 2011
Location: Sweden
Distribution: Slackware
Posts: 288

Rep: Reputation: 51
Quote:
Originally Posted by ChrisAbela View Post
I have a shiny new Slackware64-current installation. I simply created my own DVD ISO image with a mirror-slackware-current.sh script by Eric Hameleers. I also have full multilib packages also from Eric Hameleers http://slackware.com/~alien/multilib/current/

Traditionally I run Slackware32 stable with no issues but bad company (actually a friend who claims to boot Fedora in seconds), and a new UEFI laptop with a 20GB SSD drive and a mysterious wifi problem intrigued me to meddle with the darker flavors of Slack. I am fully aware that SlackBuilds are only tested on stable and Skype runs only only on 32bit installations, but thanks to Alien Bob's multilib I even run google-earth without any problems, so I was optimistic.

Back to my problem, this is all I can submit:



As I happened to have built skype from slackbuilds.org, I contacted the maintainer of the script who promptly replied that he runs it on Slack64-current + multilib without any issues and there is nothing to it.

Any suggestions would be welcome.
I also had that problem with the Skype version from SlackBuild. The solution was to use a newer version (4.2.0.11) from Skype's website.
 
1 members found this post helpful.
Old 05-29-2013, 07:04 AM   #3
Alien Bob
Slackware Contributor
 
Registered: Sep 2005
Location: Eindhoven, The Netherlands
Distribution: Slackware
Posts: 5,223

Rep: Reputation: Disabled
Same here. The newest release of Skype fixed the segfaults.

Eric
 
1 members found this post helpful.
Old 05-30-2013, 07:02 AM   #4
ChrisAbela
Member
 
Registered: Mar 2008
Location: Malta
Distribution: Slackware 14.1
Posts: 467

Original Poster
Rep: Reputation: 87
This is to confirm that updating the source to Version 4.2.0.11 and using the original SlackBuild, skype works on Slackware64-current (with multilib).
Thanks for the help.

Last edited by ChrisAbela; 05-30-2013 at 07:03 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
qt segmentation fault binarybob0001 Programming 1 12-09-2007 01:12 AM
yast segmentation fault, system freezing - nvidia driver at fault? BaltikaTroika Suse/Novell 2 12-02-2005 09:34 AM
Segmentation Fault redhatnoob Linux - Software 3 11-13-2003 02:11 AM
Segmentation fault compjinx Linux - Newbie 4 11-09-2003 04:51 PM
segmentation fault Linh Programming 6 11-03-2003 08:25 AM


All times are GMT -5. The time now is 03:29 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration