LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 06-17-2012, 04:13 PM   #31
zerouno
Member
 
Registered: Oct 2009
Distribution: Slackware
Posts: 268

Rep: Reputation: 80

The symlink is required becouse skype is compiled with libtiff 4 but slackware have libtiff 3.

It's needed only in /usr/lib, not lib64 becouse skype is a 32bit software
 
Old 06-20-2012, 12:39 PM   #32
ryerke
Member
 
Registered: Dec 2006
Location: Fresno CA
Distribution: Slackware 13 Slackware 13.37 ARMEDSlack 13.37
Posts: 89

Rep: Reputation: 21
I missed the entire second page. I meant to update the link but it is updated. Oops
:-)

Last edited by ryerke; 06-20-2012 at 12:45 PM.
 
Old 07-18-2012, 09:32 AM   #33
mats_b_tegner
Member
 
Registered: Nov 2009
Location: Gothenburg, Sweden
Distribution: Slackware64
Posts: 143

Rep: Reputation: 47
Quote:
Originally Posted by zerouno View Post
I tried to build a skype-4.0.0.8 package for latest -current, but the Slackbuild-script halts when it looks for libz.so.1 which is not present in the latest version of the aaa_elflibs-14.0-i486-2 package. How do I modify the script to build for -current?

Edit:
The package builds fine for 13.37.
Noticed this in the -current Changelog:
Mon Mar 26 01:41:11 UTC 2012
l/zlib-1.2.6-i486-1.txz: Upgraded.
Moved shared library to /lib{,64} to prepare for kmod.

Last edited by mats_b_tegner; 07-18-2012 at 10:25 AM.
 
Old 07-19-2012, 11:37 AM   #34
zerouno
Member
 
Registered: Oct 2009
Distribution: Slackware
Posts: 268

Rep: Reputation: 80
Yes. The latest -current breaks a lot of packages and slackbuilds.

Now I've not a stable internet connection, so I cannot fix skype.
However to build skype_static should be sufficient to modify the 'libraries.txt' file.

But now is not the time to fix it, for me, becouse Patrick is fixing and changing continuosly a large number of vital packages, so I should rebuild skype too many time.

However, as you see, the 13.37 packages works. In effect skype_static packages is not called 'static' from the name skype_static.tar.bz2 released by Skype, but from the 32bit libraries included in the package, so the 'skype' binary does not link with any 'system' libraries (in /usr/lib*/).
In effect some people use the 13.37 skype_static package over a 13.1 slackware distribution.
 
1 members found this post helpful.
Old 07-23-2012, 03:38 AM   #35
zerouno
Member
 
Registered: Oct 2009
Distribution: Slackware
Posts: 268

Rep: Reputation: 80
Now aaa_elflibs in current include libz
 
Old 07-23-2012, 05:44 AM   #36
mats_b_tegner
Member
 
Registered: Nov 2009
Location: Gothenburg, Sweden
Distribution: Slackware64
Posts: 143

Rep: Reputation: 47
Quote:
Originally Posted by zerouno View Post
Now aaa_elflibs in current include libz
Sure is, but the libraries.txt file needs to be updated because the SlackBuild-script still halts on -current.
 
Old 07-23-2012, 05:54 AM   #37
willysr
Senior Member
 
Registered: Jul 2004
Location: Jogja, Indonesia
Distribution: Slackware-Current
Posts: 2,553

Rep: Reputation: 424Reputation: 424Reputation: 424Reputation: 424Reputation: 424
is it? my SlackBuild still works on -Current
 
Old 07-23-2012, 06:06 AM   #38
mats_b_tegner
Member
 
Registered: Nov 2009
Location: Gothenburg, Sweden
Distribution: Slackware64
Posts: 143

Rep: Reputation: 47
Quote:
Originally Posted by willysr View Post
is it? my SlackBuild still works on -Current
Yes, but I'll need Zerouno's script to be able to use Skype on Slackware64-current.
 
Old 07-24-2012, 03:57 AM   #39
zerouno
Member
 
Registered: Oct 2009
Distribution: Slackware
Posts: 268

Rep: Reputation: 80
libraries.txt :
Code:
a/aaa_elflibs     libasound.so.2           usr/lib/libasound.so.2
a/aaa_elflibs     libexpat.so.1            usr/lib/libexpat.so.1
a/aaa_elflibs     libfreetype.so.6         usr/lib/libfreetype.so.6
a/aaa_elflibs     libgcc_s.so.1            usr/lib/libgcc_s.so.1
a/aaa_elflibs     libglib-2.0.so.0         usr/lib/libglib-2.0.so.0
a/aaa_elflibs     libgthread-2.0.so.0      usr/lib/libgthread-2.0.so.0
a/aaa_elflibs     libbz2.so.1              lib/libbz2.so.1
a/aaa_elflibs     libz.so.1                lib/libz.so.1
a/aaa_elflibs     libgobject-2.0.so.0      usr/lib/libgobject-2.0.so.0
a/aaa_elflibs     libjpeg.so.8             usr/lib/libjpeg.so.8
a/aaa_elflibs     libtiff.so.4             usr/lib/libtiff.so.3
a/cxxlibs         libstdc++.so.6           usr/lib/libstdc++.so.6
a/glibc-solibs    ld-linux.so.2            lib/incoming/ld-2
a/glibc-solibs    libc.so.6                lib/incoming/libc-2
a/glibc-solibs    libdl.so.2               lib/incoming/libdl-2
a/glibc-solibs    libm.so.6                lib/incoming/libm-2
a/glibc-solibs    libpthread.so.0          lib/incoming/libpthread-2
a/glibc-solibs    librt.so.1               lib/incoming/librt-2
a/glibc-solibs    libnss_compat.so.2       lib/incoming/libnss_compat-2
a/glibc-solibs    libnss_dns.so.2          lib/incoming/libnss_dns-2
a/glibc-solibs    libnss_nis.so.2          lib/incoming/libnss_nis-2
a/glibc-solibs    libnsl.so.1              lib/incoming/libnsl-2
a/glibc-solibs    libnss_files.so.2        lib/incoming/libnss_files-2
a/glibc-solibs    libresolv.so.2           lib/incoming/libresolv-2
a/glibc-solibs    gconv                    usr/lib/gconv/$
a/openssl-solibs  libssl.so.0              lib/libssl.so.0
a/openssl-solibs  libcrypto.so.0           lib/libcrypto.so.0
a/util-linux      libuuid.so.1             lib/libuuid.so.1
x/fontconfig      libfontconfig.so.1       usr/lib/libfontconfig.so.1
x/libICE          libICE.so.6              usr/lib/libICE.so.6
x/libSM           libSM.so.6               usr/lib/libSM.so.6
x/libX11          libX11.so.6              usr/lib/libX11.so.6
x/libXScrnSaver   libXss.so.1              usr/lib/libXss.so.1
x/libXau          libXau.so.6              usr/lib/libXau.so.6
x/libXdmcp        libXdmcp.so.6            usr/lib/libXdmcp.so.6
x/libXext         libXext.so.6             usr/lib/libXext.so.6
x/libXrender      libXrender.so.1          usr/lib/libXrender.so.1
x/libXv           libXv.so.1               usr/lib/libXv.so.1
x/libxcb          libxcb.so.1              usr/lib/libxcb.so.1
x/libXcursor      libXcursor.so.1          usr/lib/libXcursor.so.1
x/libXfixes       libXfixes.so.3           usr/lib/libXfixes.so.3
x/libXinerama     libXinerama.so.1         usr/lib/libXinerama.so.1
x/libXrandr       libXrandr.so.2           usr/lib/libXrandr.so.2
l/libffi          libffi.so.6              usr/lib/libffi.so.6
l/v4l-utils       libv4lconvert.so.0       usr/lib/libv4lconvert.so.0
l/v4l-utils       libv4l1.so.0             usr/lib/libv4l1.so.0
l/v4l-utils       libv4l                   usr/lib/libv4l/$
l/v4l-utils       libv4l2.so.0             usr/lib/libv4l2.so.0
l/qt              plugins                  usr/lib/qt/plugins/$
 
1 members found this post helpful.
Old 07-24-2012, 07:40 AM   #40
mats_b_tegner
Member
 
Registered: Nov 2009
Location: Gothenburg, Sweden
Distribution: Slackware64
Posts: 143

Rep: Reputation: 47
Mille Grazie zerouno. That worked like a charm.
 
Old 07-24-2012, 02:15 PM   #41
persilon
LQ Newbie
 
Registered: Mar 2006
Posts: 1

Rep: Reputation: 0
Cool, thanks !
 
Old 07-25-2012, 04:09 PM   #42
zerouno
Member
 
Registered: Oct 2009
Distribution: Slackware
Posts: 268

Rep: Reputation: 80
Package and slackbuild are moved here:
http://www.z01.eu/repo-slack/slackwa.../skype_static/

the slackbuild is available also under github:
https://github.com/zuno/repo-slack/t...t/skype_static
 
2 members found this post helpful.
Old 08-10-2012, 11:17 PM   #43
zw963
LQ Newbie
 
Registered: Jan 2011
Posts: 12

Rep: Reputation: 0
Thank very much.

I use Slackware13.37 64bit, I use bash-script wrapper skype 2.2 beta before, it work fine..

When i updated to 4.0.0.8 , It have some bother with me, I use ldd command to test, and
wrapper skype with some 32bit lib, so basic..., thus it can run now, but when i input
chinese with input-method, all content is garbled, but if i copy/paste from other place,
it show normally.

i send a post in Skype form, after a week, a guy return my post, point me to here.

Fantastic!! this package is all worked ok. thus I don't know why this input chinese fine.
but i find, linuxquestions.org is slacker heaven, I will return here every day.

Thanks for zerouno again!!
 
Old 08-12-2012, 02:57 AM   #44
zerouno
Member
 
Registered: Oct 2009
Distribution: Slackware
Posts: 268

Rep: Reputation: 80
ldd is not sufficient for detecting all libraries needed used by skype.

To solve the keyboard problems you must to install the qt plugins and gconv libraries. Also you need v4l for some webcam and some other libraries.

In post #39 you can find the full 32bit libraries needed.


All these libraries are included in the package skype_static-4.0.0.8-x86_64-1mt.txz linked in post #42
 
1 members found this post helpful.
Old 08-30-2012, 06:37 AM   #45
zw963
LQ Newbie
 
Registered: Jan 2011
Posts: 12

Rep: Reputation: 0
Quote:
Originally Posted by zerouno View Post
ldd is not sufficient for detecting all libraries needed used by skype.

To solve the keyboard problems you must to install the qt plugins and gconv libraries. Also you need v4l for some webcam and some other libraries.

In post #39 you can find the full 32bit libraries needed.


All these libraries are included in the package skype_static-4.0.0.8-x86_64-1mt.txz linked in post #42
Thanks. I have resolve my Skype problem.

But i still have some other software problem, it about keybinding.
I'm not understood about linux 64bit lib something..
And I have used a Compare software named: Beyond Compare 3,
It is a 32bit software too, and it work OK, except, a situation...
this software allow binding some hotkey with some menu item,
I inputs some hotkey, and it invoke a new compare window,
But this window, all hotkey is not work for me. If I invoke
this window with mouse click in the menu, it work OK again.
I submit a bug to the developer, But they say this situation
is not exist in their version, What i ask is , How lib missing
can cause this problem??
mouse click -> show new window, binding work OK.
hotkey click -> show new window, all binding is not work, Even I
cannot input a char.

Thanks.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Skype for Slackware Konphine Linux - Software 2 07-07-2011 01:25 PM
latest skype Skype 2.2.0.25 and Slackware --current anti_user Slackware 10 04-07-2011 02:22 PM
noise in skype to skype calls in skype v2.1 beta for fedora mq15 Linux - Software 0 01-20-2010 12:04 AM
skype on slackware alexrait1 Slackware 23 04-02-2008 09:29 AM
Skype on Kubuntu 7.04 64bit matuk_444 Ubuntu 3 06-11-2007 02:13 PM


All times are GMT -5. The time now is 03:26 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration