LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
LinkBack Search this Thread
Old 03-31-2013, 09:04 AM   #1
vdemuth
Member
 
Registered: Oct 2003
Location: West Midlands, UK
Distribution: Slackware 14 (Server),Suse 13.1 (Desktop),, Mepis on the wifes lappy
Posts: 760

Rep: Reputation: 90
Since march 23rd update, libreoffice no longer exports embedded spreadsheets to pdf


The title pretty much says it all. Since the current upgrades on the 23rd March and onwards, Libreoffice no longer creates PDFs correctly when the original writer document contains embedded spreadsheets.

What happens is anything in plain text is converted fine, but any embedded spreadsheet just results in a blank area of the page.

Exporting just a spreadsheet is fine, as is just a document. Seems to be when a SS is embedded that the problem shows itself.

Anyone got any ideas where the problem might be?
 
Old 03-31-2013, 09:40 AM   #2
willysr
Senior Member
 
Registered: Jul 2004
Location: Jogja, Indonesia
Distribution: Slackware-Current
Posts: 2,346

Rep: Reputation: 378Reputation: 378Reputation: 378Reputation: 378
Which LibreOffice package do you use? SlackBuild or Eric's LibreOffice package?
 
Old 03-31-2013, 10:04 AM   #3
vdemuth
Member
 
Registered: Oct 2003
Location: West Midlands, UK
Distribution: Slackware 14 (Server),Suse 13.1 (Desktop),, Mepis on the wifes lappy
Posts: 760

Original Poster
Rep: Reputation: 90
Using LibreOffice 4.0.1.2 from Eric
 
Old 03-31-2013, 10:21 AM   #4
willysr
Senior Member
 
Registered: Jul 2004
Location: Jogja, Indonesia
Distribution: Slackware-Current
Posts: 2,346

Rep: Reputation: 378Reputation: 378Reputation: 378Reputation: 378
Can you provide any source document?
i tested creating a new document and spreadsheet, saved both and embed spreadsheet into the document and export to PDF and it's working fine
 
Old 03-31-2013, 10:25 AM   #5
allend
Senior Member
 
Registered: Oct 2003
Location: Melbourne
Distribution: Slackware-current
Posts: 3,288

Rep: Reputation: 802Reputation: 802Reputation: 802Reputation: 802Reputation: 802Reputation: 802Reputation: 802
Just to confirm that I have no problems on Slackware64-current and LibreOffice 4.0.0.3 from Alien_Bob.
 
Old 03-31-2013, 02:38 PM   #6
vdemuth
Member
 
Registered: Oct 2003
Location: West Midlands, UK
Distribution: Slackware 14 (Server),Suse 13.1 (Desktop),, Mepis on the wifes lappy
Posts: 760

Original Poster
Rep: Reputation: 90
Well, don't know what caused that, but re-installing Erics package seemed to have cured it.
 
Old 04-07-2013, 02:07 AM   #7
vdemuth
Member
 
Registered: Oct 2003
Location: West Midlands, UK
Distribution: Slackware 14 (Server),Suse 13.1 (Desktop),, Mepis on the wifes lappy
Posts: 760

Original Poster
Rep: Reputation: 90
Thought this was solved, but turns out it's not.

Unfortunately it's quite intermittent. I can for example, export the same document to pdf multiple times and sometimes it's OK and others it results in the embedded SS not exporting. What's more, there doesn't seem to be any discernable pattern. Anyone any more ideas to try?
 
Old 04-07-2013, 08:53 AM   #8
fskmh
Member
 
Registered: Jun 2002
Location: South Africa
Distribution: Slackware64-current multilib
Posts: 225

Rep: Reputation: 52
I have a spreadsheet here with some embedded graphs and I've just tested it with LO 4.0.2.2 (libreoffice-4.0.2-x86_64-1alien - thanks Alien Bob) and it still works for me when I export to PDF. I also tried exporting PDF to the same file a few times.

Last edited by fskmh; 04-07-2013 at 08:54 AM.
 
Old 04-07-2013, 10:19 AM   #9
vdemuth
Member
 
Registered: Oct 2003
Location: West Midlands, UK
Distribution: Slackware 14 (Server),Suse 13.1 (Desktop),, Mepis on the wifes lappy
Posts: 760

Original Poster
Rep: Reputation: 90
Quote:
Originally Posted by fskmh View Post
I have a spreadsheet here with some embedded graphs and I've just tested it with LO 4.0.2.2 (libreoffice-4.0.2-x86_64-1alien - thanks Alien Bob) and it still works for me when I export to PDF. I also tried exporting PDF to the same file a few times.

Thanks for that, but not really of much assistance.

With respect, I don't need answers from people who have it working, but rather from people who have had the same issue and have found a solution. But thanks anyway.
 
Old 04-07-2013, 10:36 AM   #10
allend
Senior Member
 
Registered: Oct 2003
Location: Melbourne
Distribution: Slackware-current
Posts: 3,288

Rep: Reputation: 802Reputation: 802Reputation: 802Reputation: 802Reputation: 802Reputation: 802Reputation: 802
The thread title is
Quote:
Since march 23rd update, libreoffice no longer exports embedded spreadsheets to pdf
This can be construed as a bug report, so it is legitimate for people to report that they do not see the problem.
There is also a lack of people reporting the same problem.

I believe a better interpretation for you to make of feedback from other people is that something has gone wrong on your system. It is expected that people who run -current will take responsibility for maintaining and fixing their own system. Perhaps you should revert your system to how it was before the problematic upgrade and try again. I assume you have procedures in place to do this.
 
Old 04-07-2013, 10:56 AM   #11
fskmh
Member
 
Registered: Jun 2002
Location: South Africa
Distribution: Slackware64-current multilib
Posts: 225

Rep: Reputation: 52
Quote:
Originally Posted by vdemuth View Post
With respect, I don't need answers from people who have it working, but rather from people who have had the same issue and have found a solution. But thanks anyway.
With respect, my previous post was for the LO packager's benefit, as well as other LO users who are reading your bug report.
 
Old 04-07-2013, 11:11 AM   #12
vdemuth
Member
 
Registered: Oct 2003
Location: West Midlands, UK
Distribution: Slackware 14 (Server),Suse 13.1 (Desktop),, Mepis on the wifes lappy
Posts: 760

Original Poster
Rep: Reputation: 90
If I had wanted it to be seen as a bug report I would have said as much. If the title could be 'construed' as a bug report, then the same could be said of every question posed on here. Or perhaps it's just been misconstrued!!!

Maybe I should start a new thread entitled "How many Slackware users NEVER have a problem?"

Better still, maybe in future people here only ever answer queries by saying everything works for them. That way more helpful and relevant answers will be found.
 
Old 04-09-2013, 08:57 AM   #13
MadMaverick9
Member
 
Registered: Aug 2010
Location: Here
Distribution: Slackware 14.0
Posts: 118

Rep: Reputation: Disabled
Quote:
Can you provide any source document?
As far as I can see you still have not done this.

What you should try doing, is to create a minimal test case, that still shows the problem. And then post that minimal test case here on LQ, so that we can try and see.

If you don't provide a minimal test document (two in your case; ods & odt), that shows the problem, then I am sorry to say, the only answer you will get, is ... It works for me.

If we have no way of re-producing the problem you are seeing, nobody can help you.

Hope this helps.
 
1 members found this post helpful.
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Libreoffice - how can I convert many odt files to doc or pdf automatically? charlemagne-is-my-son Linux - Software 3 12-10-2012 11:32 AM
LXer: PDF import for LibreOffice in Debian Backports is broken -- here's how to fix it LXer Syndicated Linux News 0 12-16-2011 07:20 AM
[SOLVED] LibreOffice unable to print to pdf michalng Debian 2 03-27-2011 09:29 AM
Printing webpages, spreadsheets into PDF is not WYSIWYG in Ubuntu wagaboy Linux - Software 1 07-30-2010 08:26 PM
LXer: How to generate and update ODF spreadsheets without OpenOffice LXer Syndicated Linux News 0 05-27-2010 09:30 PM


All times are GMT -5. The time now is 09:40 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration