LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 01-15-2004, 09:48 PM   #1
true_atlantis
Member
 
Registered: Oct 2003
Distribution: fedora cor 5 x86_64
Posts: 639

Rep: Reputation: 30
shuttingdown


2 quick newbie questions... 1. to shutdown in slack, how are you supposed to do it? i logout and su then telinit 6 or 0... and 2. when i do shut down, my computer shows the message shutting down, but it doesnt really turn off, i have to hold the power button untill its off...
 
Old 01-15-2004, 09:56 PM   #2
Tinkster
Moderator
 
Registered: Apr 2002
Location: in a fallen world
Distribution: slackware by choice, others too :} ... android.
Posts: 23,000
Blog Entries: 11

Rep: Reputation: 893Reputation: 893Reputation: 893Reputation: 893Reputation: 893Reputation: 893Reputation: 893
Quote:
but it doesnt really turn off, i have to hold the power button untill its off...
That behaviour is determined by the APM/ACPI
set-up of your machine ... have a search on the
forums ;)

As for the shutdown ... I usually do
su -c halt



Cheers,
Tink
 
Old 01-16-2004, 12:17 AM   #3
Lohan
LQ Newbie
 
Registered: Jan 2004
Location: Brooklyn
Distribution: Slackware 9.1, Kernel 2.6.0
Posts: 11

Rep: Reputation: 0
Also, if you boot straight into X, or otherwise find yourself using kdm or gdm, you can shutdown from there. More info on this subject can also be found by searching the forums...
 
Old 01-16-2004, 01:20 AM   #4
Skyline
Senior Member
 
Registered: Jun 2003
Distribution: Debian/other
Posts: 2,104

Rep: Reputation: 45
2 things you need to do for shutdown:

1) add;

apm=power-off

to your append line in the Slackware stanza in lilo.conf - ie for example

append="devfs=mount hdc=ide-scsi acpi=off quiet apm=power-off"

then type

/sbin/lilo

to make the changes take effect - then use

halt

as root user or if you're using KDM you'll get the normal gui option.


2) Uncomment this line in /etc/rc.d/rc.modules

#/sbin/modprobe apm

to

/sbin/modprobe apm

Last edited by Skyline; 01-16-2004 at 01:28 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
special keys, touchpad, shuttingdown gfx and a little bit more things xmav78 Suse/Novell 5 06-16-2005 05:55 PM
dmesg when shuttingdown thermite_1033 Slackware 1 06-08-2004 03:33 PM


All times are GMT -5. The time now is 09:33 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration