LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices



Reply
 
Search this Thread
Old 01-19-2003, 01:24 AM   #16
Half_Elf
Guru
 
Registered: Sep 2001
Location: Montreal, Canada
Distribution: Slackware; Debian; Gentoo...
Posts: 2,163

Rep: Reputation: 45

"Processor" is the one doing the power off for me... I don't think button can do anything yet, the kernel help says "it can't do anything except show you the button event", or something like that.

However, it's true that any modern mb will use ACPI instead of APM.
 
Old 01-19-2003, 03:23 PM   #17
ccool
Member
 
Registered: Oct 2002
Location: Canada
Distribution: Slackware 10.1
Posts: 71

Rep: Reputation: 15
Wooohhooo

I did'nt know that the new motherboard were using ACPI instead of APM... So I recompiled my kernel with acpi and remove all the apm modules and Voilą ! Everything worked.

I want to thank you all to help me resolv that problem. I am now one question less stupid my slackware 8.1 works like a charm now, thanks
 
Old 01-24-2003, 12:27 PM   #18
Darin
Senior Member
 
Registered: Jan 2003
Location: Portland, OR USA
Distribution: Slackware, SLAX, Gentoo, RH/Fedora
Posts: 1,024

Rep: Reputation: 45
I hated that, I always thought it was a Linux thing!

I guess for most people APM works, either when you compile it normal or when you compile it with the "use real mode APM call for shutdown"

For my system I tried ACPI since it is the newer standard, I compiled ACPI into the kernel and added the system option. In order to get ACPI as an option in 2.4.20 I had to turn on the prompt for development or experimental option. I needed the "system" option of ACPI to get it working, not the processor or power button options.

What I did was what was suggested, compile both apm and acpi as modules and then try one or the other. For APM it was just modprobe apm uncommented in the rc.modules but for acpi I had to add a modprobe line so I stuck it in rc.modules right below the apm stuff, I think the line was: "/sbin/modprobe ospf_system" (sorry I'm booted into Windows now and can't verify it.) If you compile it into the kernel you will not need the modprobe line obviously.
 
Old 01-24-2003, 12:55 PM   #19
ccool
Member
 
Registered: Oct 2002
Location: Canada
Distribution: Slackware 10.1
Posts: 71

Rep: Reputation: 15
thanks... all I did, to make it work, was to compile acpi right into the kernel... so no modprobe, and the shutdown works perfect

still, tks
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Shutdown Problem Andjeo Mandriva 5 10-21-2004 05:52 PM
Shutdown Problem Jmcatch742 Linux - General 2 08-16-2004 04:09 AM
X shutdown problem kleptophobiac Linux - Software 9 04-02-2004 08:53 AM
Shutdown problem tsitras Debian 6 10-21-2003 09:31 AM
Shutdown Problem gbj Linux - General 1 08-07-2003 09:45 PM


All times are GMT -5. The time now is 08:15 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration