LinuxQuestions.org
Did you know LQ has a Linux Hardware Compatibility List?
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 06-20-2002, 11:41 PM   #1
joel1
Member
 
Registered: Jun 2002
Posts: 31

Rep: Reputation: 15
Shutdown problem


Doesn't seem to shutdown properly. I type power off it halts everything unmounts and then it just says 'System shutdown.' or 'Shutdown complete.' something like that anyway (I'll check tonight and post exact message. But it doesn't turn off like it did under redhat.

Is this normal? or is something wrong?

Using Slackware 8.1
 
Old 06-21-2002, 12:23 AM   #2
Half_Elf
Guru
 
Registered: Sep 2001
Location: Montreal, Canada
Distribution: Slackware; Debian; Gentoo...
Posts: 2,163

Rep: Reputation: 45
Herm try to enable "advanced power management" in your kernel and the "use real time APM bios to power off", I heard sometime this can help.

But I have this problem too, my box doesn't shutdown by it self.... I can reboot, but I can't shutdown... Dunno why.
 
Old 06-21-2002, 12:27 AM   #3
joel1
Member
 
Registered: Jun 2002
Posts: 31

Original Poster
Rep: Reputation: 15
Yeah exact same problem reboot works fine but not shutdown, very strange!

Thanks for the suggestions, I will look into it and try it out over the weekend...
 
Old 06-21-2002, 06:17 AM   #4
Aussie
Senior Member
 
Registered: Sep 2001
Location: Brisvegas, Antipodes
Distribution: Slackware
Posts: 4,590

Rep: Reputation: 56
Just modprobe apm and all should be well.
 
Old 06-21-2002, 11:45 AM   #5
Jeff Sadowski
LQ Newbie
 
Registered: Jun 2002
Location: Albuquerque
Distribution: The only true distro Slackware
Posts: 1

Rep: Reputation: 0
With a multi-processor kernel ACPI must be used not APM
I haven't tried to get ACPI because I only need a single
processor kernel It works for me. You'll either need to
a) look into acpi and disabling apmd.
b) dissabling multiprocessor support in the kernel options
c) turn off the power by hand
I hope that this was helpful
 
Old 06-21-2002, 11:50 PM   #6
joel1
Member
 
Registered: Jun 2002
Posts: 31

Original Poster
Rep: Reputation: 15
Thanks guys modrpobe apm fixed it all up.
 
Old 06-23-2002, 06:46 PM   #7
Darkstar
Member
 
Registered: Jan 2002
Location: Elkton, MD
Distribution: Debian 3.1, SimplyMEPIS 3.3.1, Kanotix 2005-03
Posts: 91

Rep: Reputation: 15
Actually, if you edit the rc.modules file, you'll see a line commented out that enables apm so you don't have to do a modprobe each time. I think this works better.

Last edited by Darkstar; 06-23-2002 at 06:47 PM.
 
Old 06-23-2002, 07:05 PM   #8
joel1
Member
 
Registered: Jun 2002
Posts: 31

Original Poster
Rep: Reputation: 15
Yeah I just added 'modprobe apm' to the bottom of the rc.modules file.
 
Old 06-25-2002, 08:51 AM   #9
de_guiche
LQ Newbie
 
Registered: Jun 2002
Distribution: SUSE but will change soon.
Posts: 9

Rep: Reputation: 0
I have the exact same Pb under SUSE but nothing has worked for me
 
Old 01-16-2003, 02:20 PM   #10
ccool
Member
 
Registered: Oct 2002
Location: Canada
Distribution: Slackware 10.1
Posts: 71

Rep: Reputation: 15
euh, guys... it does'nt work for me...

I recompile the kernel (2.4.20) with acpi and apm and the shutdown still does'nt work. When I shut down my computer, everything is turning off and then, it says : "Power down" but it hangs there

modprobe apm does'nt work for me, becaus I compiled it in the kernel, and not as a module...

Can somebody help me ???
 
Old 01-16-2003, 03:37 PM   #11
Half_Elf
Guru
 
Registered: Sep 2001
Location: Montreal, Canada
Distribution: Slackware; Debian; Gentoo...
Posts: 2,163

Rep: Reputation: 45
ccool: some motherboard are just bad and you will not be able to shutdown properly... however, try to enable Acpi alone or Apm alone. Apm will always be taked by default I think, so if you enable it and you motherboard does not support it, it will never use acpi unless you disable APM.
 
Old 01-16-2003, 03:39 PM   #12
NSKL
Senior Member
 
Registered: Jan 2002
Location: Rome, Italy ; Novi Sad, Srbija; Brisbane, Australia
Distribution: Ubuntu / ITOS2008
Posts: 1,207

Rep: Reputation: 46
You should not have both APM and ACPI enabled. If you dont have SMP, or a laptop, i suggest using APM. Recompile the kernel, this time including both APM and ACPI as modules, then first modprobe APM, and try to shutdown. If that doesn't work, then reboot, and insted load ACPI and try. If that doesn't work you'll have to recompile again. This time include APM to be built in the kernel, and play with APM options. This can involve a couple of kernel re-compiles, and get very annoying... in the end however, it usually works with only APM, or APM and "use real time bios call to power off"
Good luck
-NSKL
 
Old 01-16-2003, 09:52 PM   #13
ccool
Member
 
Registered: Oct 2002
Location: Canada
Distribution: Slackware 10.1
Posts: 71

Rep: Reputation: 15
thanks nskl....

I will try that

PS: thanks half_elf, but my motherboard work correctly with windows (and I tried mandrake 8.2 and it was working too..) I should have mentioned that...

still, thanks for your replys, I will try that
 
Old 01-18-2003, 05:10 AM   #14
fskmh
Member
 
Registered: Jun 2002
Location: South Africa
Distribution: Slackware64-current multilib
Posts: 235

Rep: Reputation: 55
Here's a solution that works well for me on more recent Gigabyte (2001+) mobos:
Enable ACPI support:
Then add support for System, Processor and Button (Button is the one that does the poweroff). I compile these directly into the kernel.
On older machines that support APM and which have ATX power supplies I do:
Enable APM BIOS support:
Then enable real mode APM BIOS call to poweroff. I also compile these directly into the kernel.
Note that you have to pick ONE of these methods, it makes no sense trying to use both.
 
Old 01-18-2003, 12:56 PM   #15
ccool
Member
 
Registered: Oct 2002
Location: Canada
Distribution: Slackware 10.1
Posts: 71

Rep: Reputation: 15
ok, I'll try your solution with acpi, because it did'nt work with apm...
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Shutdown Problem Andjeo Mandriva 5 10-21-2004 04:52 PM
Shutdown Problem Jmcatch742 Linux - General 2 08-16-2004 03:09 AM
X shutdown problem kleptophobiac Linux - Software 9 04-02-2004 07:53 AM
Shutdown problem tsitras Debian 6 10-21-2003 08:31 AM
Shutdown Problem gbj Linux - General 1 08-07-2003 08:45 PM


All times are GMT -5. The time now is 07:30 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration