LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 06-04-2003, 02:06 AM   #1
alloydog
LQ Newbie
 
Registered: May 2003
Posts: 25

Rep: Reputation: 15
shutdown fron GUI login screen ?


I got the GUI login screen with:
id:4:initdefault:
but now when I logout, I'm back to that screen, not the CLI, so how do I shutdown ? It is the same wether I was working as a normal user, or as root.

The PC has an AT PSU at the moment, so shutdown has to be done at the command line.
 
Old 06-04-2003, 02:37 AM   #2
centr0
Member
 
Registered: Feb 2003
Location: Earth
Distribution: Slackware 9.1
Posts: 134

Rep: Reputation: 15
shutdown -h now

is what i use. to reboot i believe slack9 has reboot cmd or you can just do a shutdown -r now
 
Old 06-04-2003, 04:06 AM   #3
Ivan
Member
 
Registered: May 2003
Location: Romania
Distribution: Slackware 9.0
Posts: 32

Rep: Reputation: 15
You can shutdown the machine from X, you don't have to logoff and then shutdown.
You can use shutdown -h now or halt or init 0.
 
Old 06-04-2003, 05:41 AM   #4
webtoe
Member
 
Registered: Apr 2001
Location: Cambridge, England
Distribution: Slackware 10, Fedora Core 3, Mac OS X
Posts: 617

Rep: Reputation: 30
Also, a lot of the login guis have a shudown option. Which one are you using?

Alex
 
Old 06-04-2003, 08:36 AM   #5
kater
Member
 
Registered: Feb 2003
Location: Switzerland, Berne
Distribution: Slackware 9.0
Posts: 186

Rep: Reputation: 30
XDM.
GDM and KDM have the ability to shutdown, reboot and so on. I just use su <pwd> && poweroff/halt/init 0/shutdown -h now, whatever
 
Old 06-04-2003, 10:28 AM   #6
alloydog
LQ Newbie
 
Registered: May 2003
Posts: 25

Original Poster
Rep: Reputation: 15
I have problem with 'shutdown -h now' from the command line, but getting there was the problem.

Where I went into KDE from the command line, with 'startx', on logout, I was returned to the command line. However, When I set things to boot straight to KDE,
( /etc/initab -> id:4:initdefault, it boots to a groovey flowery login screen, & sure enough you login to KDE or gnome. However, when you logon out, it returns you to the login screen ! Maybe I've missed something, but I couldn't find any powerdown option in KDE - I didn't think it would as the PC's PSU is an AT one, without APM.
 
Old 06-04-2003, 12:04 PM   #7
cpv204
Member
 
Registered: Mar 2003
Location: Tribeca, NYC
Distribution: Slackware 9.0, Fedora Core 1
Posts: 111

Rep: Reputation: 15
Hey alloydog, as webtoe asked earlier, what login manager are you using? gdm? kdm? xdm?

If you use gdm, you need to edit gdm.conf and in that file set system_menu_disabled=0 (it is set to 1 by default). This will give you a reboot/shutdown menu option from the screen where you log in.

Maybe someone else can tell you what you need to do if you're using kdm or xdm.

Last edited by cpv204; 06-04-2003 at 12:05 PM.
 
Old 06-04-2003, 12:20 PM   #8
DaOne
Member
 
Registered: Jan 2003
Location: USA
Distribution: Slackware
Posts: 498

Rep: Reputation: 30
Slackware defaults to gdm...if you want to change to kdm, which by default gives you the shutdown/reboot options, you'll need to edit /etc/rc.d/rc.4. You'll see the entires as:

# Tell the viewers what's going to happen...
echo "Starting up X11 session manager..."

# Try to use GNOME's gdm session manager:
if [ -x /usr/bin/gdm ]; then
exec /usr/bin/gdm -nodaemon
fi

# Not there? OK, try to use KDE's kdm session manager:
if [ -x /opt/kde/bin/kdm ]; then
exec /opt/kde/bin/kdm -nodaemon
fi


Just switch these around and you'll use kdm instead of gdm.
 
Old 06-04-2003, 03:54 PM   #9
Rodrin
Member
 
Registered: May 2003
Location: Upstate NY, U.S.
Distribution: Slackware
Posts: 247

Rep: Reputation: 31
You could also continue to use GDM, and solve this problem by running gdmconfig as root once you're logged onto a session. There you will find many configuration options for GDM, including a setting for the ability to shut down from the login screen.
 
Old 06-04-2003, 11:32 PM   #10
alloydog
LQ Newbie
 
Registered: May 2003
Posts: 25

Original Poster
Rep: Reputation: 15
Hmmm, I think somethings trying to drive me nuts...
The other night, when I had the shutdown prolem (i.e. couldn't), I committed the evil of all evils & just hit the power switch !
The next time I turned the PC on, the file system was bu**ered & it wouldn't boot.
Anyway, I was planning a re-install, because I wanted to re-partition the HDD, & see is ext3 was worth using (maybe in case of dirty power-downs ?)
So, for this installation, I also created a partion for /home, used ext3, & for the SW selection, I missed out much of the developer stuff (It'll never be used on this box) & Gnome.
After the first boot, I edited /etc/initab as normal & rebooted...
The GUI login screen was different this time (last time, it defualted to Gnome), it looked more KDE-ish, and had option buttons. There, clear as day was the option to shutdown. Also, after the session, on logout, the logout screen was different (had a 'cute' little dragon), and again the was the option to log in, reboot, or shutdown.
So, I guess the original screen (Gnome) was less obvious with the options, but the enforce re-install & new set-up precluded any further investigation.
However, every little detail has been scribbled in me notebook, so is ready for the next time...
 
Old 06-04-2003, 11:39 PM   #11
alloydog
LQ Newbie
 
Registered: May 2003
Posts: 25

Original Poster
Rep: Reputation: 15
DaOne - Thanks for the details, as you can see, I didn't go that route, as after screwing things up good & proper, I didn't re-install Gnome the next time, so it defaulted to the kdm anyway.

cpv204 - I wasn't aware what gdm or kdm was at the time !
Live & learn :-D

I can see many more installations to come, & each piece of info I get, get's saved. Which reminds me, my missuss is getting cheesed of with the computer desk dissappearing under a few tons of notes - She wonders what happened to my 'paperless office'...
 
Old 06-05-2003, 11:23 AM   #12
cpv204
Member
 
Registered: Mar 2003
Location: Tribeca, NYC
Distribution: Slackware 9.0, Fedora Core 1
Posts: 111

Rep: Reputation: 15
Yeah, if you don't have gdm, kdm is next in line.

Happy to help. Just look at how much more you know now than you did a few days ago!
 
Old 06-05-2003, 11:33 AM   #13
JustSlack
Member
 
Registered: Jun 2003
Location: Gurnee, IL
Distribution: Mandrake
Posts: 65

Rep: Reputation: 15
alloydog, you may want to try ReiserFS instead of ext3. It works quite well.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
No GUI login screen n175uj Programming 1 06-29-2005 07:15 AM
Customizing the GUI login screen Wynand1 VectorLinux 3 03-04-2004 11:05 AM
can't get gui login screen woja Linux - Software 5 11-28-2003 10:27 AM
gui login screen only not the same after reinstall? guitarnix Slackware 3 11-20-2003 08:36 PM
Redhat 9: restricting reboot/shutdown from login screen jsf03723 Linux - Distributions 7 06-20-2003 10:33 AM


All times are GMT -5. The time now is 11:29 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration