LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   shutdown fron GUI login screen ? (http://www.linuxquestions.org/questions/slackware-14/shutdown-fron-gui-login-screen-63567/)

alloydog 06-04-2003 02:06 AM

shutdown fron GUI login screen ?
 
I got the GUI login screen with:
id:4:initdefault:
but now when I logout, I'm back to that screen, not the CLI, so how do I shutdown ? It is the same wether I was working as a normal user, or as root.

The PC has an AT PSU at the moment, so shutdown has to be done at the command line.

centr0 06-04-2003 02:37 AM

shutdown -h now

is what i use. to reboot i believe slack9 has reboot cmd or you can just do a shutdown -r now

Ivan 06-04-2003 04:06 AM

You can shutdown the machine from X, you don't have to logoff and then shutdown.
You can use shutdown -h now or halt or init 0.

webtoe 06-04-2003 05:41 AM

Also, a lot of the login guis have a shudown option. Which one are you using?

Alex

kater 06-04-2003 08:36 AM

XDM.
GDM and KDM have the ability to shutdown, reboot and so on. I just use su <pwd> && poweroff/halt/init 0/shutdown -h now, whatever ;)

alloydog 06-04-2003 10:28 AM

I have problem with 'shutdown -h now' from the command line, but getting there was the problem.

Where I went into KDE from the command line, with 'startx', on logout, I was returned to the command line. However, When I set things to boot straight to KDE,
( /etc/initab -> id:4:initdefault:), it boots to a groovey flowery login screen, & sure enough you login to KDE or gnome. However, when you logon out, it returns you to the login screen ! Maybe I've missed something, but I couldn't find any powerdown option in KDE - I didn't think it would as the PC's PSU is an AT one, without APM.

cpv204 06-04-2003 12:04 PM

Hey alloydog, as webtoe asked earlier, what login manager are you using? gdm? kdm? xdm?

If you use gdm, you need to edit gdm.conf and in that file set system_menu_disabled=0 (it is set to 1 by default). This will give you a reboot/shutdown menu option from the screen where you log in.

Maybe someone else can tell you what you need to do if you're using kdm or xdm.

DaOne 06-04-2003 12:20 PM

Slackware defaults to gdm...if you want to change to kdm, which by default gives you the shutdown/reboot options, you'll need to edit /etc/rc.d/rc.4. You'll see the entires as:

# Tell the viewers what's going to happen...
echo "Starting up X11 session manager..."

# Try to use GNOME's gdm session manager:
if [ -x /usr/bin/gdm ]; then
exec /usr/bin/gdm -nodaemon
fi

# Not there? OK, try to use KDE's kdm session manager:
if [ -x /opt/kde/bin/kdm ]; then
exec /opt/kde/bin/kdm -nodaemon
fi


Just switch these around and you'll use kdm instead of gdm.

Rodrin 06-04-2003 03:54 PM

You could also continue to use GDM, and solve this problem by running gdmconfig as root once you're logged onto a session. There you will find many configuration options for GDM, including a setting for the ability to shut down from the login screen.

alloydog 06-04-2003 11:32 PM

Hmmm, I think somethings trying to drive me nuts...
The other night, when I had the shutdown prolem (i.e. couldn't), I committed the evil of all evils & just hit the power switch !
The next time I turned the PC on, the file system was bu**ered & it wouldn't boot.
Anyway, I was planning a re-install, because I wanted to re-partition the HDD, & see is ext3 was worth using (maybe in case of dirty power-downs ?)
So, for this installation, I also created a partion for /home, used ext3, & for the SW selection, I missed out much of the developer stuff (It'll never be used on this box) & Gnome.
After the first boot, I edited /etc/initab as normal & rebooted...
The GUI login screen was different this time (last time, it defualted to Gnome), it looked more KDE-ish, and had option buttons. There, clear as day was the option to shutdown. Also, after the session, on logout, the logout screen was different (had a 'cute' little dragon), and again the was the option to log in, reboot, or shutdown.
So, I guess the original screen (Gnome) was less obvious with the options, but the enforce re-install & new set-up precluded any further investigation.
However, every little detail has been scribbled in me notebook, so is ready for the next time...

alloydog 06-04-2003 11:39 PM

DaOne - Thanks for the details, as you can see, I didn't go that route, as after screwing things up good & proper, I didn't re-install Gnome the next time, so it defaulted to the kdm anyway.

cpv204 - I wasn't aware what gdm or kdm was at the time !
Live & learn :-D

I can see many more installations to come, & each piece of info I get, get's saved. Which reminds me, my missuss is getting cheesed of with the computer desk dissappearing under a few tons of notes - She wonders what happened to my 'paperless office'...

cpv204 06-05-2003 11:23 AM

Yeah, if you don't have gdm, kdm is next in line.

Happy to help. Just look at how much more you know now than you did a few days ago!

JustSlack 06-05-2003 11:33 AM

alloydog, you may want to try ReiserFS instead of ext3. It works quite well.


All times are GMT -5. The time now is 09:32 PM.