LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 11-16-2006, 03:08 PM   #1
arubin
Senior Member
 
Registered: Mar 2004
Location: Middx UK
Distribution: Slackware64 14.1 (multilib)
Posts: 1,209

Rep: Reputation: 55
Shutdown button on kde logoff gone


I use run mode 4.

When I log off from a kde session I ought to have the options in the dialog to:

End current session
shutdown
restart

Something has happened and I only see the 'End current session' button unless I am running as root.
The shutdown and restart options are still there on the kdm manager but not in the logout dialog.

In Control Centre/Session Manager/General offer shutdown options is checked.

How do I get my buttons back?
 
Old 11-16-2006, 03:33 PM   #2
Samoth
Member
 
Registered: Apr 2005
Distribution: Exherbo
Posts: 474
Blog Entries: 1

Rep: Reputation: 32
If I remember correctly, you have to have kdm running in order to do stuff like that. Do you have it running?
 
Old 11-16-2006, 03:41 PM   #3
gilead
Senior Member
 
Registered: Dec 2005
Location: Brisbane, Australia
Distribution: Slackware64 14.0
Posts: 4,123

Rep: Reputation: 151Reputation: 151
You should be able to configure this from the KDE Control Centre. Go to System Administration / Login Manager. From there select the Shutdown tab (you'll need to enter root's password to make changes). In the Allow Shutdown section you can set the Local setting to either Nobody, Everybody or Only Root.
 
Old 11-16-2006, 03:45 PM   #4
arubin
Senior Member
 
Registered: Mar 2004
Location: Middx UK
Distribution: Slackware64 14.1 (multilib)
Posts: 1,209

Original Poster
Rep: Reputation: 55
No you have not read the question.

I am running kdm.

Shutdown and restart is available from kdm.

My problem is that I should also be able to shutdown from the dialog box that is brought up when you log out and those buttons are gone.

System Administration / Login Manager controls the kdm dialog not the log off dialog which ought to be controlled by session manager.

A possibly related thing. I have lost Switch user from the kde menu
 
Old 11-16-2006, 07:04 PM   #5
gilead
Senior Member
 
Registered: Dec 2005
Location: Brisbane, Australia
Distribution: Slackware64 14.0
Posts: 4,123

Rep: Reputation: 151Reputation: 151
Rubbish - what I haven't done is set up a box to use run level 4 recently. As well as the setting I mentioned earlier, you'll probably need to go to the Session Manager (in KDE Control Centre under KDE Components) and check the Offer Shutdown Options in the General section.
 
Old 11-17-2006, 02:17 AM   #6
arubin
Senior Member
 
Registered: Mar 2004
Location: Middx UK
Distribution: Slackware64 14.1 (multilib)
Posts: 1,209

Original Poster
Rep: Reputation: 55
Quote:
you'll probably need to go to the Session Manager (in KDE Control Centre under KDE Components) and check the Offer Shutdown Options in the General section.
As I wrote in the first post

Quote:
In Control Centre/Session Manager/General offer shutdown options is checked.
It does not seem to have any effect
 
Old 11-17-2006, 06:31 AM   #7
rkrishna
Member
 
Registered: Mar 2005
Location: chennai(madras), India
Distribution: slackware ofcourse
Posts: 654

Rep: Reputation: 32
dows taht mean runlevel 4, from teh default runlevel 3 u cant expect kdm choices or restart shutdown options. i hope you dont need to startx to get into xwindow.

as giled said make sure tht it is runlevel 4.
Quote:
The shutdown and restart options are still there on the kdm manager but not in the logout dialog.
oho not quite sure
 
Old 11-17-2006, 08:36 PM   #8
xflow7
Member
 
Registered: May 2004
Distribution: Slackware
Posts: 158

Rep: Reputation: 21
Quote:
Originally Posted by arubin
As I wrote in the first post


Quote:
In Control Centre/Session Manager/General offer shutdown options is checked.
It does not seem to have any effect
I've just been playing with the Session Manager options. In addition to Offer Shutdown Options, do you also have Confirm Logout selected? I've found that both need to be enabled in order to be presented with the options.

Dave
 
Old 11-18-2006, 01:01 PM   #9
arubin
Senior Member
 
Registered: Mar 2004
Location: Middx UK
Distribution: Slackware64 14.1 (multilib)
Posts: 1,209

Original Poster
Rep: Reputation: 55
I think I have sorted this out. I do not know how this happened but the permissions for /var were at rwx------

I have changed them to rwxr-xr-x and I have the buttons back.
 
Old 11-20-2006, 01:58 AM   #10
rkrishna
Member
 
Registered: Mar 2005
Location: chennai(madras), India
Distribution: slackware ofcourse
Posts: 654

Rep: Reputation: 32
new result, thank you
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Shutdown/logoff problem rsiby Linux - Laptop and Netbook 4 01-16-2006 08:49 PM
new nVidia driver hangs on logoff/shutdown merize147 Suse/Novell 0 10-16-2004 10:42 AM
Madatory Auto Logoff and shutdown wanted 1kyle Linux - Security 1 07-17-2004 02:19 PM
Adding reboot & shutdown to gnome logoff ringwraith Slackware 7 12-13-2003 11:27 AM
Where is the logoff button? pe2338 LQ Suggestions & Feedback 2 08-08-2003 01:06 AM


All times are GMT -5. The time now is 03:00 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration