LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   Shutdown but no power off (http://www.linuxquestions.org/questions/slackware-14/shutdown-but-no-power-off-567833/)

marnold 07-09-2007 10:01 AM

Shutdown but no power off
 
OK, as I mentioned in the installation forum, I had to put "acpi=off" into the LILO append otherwise when I boot up, my keyboard would be dead. The problem I run into now is that when I shutdown my box, it gets to the point where it says "System halted." but my box won't power off. Is there a way I can do both? It's not a huge issue since my box stays on most of the time. It confused my loving wife when she turned off my computer last night due to a thunderstorm that woke her up but not me. It would also be a problem in the case of a power failure when I'm not around. apcupsd would be able to bring Linux down, but the computer would keep merrily running until the batteries failed.

I know that in previous versions one solution was to do a "modprobe apm" but there is no apm module in Slack 12 with the hugesmp kernel. FWIW, apmd is running.

Thoughts?
Matt

geek745 07-09-2007 11:42 PM

I dunno, man, I was puzzled by that situation previously, but since I've been compiling my own kernels I haven't had any trouble. Linus signed off on a new version today! download it, configure it, build it, have fun! 2.6.22 You might fix some problems you didn't know you had... you could break something too, but the slack install media is great *for* fixing up systems that are ruined by a bad kernel, just note that you'll be the one issuing commands, not any automated tool. read up or have another computer up so you can read while you hack :)

dracolich 07-10-2007 03:32 PM

What kind of keyboard is it that requirs acpi=off to work? If it's usb you probably need to enable legacy (or DOS) usb support in the BIOS instead. The powering off is an acpi feature, so if acpi=off it's not gonna happen.

austinramsay 07-10-2007 04:15 PM

It could be like my computer, I built my computer and when I turn it off, the mouse and keyboard are still on, so, it may just be the way your computer is

dkpw 07-10-2007 06:31 PM

Quote:

Originally Posted by austinramsay
It could be like my computer, I built my computer and when I turn it off, the mouse and keyboard are still on, so, it may just be the way your computer is

Self-powering mouse and keyboard. How useful.
Do you use solar or nuclear power?

dracolich 07-10-2007 07:19 PM

Quote:

Originally Posted by austinramsay
It could be like my computer, I built my computer and when I turn it off, the mouse and keyboard are still on, so, it may just be the way your computer is

Self-powering mouse and keyboard. How useful.
Do you use solar or nuclear power?
I remember some early gasoline-powered models. I think they were made by Microsoft. :D

Actually, maybe it's a usb keyboard and mouse plugged into an A/C powered hub. As long as the hub gets power anything that's connected to it will also.

dkpw 07-10-2007 07:27 PM

Quote:

Originally Posted by dracolich
I remember some early gasoline-powered models. I think they were made by Microsoft. :D

Actually, maybe it's a usb keyboard and mouse plugged into an A/C powered hub. As long as the hub gets power anything that's connected to it will also.

:D Almost certainly USB - but I couldn't resist.

geek745 07-11-2007 09:48 AM

hey me 2! my mouse stays lit and the keyboard lights too, when I power down. Sure the system goes down by itself but there is still power on the usb, ps/2, and ethernet lines.

hutyerah 07-11-2007 09:57 AM

Turn off the power properly, at the power point, and after around 15 seconds I bet the keyboard/mouse won't still be on :P Power supplies keep parts of the motherboard powered for wake-on-LAN and keyboard/mouse booting, and maybe other crazy features of your BIOS like playing CDs while the computer is officially off. Not really contributing to the solution here though, hmm...

marnold 07-12-2007 12:27 PM

Quote:

Originally Posted by dracolich
What kind of keyboard is it that requirs acpi=off to work? If it's usb you probably need to enable legacy (or DOS) usb support in the BIOS instead. The powering off is an acpi feature, so if acpi=off it's not gonna happen.

Check out my post in the Slackware Installation forum. It's an IBM ps/2 style keyboard--the kind you could beat an intruder to death with. My mobo has never played nice with ACPI, but this one is a doozy. It seems that with every new kernel I try, it finds some new and improved way to mess with my mobo and ACPI. I'm 1/2 way tempted to download the new kernel and see if that solves the problem. I'd hate to go through a full-blown kernel compilation to find out it doesn't fix anything.

FWIW, everything worked just fine with the Slackware 11 kernel. Go fig.

marnold 07-12-2007 12:38 PM

Quote:

Originally Posted by geek745
I dunno, man, I was puzzled by that situation previously, but since I've been compiling my own kernels I haven't had any trouble. Linus signed off on a new version today! download it, configure it, build it, have fun! 2.6.22 You might fix some problems you didn't know you had... you could break something too, but the slack install media is great *for* fixing up systems that are ruined by a bad kernel, just note that you'll be the one issuing commands, not any automated tool. read up or have another computer up so you can read while you hack :)

Actually 2.6.22.1 is out now. :)

I just read through the full 2.6.22 changelog and there are some ACPI fixes in there that sound like they might be relevant to my situation. We'll see.

Time to dust off my kernel compilation skillz.

marnold 07-12-2007 03:32 PM

Well, somehow or the other 2.6.22.1 fixed the problem. Without acpi=off I still can't use my keyboard. However, I also added apm=realmode-power-off to the append as well because the box would crash at power-off. Now apm will turn off my computer normally.

FWIW, I used the config-generic-2.6.21.5 as the basis for my .config file. The only thing I changed was specifically choosing my processor, adding Voluntary Kernel Preemption, and telling the kernel to scan for LUNs.


All times are GMT -5. The time now is 08:54 PM.