LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 05-03-2003, 07:07 PM   #1
ritris
LQ Newbie
 
Registered: May 2003
Location: Brazil
Posts: 3

Rep: Reputation: 0
Angry Sharing Printer with Samba


Hi...

I've installed Slackware 9 with Samba 2.28a on my server. I configured the "file sharing" and it's working fine... but my WinXP client can't print at the server printer. When I add the printer on the client, the printer status is "Ready"... but when a send something to the printer, the status changes to "Access Denied - It's not possible to connect..." even when it's defined public access (guest account) to the printer...
From the server, I can print normally.... Could anyone help ???

This is my SMB.CONF

# Samba config file created using SWAT
# from 0.0.0.0 (0.0.0.0)
# Date: 2003/05/03 15:19:55

# Global parameters
[global]
log file = /var/log/samba.%m
dns proxy = No
load printers = yes
server string = Samba Server
printing = lprng
workgroup = MSHOME
username map = /etc/samba/user.map
security = SHARE
max log size = 50
ssl ca certdir = /etc/ssl/certs

[homes]
comment = Home Directories
read only = No
browseable = No

[public]
comment = Public Stuff
path = /home/ftp
read only = No
guest only = No
guest ok = Yes

[printers]
printer = DeskJet600
browseable = no
printable = yes
path = /var/spool/samba
comment = All Printers
public = yes
guest ok = Yes

Thanks !!!
 
Old 05-03-2003, 07:16 PM   #2
Excalibur
Senior Member
 
Registered: Jun 2002
Location: Northern VA, USA
Distribution: Ubuntu
Posts: 1,180

Rep: Reputation: 45
Check the permissions on /var/spool/samba. According to your smb.conf that is the spool directory where the job would be queued. Try "chmod 766 /var/spool/samba" and see if that allows the print jobs to be queued. It is probably providing a default user level of "nobody".
 
Old 05-05-2003, 06:41 AM   #3
fskmh
Member
 
Registered: Jun 2002
Location: South Africa
Distribution: Slackware64-current multilib
Posts: 235

Rep: Reputation: 55
In reference to the [public] entry, I would say add "create mask=0700".
 
Old 05-06-2003, 08:24 PM   #4
ritris
LQ Newbie
 
Registered: May 2003
Location: Brazil
Posts: 3

Original Poster
Rep: Reputation: 0
Hi....

Doing the "chmod 766 /var/spool/samba" doesn't work...

Any other ideia ?!?!?

Thanks !!!


Quote:
Originally posted by Excalibur
Check the permissions on /var/spool/samba. According to your smb.conf that is the spool directory where the job would be queued. Try "chmod 766 /var/spool/samba" and see if that allows the print jobs to be queued. It is probably providing a default user level of "nobody".
 
Old 05-06-2003, 09:15 PM   #5
Excalibur
Senior Member
 
Registered: Jun 2002
Location: Northern VA, USA
Distribution: Ubuntu
Posts: 1,180

Rep: Reputation: 45
Have you checked to see if the directory exists?
 
Old 05-08-2003, 09:47 PM   #6
ritris
LQ Newbie
 
Registered: May 2003
Location: Brazil
Posts: 3

Original Poster
Rep: Reputation: 0
Yes... the directory exists...


Quote:
Originally posted by Excalibur
Have you checked to see if the directory exists?
 
Old 05-09-2003, 07:39 AM   #7
Excalibur
Senior Member
 
Registered: Jun 2002
Location: Northern VA, USA
Distribution: Ubuntu
Posts: 1,180

Rep: Reputation: 45
Well, then you could try adding "guest account = root" and restart samba. If the printing is allowed then it is a permsision issue, if not then it is a config or security with Samba/Win2K issue. Once the issue is resolved you should remove the setting though for security purposes, especially if the Linux box has a direct internet gateway.
 
Old 05-09-2003, 12:15 PM   #8
jtshaw
Senior Member
 
Registered: Nov 2000
Location: Seattle, WA USA
Distribution: Ubuntu @ Home, RHEL @ Work
Posts: 3,892
Blog Entries: 1

Rep: Reputation: 66
Along similar lines, what exactly am I suppose to use as a driver on the windows end to talk to my cups printer?

Basically, I run vmware on my computer and I have my Deskjet 720C installed through cups. If I want to print anything from vmware (really the only reason why I have it is professors that give me special word files that open office can't open) having it take over control of the parrellel port cause cups to stop working and windows wasn't printing anymore. So I decided to share the printer though Samba.

Anyway, the share is there but all the documentation refers to using one of two drivers, either the adobe driver (which doesn't work) or the real driver for the printer which also doesn't seam to work. Is there some special switch I have to add to have samba/cups pass in the data raw directly to the printer so I can use the conventional windows driver for the HP 720C?
 
Old 05-09-2003, 09:40 PM   #9
Excalibur
Senior Member
 
Registered: Jun 2002
Location: Northern VA, USA
Distribution: Ubuntu
Posts: 1,180

Rep: Reputation: 45
You might try just setting up a special queue for sharing through SMB. When you set it up in CUPS use the "raw" device driver on the port.

There is a switch for raw output when using the linux command parameters like "-oraw". I primarily use this option when printing photos from gimp.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Sharing a printer using samba kponenation Fedora 1 11-15-2005 08:14 PM
Sharing Printer using Samba subaruwrx Linux - Software 2 03-22-2005 11:48 AM
Samba and printer sharing onelung02 Linux - Software 2 02-28-2005 01:50 PM
samba printer sharing nithin_bhaskar Linux - Networking 1 06-17-2004 05:17 PM
Sharing printer through samba rejser Linux - Networking 12 05-21-2004 01:10 PM


All times are GMT -5. The time now is 07:37 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration