LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices



Reply
 
Search this Thread
Old 12-05-2009, 03:53 AM   #1
imitheos
Member
 
Registered: May 2005
Location: Greece
Posts: 374

Rep: Reputation: 55
Shadow 4.0.3 Package


Hello.

I don't have any ill purpose (flaming,trolling,etc). I am just curious
why it hasn't been updated for so long. Is it because it got a low
priority and the team doesn't have much time or new versions have some
problem ? (Or another reason)

I have the impression that there was a discussion in the Slackware 8-9
era (i think it was about the version of shadow that was released then
and that it didnt' work well in non-pam setups) but i couldn't find it by
googling so i may not remember well.

Nowadays the newest shadow 4.0 release is 4.0.18.2 and there is also a
major version upgrade which has 4.1.4.2 as latest release.

Its not that shadow 4.0.3 doesn't work. Apart from a very minor issue,
it works fine. I am just curious as i mentioned earlier.

Thank you for your time.
 
Old 12-05-2009, 05:32 AM   #2
gnashley
Amigo developer
 
Registered: Dec 2003
Location: Germany
Distribution: Slackware
Posts: 4,775

Rep: Reputation: 481Reputation: 481Reputation: 481Reputation: 481Reputation: 481
This question was asked not too long ago. When something works, does exactly what you want and has no security issues, then there is no need to update it. I think later version of shadow are harder to use without PAM, but I may be wrong about that. Slackware also uses tar-1.13 for creating and installing packages because it does some desirable things that later versions do not.
 
Old 12-05-2009, 09:22 AM   #3
imitheos
Member
 
Registered: May 2005
Location: Greece
Posts: 374

Original Poster
Rep: Reputation: 55
Quote:
Originally Posted by gnashley View Post
This question was asked not too long ago.
Hello gnashley and thank you for answering.

I am sorry if my question is already answered. The only relevant thread
i found was this http://www.linuxquestions.org/questi...ghlight=shadow from a year ago.

Quote:
Originally Posted by gnashley View Post
When something works, does exactly what you want and has no security issues, then there is no need to update it.
I agree with that, though things evolve at some time (like the 2.4->2.6
kernel or KD3->KDE4 and others)

Quote:
Originally Posted by gnashley View Post
I think later version of shadow are harder to use without PAM,
Yes, that is what i remembered too, but i wasn't sure if that is the
reason.
 
  


Reply

Tags
shadow, slackware


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
/etc/shadow malini_1 Linux - Newbie 3 03-24-2009 05:33 PM
/etc/shadow throwapart Linux - Security 2 01-18-2006 09:43 PM
Accidentally removed shadow package hussar Slackware 3 12-24-2005 07:31 AM
shadow file os2 Linux - Security 3 10-18-2005 04:20 PM
/etc/shadow- (notice the dash after the word shadow) shellcode Linux - Security 1 09-03-2004 05:54 AM


All times are GMT -5. The time now is 08:18 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration