LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 10-28-2003, 01:42 PM   #1
Supernaut
LQ Newbie
 
Registered: Jan 2003
Location: NY
Distribution: Slackware
Posts: 5

Rep: Reputation: 0
sftp doesn't work in Konqueror after SSH/SSL upgrade


Hello All

I applied the OpenSSH/OpenSSL upgrades to my Slackware 9.0 box and sftp no longer works in Konqueror 3.1.2 - ssh/sftp/scp all work fine from the command line. I've been beating on this for 2 weeks and can't figure it out. Is there something in KDE I need to reset? I've never hit this one before.

Anybody have any idea how to track this down? Suggestions welcome.

Slackware 9.0
KDE 3.1.2
OpenSSL 0.9.7c 30 Sep 2003
OpenSSH_3.7.1p2, SSH protocols 1.5/2.0, OpenSSL 0.9.7c 30 Sep 2003

Suggestions welcome!

Thanks - JB
 
Old 10-28-2003, 02:14 PM   #2
Tinkster
Moderator
 
Registered: Apr 2002
Location: in a fallen world
Distribution: slackware by choice, others too :} ... android.
Posts: 22,978
Blog Entries: 11

Rep: Reputation: 879Reputation: 879Reputation: 879Reputation: 879Reputation: 879Reputation: 879Reputation: 879
Wild guess: make a symlink from the
current version's library to the name of the
old versions (the one Konqueror has been
compiled against).

Cheers,
Tink
 
Old 10-28-2003, 02:17 PM   #3
rotvogel
Member
 
Registered: Oct 2003
Posts: 534

Rep: Reputation: 30
There are updated KDE packages as well for Slack 9.0. These packages are version 3.1.3 and 3.1.3a. Perhaps these packages will work better with the updated OpenSSL/SSH versions.
 
Old 10-28-2003, 02:31 PM   #4
Supernaut
LQ Newbie
 
Registered: Jan 2003
Location: NY
Distribution: Slackware
Posts: 5

Original Poster
Rep: Reputation: 0
Quote:
Originally posted by Tinkster
Wild guess: make a symlink from the
current version's library to the name of the
old versions (the one Konqueror has been
compiled against).

Cheers,
Tink
It's a minor revision change (openssl-0.9.7a --> openssl-0.9.7c and it's not reflected in the so library name for ssl. Thanks for the suggestion though.

JB
 
Old 10-28-2003, 02:33 PM   #5
Supernaut
LQ Newbie
 
Registered: Jan 2003
Location: NY
Distribution: Slackware
Posts: 5

Original Poster
Rep: Reputation: 0
Quote:
Originally posted by rotvogel
There are updated KDE packages as well for Slack 9.0. These packages are version 3.1.3 and 3.1.3a. Perhaps these packages will work better with the updated OpenSSL/SSH versions.
I've tried 3.1.3 and 3.1.4 when they came out. 3.1.3 had a nasty text overflow bug in Konq that drove me crazy and 3.1.4 did strange, chaotic things when working on the desktop (on 3 different boxes). This might fix my sftp problem but at a very high cost ;-)

Thanks - JB
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
SFTP and SSH XaViaR Linux - Security 5 07-20-2005 10:18 AM
ssh sftp-server dtaju Linux - Security 5 02-23-2004 04:16 PM
SSH - where are scp and sftp satimis Linux - Networking 2 11-15-2003 10:27 AM
sftp and ssh-keygen help please grayhost Linux - Newbie 2 06-26-2003 05:51 PM
ssh and sftp help Rex_chaos Linux - Networking 8 03-17-2003 08:12 PM


All times are GMT -5. The time now is 03:24 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration