LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 07-02-2005, 02:16 AM   #1
Nylex
LQ Addict
 
Registered: Jul 2003
Location: London, UK
Distribution: Slackware
Posts: 7,464

Rep: Reputation: Disabled
Several problems: Apache/PHP, playing CDs and volume control


Hi people, I'm having some trouble with my newly installed Slack 10.1 system so I could really do with some help here please!

1. I installed both Apache (version 1.3.33) and PHP (version 4.3.0 I think) when I installed Slack and I made a test page with the code <? phpinfo(); ?> in it. When I try to view the page, all I see is that code. I found a file called mod_php.conf in /etc/apache and it had the lines "LoadModule php4_module libexec/apache/libphp4.so" and "AddType application/x-httpd-php .php" (there was also another one about coloured syntax form, but that's not important here I guess). After adding these lines to httpd.conf (does it matter where the AddType one goes? I put in under the first AddType line I saw), I restarted my server. Now, my browser tries to open the file (Mozilla 1.7) as it does not know how to handle it. Oh, in /var/log/apache/error_log, there are several lines that say "Cannot remove module mod_php4.c: not found in module list". How can I get PHP to work?

2. Playing CDs only works when I'm root. Do I just need to add my user account to the audio/disks group? Is it safer to add to audio only, rather than disks? I'm not sure really how all the groups and stuff work. Oh and while I'm on the subject of CDs, my CD rewriter drive doesn't appear in my fstab file. Does it need to be there? Also, Slack seems to have added an imaginary floppy drive to my fstab, as shown below. I assume I can just get rid of that line, since I don't have a floppy drive?

/dev/hdb2 swap swap defaults 0 0
/dev/hdb1 / ext3 defaults 1 1
/dev/hda1 /mnt/windows ntfs ro 1 0
/dev/cdrom /mnt/cdrom iso9660 noauto,owner,ro 0 0
/dev/fd0 /mnt/floppy auto noauto,owner 0 0
devpts /dev/pts devpts gid=5,mode=620 0 0
proc /proc proc defaults 0 0

3. When I played a CD as root, there was no sound. I tried to use the volume control in GNOME that's next to the clock (top right hand corner), but when I increase the volume, it goes back down again :/. I also tried to access the volume control from the Multimedia menu, but got an error: Sorry, no mixer elements and/or devices found. The last thing I tried was to run alsamixer and increase the volume there for different items. The thing is though that it has for example "Item: Master [Off]". How do I change those to "On"? My sound card is an onboard Analog Devices AD1980 (motherboard has a VIA KT400 chipset).

Apologies for the really long post :/. Any help would be greatly appreciated, thanks!
 
Old 07-02-2005, 05:34 AM   #2
newinlinux
Member
 
Registered: Dec 2003
Location: Next to Equator
Distribution: GNU/Linux 2.6.14
Posts: 382

Rep: Reputation: 30
3. When I played a CD as root, there was no sound. I tried to use the volume control in GNOME that's next to the clock (top right hand corner), but when I increase the volume, it goes back down again :/. I also tried to access the volume control from the Multimedia menu, but got an error: Sorry, no mixer elements and/or devices found. The last thing I tried was to run alsamixer and increase the volume there for different items. The thing is though that it has for example "Item: Master [Off]". How do I change those to "On"? My sound card is an onboard Analog Devices AD1980 (motherboard has a VIA KT400 chipset).

Let me try this one(seems the easiest to me )

su to root, start alsamixer:

#alsamixer

then press "M" each for PCM, Master and Headphones. These will unmute the 3. Turnup these 3 to a level like 80% or slightly more.

press ESC to exit. Then do a alsactl store. These few steps should solve your no sound problem.
 
Old 07-02-2005, 05:38 AM   #3
newinlinux
Member
 
Registered: Dec 2003
Location: Next to Equator
Distribution: GNU/Linux 2.6.14
Posts: 382

Rep: Reputation: 30
Here's a good guide for your apache/php trouble, it helps me on setting my server, maybe you can fidn your answer in it too.

http://www.linuxquestions.org/questi...hreadid=311344
 
Old 07-02-2005, 06:22 AM   #4
Nylex
LQ Addict
 
Registered: Jul 2003
Location: London, UK
Distribution: Slackware
Posts: 7,464

Original Poster
Rep: Reputation: Disabled
Thank you newinlinux! All I needed to do for Apache/PHP was to use an include directive in my httpd.conf (I don't know why it wouldn't work just copying the two lines though). Sound works now as well. All I need to do is sort out CD permissions/rewriter.

Thanks again .
 
Old 07-02-2005, 07:50 AM   #5
killerbob
Member
 
Registered: Oct 2004
Location: Ottawa, ON
Distribution: Slackware
Posts: 662

Rep: Reputation: 30
To play as user, you need to add your user to the "audio" and "cdrom" groups. If you aren't in the cdrom group, you don't own the CD drive and can't write to it, and also, you won't be able to mount it to play back.

The alternative method, which works as long as you don't want to burn cd's, is to change this:
/dev/cdrom /mnt/cdrom iso9660 noauto,owner,ro 0 0

to this:
/dev/cdrom /mnt/cdrom iso9660 noauto,users,ro 0 0
 
Old 07-02-2005, 07:54 AM   #6
Nylex
LQ Addict
 
Registered: Jul 2003
Location: London, UK
Distribution: Slackware
Posts: 7,464

Original Poster
Rep: Reputation: Disabled
Cheers killerbob .
 
Old 07-02-2005, 08:14 AM   #7
Nylex
LQ Addict
 
Registered: Jul 2003
Location: London, UK
Distribution: Slackware
Posts: 7,464

Original Poster
Rep: Reputation: Disabled
How do I add myself to BOTH audio and cdrom?

I tried "# usermod -G audio, cdrom nick" but it didn't like that, so I tried to add each one separately by doing "#usermod -G audio nick" and then the other one, but then when I do "# groups nick", the output is "nick: users audio".

Help!

Thanks again.
 
Old 07-02-2005, 08:47 AM   #8
killerbob
Member
 
Registered: Oct 2004
Location: Ottawa, ON
Distribution: Slackware
Posts: 662

Rep: Reputation: 30
If you've got KDE installed, you can do it with kuser... it's a GUI frontend to all the tools.

That said, you would need to do it with "usermod -G cdrom nick" just like you did before. It's odd that it would fail on you.

The manual way of doing it is to edit /etc/group. I'd suggest you check that file to see if the cdrom group is already there.
 
Old 07-02-2005, 09:11 AM   #9
Nylex
LQ Addict
 
Registered: Jul 2003
Location: London, UK
Distribution: Slackware
Posts: 7,464

Original Poster
Rep: Reputation: Disabled
I've added myself to the cdrom group as well as audio now, but I'm still not able to play CDs with my user account .

Thanks again.
 
Old 07-02-2005, 09:45 AM   #10
killerbob
Member
 
Registered: Oct 2004
Location: Ottawa, ON
Distribution: Slackware
Posts: 662

Rep: Reputation: 30
Ok... /dev/cdrom is a symlink. On my laptop, it links to /dev/hdc, for example.

What is the ls -l of whatever /dev/cdrom links to?
 
Old 07-02-2005, 09:52 AM   #11
Nylex
LQ Addict
 
Registered: Jul 2003
Location: London, UK
Distribution: Slackware
Posts: 7,464

Original Poster
Rep: Reputation: Disabled
Quote:
Originally posted by killerbob
Ok... /dev/cdrom is a symlink. On my laptop, it links to /dev/hdc, for example.

What is the ls -l of whatever /dev/cdrom links to?
Mine is /dev/hdc as well.
 
Old 07-02-2005, 02:11 PM   #12
killerbob
Member
 
Registered: Oct 2004
Location: Ottawa, ON
Distribution: Slackware
Posts: 662

Rep: Reputation: 30
Ok... so what do you see when you type ls -l /dev/hdc?
 
Old 07-03-2005, 01:32 AM   #13
Nylex
LQ Addict
 
Registered: Jul 2003
Location: London, UK
Distribution: Slackware
Posts: 7,464

Original Poster
Rep: Reputation: Disabled
I see: brw-rw---- 1 root disk 22, 0 2002-06-09 20:27 /dev/hdc

Is that telling me that it's in the disk group and not cdrom?

Edit: I added myself to the disk group and it works now . Yay! Thanks killerbob again .

Last edited by Nylex; 07-03-2005 at 02:50 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Kmix volume control problems borderlinedd Linux - Hardware 3 05-10-2005 04:45 PM
slackware, apache and PHP from .tgz - problems with PHP szymon Slackware 2 09-06-2004 04:57 PM
Gnome Volume Control Problems 74039186 Mandriva 1 05-07-2004 02:45 PM
Alsa Volume Control Problems Ynog Linux - Hardware 4 04-24-2004 03:27 AM
How do I use Mandrake Distro CDs for Apache, MySQL & PHP? robroto88 Mandriva 17 01-26-2004 11:40 PM


All times are GMT -5. The time now is 03:38 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration