LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 03-27-2012, 07:35 AM   #1
AlleyTrotter
Member
 
Registered: Jun 2002
Location: Coal Township PA
Distribution: Slackware64-14.1 (3.17.1) UEFI enabled
Posts: 351

Rep: Reputation: 71
setup fails on most current Slackware-current March 26, 2012


I used Alien's mirror script to download and burn a current DVD for Slackware. The burn failed because the iso was > 4.7G.
Easy fix delete kdei/. Everything OK so far.
Reboot from DVD and log in as root. run 'setup' no messages, after a few seconds, newline and bash prompt return. Repeated attempts produce the same result.
my system:
uname -a returns
Linux Linux 3.3.0 #2 SMP Mon Mar 19 08:13:15 EDT 2012 x86_64 AMD Athlon(tm) 64 X2 Dual Core Processor 5000+ AuthenticAMD GNU/Linux
8GB memory
Lots of space on drives.
Any suggestions would be greatly appreciated
Thanks
John
 
Click here to see the post LQ members have rated as the most helpful post in this thread.
Old 03-27-2012, 08:20 AM   #2
SfinxSoft
LQ Newbie
 
Registered: Mar 2012
Posts: 1

Rep: Reputation: Disabled
Quote:
Originally Posted by AlleyTrotter View Post
I used Alien's mirror script to download and burn a current DVD for Slackware. The burn failed because the iso was > 4.7G.
Easy fix delete kdei/. Everything OK so far.
Reboot from DVD and log in as root. run 'setup' no messages, after a few seconds, newline and bash prompt return. Repeated attempts produce the same result.
my system:
uname -a returns
Linux Linux 3.3.0 #2 SMP Mon Mar 19 08:13:15 EDT 2012 x86_64 AMD Athlon(tm) 64 X2 Dual Core Processor 5000+ AuthenticAMD GNU/Linux
8GB memory
Lots of space on drives.
Any suggestions would be greatly appreciated
Thanks
John
The same here: as I see the dialog do not start - "Error opening terminal: unknown", seems like ncurses/termcap problem in the current build.

P.S. The further investigation shows the problem with sh (busybox) that do not propagates the TERM env var to child scripts.

P.P.S. Uploading the bash static binary and linking it to /bin/sh solved the issue completely - I've managed to install the distro.

Last edited by SfinxSoft; 03-27-2012 at 02:11 PM.
 
2 members found this post helpful.
Old 03-28-2012, 05:15 AM   #3
ponce
Senior Member
 
Registered: Aug 2004
Location: Pisa, Italy
Distribution: Slackware
Posts: 2,460

Rep: Reputation: 888Reputation: 888Reputation: 888Reputation: 888Reputation: 888Reputation: 888Reputation: 888
here, I changed the config file for building busybox like this:
Code:
--- installer/busybox-dot-config.orig	2012-01-09 19:51:11.000000000 +0100
+++ installer/busybox-dot-config	2012-03-28 10:05:57.705013774 +0200
@@ -54,7 +54,7 @@
 #
 # Build Options
 #
-# CONFIG_STATIC is not set
+CONFIG_STATIC=y
 # CONFIG_PIE is not set
 # CONFIG_NOMMU is not set
 # CONFIG_BUILD_LIBBUSYBOX is not set
@@ -89,7 +89,7 @@
 #
 # Busybox Library Tuning
 #
-CONFIG_FEATURE_SYSTEMD=y
+# CONFIG_FEATURE_SYSTEMD is not set
 CONFIG_FEATURE_RTMINMAX=y
 CONFIG_PASSWORD_MINLEN=6
 CONFIG_MD5_SIZE_VS_SPEED=2
(why the second mod? because )
 
1 members found this post helpful.
Old 03-29-2012, 06:29 PM   #4
AlleyTrotter
Member
 
Registered: Jun 2002
Location: Coal Township PA
Distribution: Slackware64-14.1 (3.17.1) UEFI enabled
Posts: 351

Original Poster
Rep: Reputation: 71
No Joy in Coal Township

Thanks for the replies, but no success
patched busybox-dot-config as described
ran busybox.Slackbuild
archived the output from the slackbuild with cpio > initrd.img
copied the initrd.img to slackware64/isolinux/initrd.img
rebuilt the DVD

did I do something wrong or miss something?

the boot from the install disk hangs at the same place
setup will not run

looking for any other suggestions
thanks
john

PS using the March 28th changelog

Last edited by AlleyTrotter; 03-30-2012 at 08:04 PM. Reason: Mixed up two initrd.img's
 
Old 04-03-2012, 08:12 PM   #5
gmartin
Member
 
Registered: Mar 2003
Location: PA
Distribution: Slackware 13.37 Linux Reg # 341245
Posts: 285

Rep: Reputation: 40
Same issue here using the 3/29 changes
 
Old 04-04-2012, 07:07 AM   #6
AlleyTrotter
Member
 
Registered: Jun 2002
Location: Coal Township PA
Distribution: Slackware64-14.1 (3.17.1) UEFI enabled
Posts: 351

Original Poster
Rep: Reputation: 71
workAround

Quote:
Originally Posted by gmartin View Post
Same issue here using the 3/29 changes
There is a work around I have used for temporary install of current.

Boot with your 13.37 disk, after you log in as root remove the 13.37 DVD
and replace it with current DVD. enter 'setup' and you should be able to install current.
Of course this is only a temporary fix as I would expect Pat to fix this before the next release.
Credit for the workaround goes to PV as he taught me that in one of my 'guru wannbe' lessons

hope it helps
john
 
Old 04-04-2012, 11:49 AM   #7
ruario
Senior Member
 
Registered: Jan 2011
Location: Oslo, Norway
Distribution: Slackware
Posts: 1,875

Rep: Reputation: 923Reputation: 923Reputation: 923Reputation: 923Reputation: 923Reputation: 923Reputation: 923Reputation: 923
Quote:
Originally Posted by AlleyTrotter View Post
There is a work around I have used for temporary install of current.

Boot with your 13.37 disk, after you log in as root remove the 13.37 DVD
and replace it with current DVD. enter 'setup' and you should be able to install current.
Or boot your 13.37 CD/DVD, do a network install and set the network path to be a current directory on your favoured mirror
 
Old 04-04-2012, 12:08 PM   #8
ponce
Senior Member
 
Registered: Aug 2004
Location: Pisa, Italy
Distribution: Slackware
Posts: 2,460

Rep: Reputation: 888Reputation: 888Reputation: 888Reputation: 888Reputation: 888Reputation: 888Reputation: 888
or, if you like, you can also try these mini-isos, where I built busybox statically and replaced it in the initrd (more info on how to extract the initrd here).

P.S. you can also:
- rebuild busybox (/source/installer) modifying busybox-dot-config as above: resulting binary will be in /tmp/busybox-*/_install/bin/busybox;
- extract the initrd.img that you find on slackware's mirrors;
- replace busybox (in extracted_initrd_folder/bin) with the just built one;
- reassemble the initrd.img;
- put it in the isolinux folder of your slackware*-current mirror;
- create the full iso with Eric's script
Code:
mirror-slackware-current.sh -i

Last edited by ponce; 04-04-2012 at 01:27 PM.
 
1 members found this post helpful.
Old 04-04-2012, 02:01 PM   #9
AlleyTrotter
Member
 
Registered: Jun 2002
Location: Coal Township PA
Distribution: Slackware64-14.1 (3.17.1) UEFI enabled
Posts: 351

Original Poster
Rep: Reputation: 71
Quote:
Originally Posted by ponce View Post
or, if you like, you can also try these mini-isos, where I built busybox statically and replaced it in the initrd (more info on how to extract the initrd here).

P.S. you can also:
- rebuild busybox (/source/installer) modifying busybox-dot-config as above: resulting binary will be in /tmp/busybox-*/_install/bin/busybox;
- extract the initrd.img that you find on slackware's mirrors;
- replace busybox (in extracted_initrd_folder/bin) with the just built one;
- reassemble the initrd.img;
- put it in the isolinux folder of your slackware*-current mirror;
- create the full iso with Eric's script
Code:
mirror-slackware-current.sh -i
Thanks again Ponce
Even after much time googling I did not find the page
http://www.flaterco.com/kb/slackware.html here
It would have helped much
Anyway fixing it was a good learning experience for me.


Thanks
john
 
Old 04-04-2012, 03:46 PM   #10
hbr
LQ Newbie
 
Registered: Apr 2012
Posts: 1

Rep: Reputation: Disabled
Quote:
Originally Posted by SfinxSoft View Post
P.P.S. Uploading the bash static binary and linking it to /bin/sh solved the issue completely - I've managed to install the distro.
Had the same problem.
Thanks to SfinxSoft solved in my case in 4 easy steps:

1) wget ftp://ftp.sh.cvut.cz/MIRRORS/slackwa...010-i486-1.txz
2) installpkg bash-4.1.010-i486-1.txz
[downloading bash package and installing it]

3) rm /bin/sh
4) ln /bin/bash /bin/sh
[replacing sh by bash - creating a link to bash in place of sh]

After that setup ran without any problem.
Thanks again
 
Old 04-08-2012, 12:08 AM   #11
willysr
Senior Member
 
Registered: Jul 2004
Location: Jogja, Indonesia
Distribution: Slackware-Current
Posts: 2,583

Rep: Reputation: 431Reputation: 431Reputation: 431Reputation: 431Reputation: 431
try to update your -Current ISO using the latest update. Pat has updated the initrd to use Genuine Bash instead of Busybox Ash
Quote:
Sat Apr 7 21:48:42 UTC 2012
l/libtiff-3.9.6-i486-1.txz: Upgraded.
Patched overflows that could lead to arbitrary code execution when parsing
a malformed image file.
For more information, see:
http://cve.mitre.org/cgi-bin/cvename...=CVE-2012-1173
(* Security fix *)
isolinux/initrd.img: Rebuilt.
Use genuine GNU bash instead of busybox ash. This fixes installer failure
caused by exported variables such as TERM failing to propogate to subshells.
I'm still not sure what's causing that issue (perhaps a change in glibc?),
but using real bash might be better in the long run, as we won't need to
avoid bashisms in the scripts. The original reason bash was avoided was to
keep things small for installer floppies, and we're well past that era.
usb-and-pxe-installers/usbboot.img: Rebuilt.
 
1 members found this post helpful.
Old 04-08-2012, 07:28 AM   #12
gmartin
Member
 
Registered: Mar 2003
Location: PA
Distribution: Slackware 13.37 Linux Reg # 341245
Posts: 285

Rep: Reputation: 40
Thanks, Willysr.
Looks like the x86_64 is a couple days behind ( at least the change log on Slackware.org). As soon as the change shows up I'll test it.
 
Old 04-08-2012, 07:39 AM   #13
Alien Bob
Slackware Contributor
 
Registered: Sep 2005
Location: Eindhoven, The Netherlands
Distribution: Slackware
Posts: 5,316

Rep: Reputation: Disabled
gmartin, you better check the actual changelog instead of the script-generated pretty-page. In http://slackware.osuosl.org/slackwar.../ChangeLog.txt you'll see that 64bit is as up-to-date as 32bit.

Eric
 
Old 04-08-2012, 08:51 AM   #14
willysr
Senior Member
 
Registered: Jul 2004
Location: Jogja, Indonesia
Distribution: Slackware-Current
Posts: 2,583

Rep: Reputation: 431Reputation: 431Reputation: 431Reputation: 431Reputation: 431
Yup, Pat uploaded all the 32/64 packages simultaneously, so they are all synched all the time
 
Old 04-08-2012, 11:25 AM   #15
gmartin
Member
 
Registered: Mar 2003
Location: PA
Distribution: Slackware 13.37 Linux Reg # 341245
Posts: 285

Rep: Reputation: 40
Yes. My local sync'd copy was up to date. Install went fine. Thanks for the tip.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
nano How-To for using X with nVidia GPUs on slackware-current after March 1 updates Didier Spaier Slackware 38 04-06-2010 11:37 AM
[SOLVED] # /etc/rc.d/rc.vboxdrv setup fails on -current gtludwig Slackware 4 03-31-2010 12:35 PM
Observation of Feb -current vs March -current Hangaber Slackware 14 03-12-2010 08:26 AM
[SOLVED] KDE desktop effects not working with Intel graphics (Slackware-Current; March 7, 2010 piratesmack Slackware 5 03-09-2010 08:08 AM


All times are GMT -5. The time now is 07:12 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration