LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
LinkBack Search this Thread
Old 12-18-2004, 07:44 AM   #16
JohnKFT
Member
 
Registered: Aug 2003
Location: NW Scotland
Distribution: Slackware 10
Posts: 169

Rep: Reputation: 30

I am not an expert but I think you are most unwise to connect to the internet as root. Anyone coming back down the line into your computer then has root privileges I think. Not clever at all. Do try wvdial - it is simple and reliable, easy to configure for any number of ISPs and I have a script you can use to set it up for non-root access. I tried chestnut-dialer, which was rather nice, but I seem to recall being horrified at the memory it consumed. Wvdial is very economical. It also automatically finds your modem and sets up the scripts for connection.
 
Old 12-18-2004, 11:09 PM   #17
ibanez862
LQ Newbie
 
Registered: Dec 2004
Distribution: Debian Etch
Posts: 14

Original Poster
Rep: Reputation: 0
It works now! I used the script gnashley provided. Though I didn't start named so i guess thats why it didn't work. Just one more thing though. How would I set it so a user can execute the script ppp-go and ppp-stop?
 
Old 12-19-2004, 02:02 AM   #18
gnashley
Amigo developer
 
Registered: Dec 2003
Location: Germany
Distribution: Slackware
Posts: 4,724

Rep: Reputation: 449Reputation: 449Reputation: 449Reputation: 449Reputation: 449
You don't need named for ispsetup.
ISPSETUP should have set up the permissions so that users have access usinf ppp-on and ppp-off. read /etc/ppp/pppscript.txt to see again the prompt you got after running it.
Thanks for testing that -my firts BASH hack. ISPSETUP is pppsetup with all the extra protocols stripped out and modified to use dynamic DNS and it gives users permission to the pppd. You can changee this if you like by looking through the script and finding where the permissions are set. There is a line for with/without user permissions.
 
Old 12-20-2004, 08:05 PM   #19
ibanez862
LQ Newbie
 
Registered: Dec 2004
Distribution: Debian Etch
Posts: 14

Original Poster
Rep: Reputation: 0
I checked my /etc/ppp/pppsetup.txt file and this is what is says about users using ppp-on:

# By default ispsetup allows normal users access to dial out using ppp-on
# Do: chmod 600 /etc/ppp/options to deny users access to ppp-on

im on a fairly fresh slackware install and it still won't let users use ppp-on. So how would I change it to where a user can use it?
 
Old 12-20-2004, 10:22 PM   #20
gnashley
Amigo developer
 
Registered: Dec 2003
Location: Germany
Distribution: Slackware
Posts: 4,724

Rep: Reputation: 449Reputation: 449Reputation: 449Reputation: 449Reputation: 449
Do this to check perms for ppd:
ls -l $(which pppd)
 
Old 12-20-2004, 11:04 PM   #21
ibanez862
LQ Newbie
 
Registered: Dec 2004
Distribution: Debian Etch
Posts: 14

Original Poster
Rep: Reputation: 0
root@darkstar:/home/kelly# ls -l $(which pppd)
-rwxr-xr-x 1 root bin 346812 2004-02-26 16:36 /usr/sbin/pppd
 
Old 12-21-2004, 10:25 AM   #22
gnashley
Amigo developer
 
Registered: Dec 2003
Location: Germany
Distribution: Slackware
Posts: 4,724

Rep: Reputation: 449Reputation: 449Reputation: 449Reputation: 449Reputation: 449
Maybe by using the full path:
/usr/sbin/ppp-on
?
 
Old 12-22-2004, 09:37 PM   #23
ibanez862
LQ Newbie
 
Registered: Dec 2004
Distribution: Debian Etch
Posts: 14

Original Poster
Rep: Reputation: 0
I created a sim link fron /usr/sbin/ppp-on to /usr/bin but it still said permision denied. Is there a certain group i have to be a member of in order to run it???
 
Old 12-26-2004, 12:00 PM   #24
gnashley
Amigo developer
 
Registered: Dec 2003
Location: Germany
Distribution: Slackware
Posts: 4,724

Rep: Reputation: 449Reputation: 449Reputation: 449Reputation: 449Reputation: 449
This should do it:
chmod 6755 /usr/sbin/pppd
 
Old 12-28-2004, 01:15 AM   #25
ibanez862
LQ Newbie
 
Registered: Dec 2004
Distribution: Debian Etch
Posts: 14

Original Poster
Rep: Reputation: 0
that did the trick! thanks alot!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
KPPP vs ppp-go in slackware pj320 Linux - Networking 1 07-26-2005 06:24 PM
kppp mdk10 ppp exit status 10 "CONNECT 44000/LAPM/" geek745 Linux - Networking 2 09-09-2004 11:04 PM
Kppp how to set in Dial up Script for PPP Keynote Red Hat 7 03-16-2004 04:02 PM
more reliable ppp dialup client than kppp? randomx Linux - Software 3 10-27-2003 09:45 PM
Apache settup failure poortl9109 Linux - Software 6 12-24-2002 05:56 AM


All times are GMT -5. The time now is 05:05 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration