LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 05-25-2005, 07:31 PM   #1
Kenji Miyamoto
Member
 
Registered: Dec 2004
Distribution: Mandrake 10.1; Fedora Core 3; FreeBSD 5.3; Slackware 10.1 (2.6.10);
Posts: 234

Rep: Reputation: 30
Setting up SCIM


I recall that you have to add something to your .xinitrc file to get SCIM to start when X does, but I forgot what it was. Does anybody else know?

Also, I can't seem to be able to read any Japanese character sets with UTF at the moment; should I be concerned?
 
Old 05-25-2005, 09:10 PM   #2
Kenji Miyamoto
Member
 
Registered: Dec 2004
Distribution: Mandrake 10.1; Fedora Core 3; FreeBSD 5.3; Slackware 10.1 (2.6.10);
Posts: 234

Original Poster
Rep: Reputation: 30
I got everything installed, but Ctrl+Space doesn't activate it.

Also, even with the FrontEnd Gtk font set to Code2000, it can't display the Unicode. The same font works in Firefox. What's going on?
 
Old 05-25-2005, 11:04 PM   #3
killerbob
Member
 
Registered: Oct 2004
Location: Ottawa, ON
Distribution: Slackware
Posts: 662

Rep: Reputation: 30
I wrote a howto recently that should explain how to do it.

http://killerbob.ca/howto/japanese.html

がんばってね。
(and I know you can't read that. it's because you don't have a Japanese font installed. That is also explained in the howto. )
 
Old 05-26-2005, 01:10 AM   #4
Kenji Miyamoto
Member
 
Registered: Dec 2004
Distribution: Mandrake 10.1; Fedora Core 3; FreeBSD 5.3; Slackware 10.1 (2.6.10);
Posts: 234

Original Poster
Rep: Reputation: 30
Actually, I've recently installed Arial Unicode MS and Code2000, so I can read it. (Isn't Code2000 the coolest?)

From past experience I've found that adding "scim -d" to .xinitrc also works; it loads completely and is operable within at least KDE.

NOTE: Beaver still complains abotu the "not supported" language when I enter Ctrl+Space. Do you think that the fact I'm using FVWM2-devel at the moment has something to do with it?

Last edited by Kenji Miyamoto; 05-26-2005 at 01:25 AM.
 
Old 05-26-2005, 08:40 AM   #5
killerbob
Member
 
Registered: Oct 2004
Location: Ottawa, ON
Distribution: Slackware
Posts: 662

Rep: Reputation: 30
If you install skim, KDE will load it automatically. You don't need to load it from .xinitrc or anything else.

As for FVWM, I honestly don't know. I tried it once, a while ago, and decided I didn't like it, and haven't even considered it since. Likewise, I've never used Beaver, so I can't answer that question.
 
Old 05-26-2005, 11:54 PM   #6
Kenji Miyamoto
Member
 
Registered: Dec 2004
Distribution: Mandrake 10.1; Fedora Core 3; FreeBSD 5.3; Slackware 10.1 (2.6.10);
Posts: 234

Original Poster
Rep: Reputation: 30
I have SCIM started as a daemon and the icon in the system tray, yet it still won't come up with the trigger hotkeys. What's going on?
 
Old 05-27-2005, 08:07 AM   #7
killerbob
Member
 
Registered: Oct 2004
Location: Ottawa, ON
Distribution: Slackware
Posts: 662

Rep: Reputation: 30
Did you edit the exports in /etc/profile.d/lang.sh?

You need these variables to be set, as well, else the IM won't actually be used, even if it's installed.

Code:
	export LC_CTYPE=ja_JP.utf8
	export XMODIFIERS=@im=SCIM
	export GTK_IM_MODULE=scim
	export QT_IM_MODULE=scim
 
Old 05-27-2005, 05:43 PM   #8
Kenji Miyamoto
Member
 
Registered: Dec 2004
Distribution: Mandrake 10.1; Fedora Core 3; FreeBSD 5.3; Slackware 10.1 (2.6.10);
Posts: 234

Original Poster
Rep: Reputation: 30
I copied it into /etc/profile.d/lang.sh, and it still doesn't work.
 
Old 05-27-2005, 06:18 PM   #9
killerbob
Member
 
Registered: Oct 2004
Location: Ottawa, ON
Distribution: Slackware
Posts: 662

Rep: Reputation: 30
Have you tried other WM's, or just FVWM?

And do you have Anthy installed? SCIM is useless without a language system installed. For Japanese, you need Anthy.
 
Old 05-27-2005, 06:19 PM   #10
gbonvehi
Senior Member
 
Registered: Jun 2004
Location: Argentina (SR, LP)
Distribution: Slackware
Posts: 3,145

Rep: Reputation: 51
You've to relogin so those exports take effect.
 
Old 05-27-2005, 06:22 PM   #11
Kenji Miyamoto
Member
 
Registered: Dec 2004
Distribution: Mandrake 10.1; Fedora Core 3; FreeBSD 5.3; Slackware 10.1 (2.6.10);
Posts: 234

Original Poster
Rep: Reputation: 30
I do have Anthhy and SCIM-Anthy installed. I've been trying it on KDE-3.4.0 for the past 24 hours or so. It does work with Skim, though.

For some reason, it doesn't seem to allow typing within the current window. It either uses a little side window that pops up or doesn't display until "space". How do I set it up so the Romaji and typing appear in the text area I'm typing in?
 
Old 05-27-2005, 07:24 PM   #12
killerbob
Member
 
Registered: Oct 2004
Location: Ottawa, ON
Distribution: Slackware
Posts: 662

Rep: Reputation: 30
You need to enable On-The-Fly mode, which will require a logout/login to take effect.

Right-click on your SCIM/SKIM icon in the system tray, and go to SCIM setup. Under Front End, go to X Window. Check the box that says "On The Fly". Apply, OK, Close, etc.

Logout, and log back in, and it should work.
 
Old 05-27-2005, 08:28 PM   #13
Kenji Miyamoto
Member
 
Registered: Dec 2004
Distribution: Mandrake 10.1; Fedora Core 3; FreeBSD 5.3; Slackware 10.1 (2.6.10);
Posts: 234

Original Poster
Rep: Reputation: 30
I have "On the Spot" enabled, and I just did reboot the system. Still, without the window option enabled, it doesn't enter the text dirlectly into the text area.
 
Old 05-28-2005, 05:12 AM   #14
shilo
Senior Member
 
Registered: Nov 2002
Location: Stockton, CA
Distribution: Slackware 11 - kernel 2.6.19.1 - Dropline Gnome 2.16.2
Posts: 1,132

Rep: Reputation: 49
Maybe somewhat OT, but:

Quote:
がんばってね。
(and I know you can't read that. it's because you don't have a Japanese font installed. That is also explained in the howto. )
I don't recall ever installing Japanese fonts, and I can see this just fine (using Firefox, Slackware -current, dropline Gnome). Is this not normal?
 
Old 05-28-2005, 07:53 AM   #15
killerbob
Member
 
Registered: Oct 2004
Location: Ottawa, ON
Distribution: Slackware
Posts: 662

Rep: Reputation: 30
The font may have been installed by your Gnome installation... I know from experience that a regular installation of Slackware (at least, my regular installation that doesn't include 100% of the packages) doesn't do it. When you don't have the font installed, instead you see squares with 4 numbers in 'em, and the way to fix it is to install a font that supports the language.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
scim does not show up yumener Linux - Software 2 10-12-2005 02:35 PM
Scim/skim ZeroKun Linux - Software 0 10-02-2005 02:44 AM
How do I install the scim??? lewkh Linux - Newbie 1 03-15-2005 09:43 PM
suse 9.2 and scim chenmenis Suse/Novell 1 02-19-2005 04:52 AM
SCIM problem hkl8324 Linux - Software 0 09-29-2004 05:59 AM


All times are GMT -5. The time now is 07:52 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration