LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 05-26-2011, 02:15 PM   #1
alkap
LQ Newbie
 
Registered: Apr 2011
Posts: 9

Rep: Reputation: 0
setting up network manager in fluxbox


I'm running Slackware 13.1 with fluxbox as my wm. I want to set up network-manager along with the pptp plugin. So far I've installed the NetworkManager and the network-manager-pptp plugin along with all the dependencies specified in the slackbuild packages which I downloaded from slackbuilds.org.

I could use some help configuring the network-manager so that I can launch it as a regular user rather than as root and I want it to come up in the fluxbox toolbar if possible.

Anyone's advice on how to do it would be much appreciated.

Alexander Kapshuk.
 
Old 05-26-2011, 03:25 PM   #2
kgs
Member
 
Registered: Apr 2011
Posts: 30

Rep: Reputation: 3
I don't know anything about network-manager, but I am sure someone who does will come along shortly.

Have you considered using wicd? It is a simple connection manager that is included in Slackware's /extra directory. I've used its graphical interface along with fluxbox in the past. It can run in the background with an icon in your taskbar. I would, personally, suggest it over network-manager as it is much easier to get running.

As far as running programs automatically when starting fluxbox, check in your $HOME/.fluxbox/startup config file. Look at the comments for directions. It's very simple, just add the commands to that file. Some programs will need an "&" symbol after them.
 
0 members found this post helpful.
Old 05-27-2011, 02:47 AM   #3
disturbed1
Senior Member
 
Registered: Mar 2005
Location: USA
Distribution: Slackware
Posts: 1,133
Blog Entries: 6

Rep: Reputation: 212Reputation: 212Reputation: 212
Give network-manager-applet a shot.
http://slackbuilds.org/repository/13...anager-applet/

Has some dependencies though (also SBo)
ORBit2
GConf
libtasn1
libgnome-keyring
gnome-keyring
 
Old 05-28-2011, 03:19 PM   #4
alkap
LQ Newbie
 
Registered: Apr 2011
Posts: 9

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by disturbed1 View Post
Give network-manager-applet a shot.
http://slackbuilds.org/repository/13...anager-applet/

Has some dependencies though (also SBo)
ORBit2
GConf
libtasn1
libgnome-keyring
gnome-keyring
Hi,
Thanks a lot for getting back to me. I have all but one of the dependent packages installed. perhaps I overlooked libgnome-keyring being a dependency when reading the README files for all the other dependencies.

I did add nm-applet & to my $HOME/.fluxbox/startup file. Here's what I get when I run nm-applet in my terminal:

Code:
bash-4.1$ nm-applet
** Message: applet now removed from the notification area

** (nm-applet:1888): WARNING **: get_all_cb: couldn't retrieve system settings properties: (2) The name org.freedesktop.NetworkManagerSystemSettings was not provided by any .service files.
** Message: applet now embedded in the notification area
** Message: applet now removed from the notification area

** (nm-applet:1888): WARNING **: fetch_connections_done: error fetching system connections: (2) The name org.freedesktop.NetworkManagerSystemSettings was not provided by any .service files.
How would I go about fixing that please?
 
Old 05-28-2011, 03:21 PM   #5
alkap
LQ Newbie
 
Registered: Apr 2011
Posts: 9

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by kgs View Post
I don't know anything about network-manager, but I am sure someone who does will come along shortly.

Have you considered using wicd? It is a simple connection manager that is included in Slackware's /extra directory. I've used its graphical interface along with fluxbox in the past. It can run in the background with an icon in your taskbar. I would, personally, suggest it over network-manager as it is much easier to get running.

As far as running programs automatically when starting fluxbox, check in your $HOME/.fluxbox/startup config file. Look at the comments for directions. It's very simple, just add the commands to that file. Some programs will need an "&" symbol after them.
thanks a lot for your reply.
i did look into using wicd, but it doesn't seem to support VPN at the moment, which is strongly desired.
 
Old 05-28-2011, 06:41 PM   #6
piratesmack
Member
 
Registered: Feb 2009
Distribution: Slackware, Arch
Posts: 517

Rep: Reputation: 132Reputation: 132
Add the following to your /etc/rc.d/rc.local:
Code:
if [ -x /etc/rc.d/rc.networkmanager ]; then
  /etc/rc.d/rc.networkmanager start
fi
And put this in your ~/.fluxbox/startup BEFORE the "exec fluxbox" line:
Code:
if [ -z "$DBUS_SESSION_BUS_ADDRESS" ]; then
  eval `dbus-launch --sh-syntax --exit-with-session`
fi
nm-applet --sm-disable &

Last edited by piratesmack; 06-07-2011 at 09:10 PM.
 
1 members found this post helpful.
Old 05-29-2011, 07:16 AM   #7
alkap
LQ Newbie
 
Registered: Apr 2011
Posts: 9

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by piratesmack View Post
Add the following to your /etc/rc.d/rc.local:
Code:
if [ -x /etc/rc.d/rc.networkmanager ]; then
  /etc/rc.d/rc.networkmanager start
fi
And put this in your ~/.fluxbox/startup BEFORE the "exec fluxbox" line:
Code:
if [ -z "$DBUS_SESSION_BUS_ADDRESS" ]; then
  eval `dbus-launch --sh-syntax --exit-with-session`
  export DBUS_SESSION_BUS_ADDRESS
fi
nm-applet --sm-disable &
thanks a lot! that did the trick.
was i supposed to do anything to /etc/dbus-1/system.d/NetworkManager.conf and/or /etc/dbus-1/system.d/nm-applet.conf

Below is what I put into my /etc/dbus-1/system.d/NetworkManager.conf as it wasn't there in the first place, possibly because i added myself to the netdev group after installing the NetworkManager along with its dependent packages. I just copied it over from my /etc/dbus-1/system.d/NetworkManager.conf on Debian.

Code:
<policy group="netdev">
        <allow send_destination="org.freedesktop.NetworkManager"/>

        <allow send_destination="org.freedesktop.NetworkManager"
            send_interface="org.freedesktop.DBus.Introspectable"/>

        <allow send_destination="org.freedesktop.NetworkManager"
            send_interface="org.freedesktop.DBus.Properties"/>

        <allow send_destination="org.freedesktop.NetworkManager"
            send_interface="org.freedesktop.NetworkManager"/>

        <allow send_destination="org.freedesktop.NetworkManager"
            send_interface="org.freedesktop.NetworkManager.AccessPoint"/>

        <allow send_destination="org.freedesktop.NetworkManager"
            send_interface="org.freedesktop.NetworkManager.Connection.Active"/>

        <allow send_destination="org.freedesktop.NetworkManager"
            send_interface="org.freedesktop.NetworkManager.Device.Cdma"/>

        <allow send_destination="org.freedesktop.NetworkManager"
            send_interface="org.freedesktop.NetworkManager.Device.Wired"/>

        <allow send_destination="org.freedesktop.NetworkManager"
            send_interface="org.freedesktop.NetworkManager.Device.Gsm"/>

        <allow send_destination="org.freedesktop.NetworkManager"
            send_interface="org.freedesktop.NetworkManager.Device.Serial"/>

        <allow send_destination="org.freedesktop.NetworkManager"
            send_interface="org.freedesktop.NetworkManager.Device.Wireless"/>

        <allow send_destination="org.freedesktop.NetworkManager"
            send_interface="org.freedesktop.NetworkManager.Device"/>

        <allow send_destination="org.freedesktop.NetworkManager"
            send_interface="org.freedesktop.NetworkManager.DHCP4Config"/>

        <allow send_destination="org.freedesktop.NetworkManager"
            send_interface="org.freedesktop.NetworkManager.IP4Config"/>

        <allow send_destination="org.freedesktop.NetworkManager"
            send_interface="org.freedesktop.NetworkManager.VPN.Connection"/>
Please let me know if I was supposed to do that or not.
 
Old 05-29-2011, 01:40 PM   #8
piratesmack
Member
 
Registered: Feb 2009
Distribution: Slackware, Arch
Posts: 517

Rep: Reputation: 132Reputation: 132
Quote:
Originally Posted by alkap View Post
was i supposed to do anything to /etc/dbus-1/system.d/NetworkManager.conf and/or /etc/dbus-1/system.d/nm-applet.conf
I don't think so, at least I didn't have to.
 
Old 05-29-2011, 02:33 PM   #9
alkap
LQ Newbie
 
Registered: Apr 2011
Posts: 9

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by piratesmack View Post
I don't think so, at least I didn't have to.
understood. thanks.

another quick question if i may...
i want to set up pptp vpn. i've installed the network-manager-pptp plugin as well as the pptp package. after entering all the details into the vpn setup wizzard thing and clicking on the vpn connection i've set up i get a vpn failed message saying no user settings service available.
does that mean i haven't got something set up that has to be set up for vpn to work properly?
 
Old 05-29-2011, 02:51 PM   #10
piratesmack
Member
 
Registered: Feb 2009
Distribution: Slackware, Arch
Posts: 517

Rep: Reputation: 132Reputation: 132
Sorry, I have no idea.
Hopefully someone else does.
 
Old 05-29-2011, 11:39 PM   #11
alkap
LQ Newbie
 
Registered: Apr 2011
Posts: 9

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by piratesmack View Post
Sorry, I have no idea.
Hopefully someone else does.
that's ok. thanks a lot for your help anyway!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] How do I switch the network manager from YAST back to the default network manager? skykooler Suse/Novell 7 03-09-2010 06:28 PM
I need a network manager that worked with debian base + fluxbox bbmak Linux - Wireless Networking 2 05-20-2009 01:19 AM
Setting up a openvpn connection on Network manager marozsas Linux - Networking 1 02-18-2009 07:01 AM
Setting up Network Manager VPN Connection dwhitney67 Linux - Software 0 09-26-2007 02:05 AM
Setting up Network Manager FC4 Malachai.77 Linux - Laptop and Netbook 0 03-22-2006 03:20 PM


All times are GMT -5. The time now is 11:53 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration