LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 03-31-2005, 07:28 AM   #1
xushi
Senior Member
 
Registered: Jun 2003
Location: UK
Distribution: Gentoo
Posts: 1,288

Rep: Reputation: 45
set system time


I don't know much about clocks.. but in xfce, and when i type clock, or date, i get
Thu 31 Mar 2005 01:21:45 PM BST -0.866873 seconds

when its supposed to be 2:21.
Thu Mar 31 13:27:00 BST 2005

My system's time didn't change with the summer/winter timechange last week.

If i manually set the clock, reboot, it goes back to the wrong time again. How can i correctly fix this problem?
 
Old 03-31-2005, 07:37 AM   #2
keefaz
Senior Member
 
Registered: Mar 2004
Distribution: Slackware
Posts: 4,614

Rep: Reputation: 136Reputation: 136
For my part I have a cron for root that set the time everyday at 21:00

0 21 * * * /usr/sbin/ntpdate uk.pool.ntp.org 1> /dev/null 2> /dev/null

(I set the time server to uk.pool.ntp.org here as I see you are in UK)
See http://ntp.isc.org/bin/view/Servers/NTPPoolServers
for more servers

[edit]
Could you post the output with :
ls -l /etc/localtime-copied-from

Last edited by keefaz; 03-31-2005 at 07:43 AM.
 
Old 03-31-2005, 08:31 AM   #3
masonm
Senior Member
 
Registered: Mar 2003
Location: Following the white rabbit
Distribution: Slackware64 13.37 Android 4.0
Posts: 2,248

Rep: Reputation: 46
Sounds like a problem with the hardware clock or you have the wronf locale set for localtime.

Last edited by masonm; 03-31-2005 at 08:33 AM.
 
Old 03-31-2005, 08:56 AM   #4
Nobber
Member
 
Registered: Jun 2002
Location: Nova Scotia
Distribution: Debian (home), Kubuntu 7.04 (work)
Posts: 265

Rep: Reputation: 30
Sounds as if you need to run timeconfig. That should correctly set up /etc/hardwareclock and /etc/localtime.

On my machine, /etc/hardwareclock contains the line:

UTC

(indicating that my hardware clock is set to UTC - as it should be), and /etc/localtime is a copy of /usr/share/zoneinfo/Europe/London (I'm in the UK too).
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
how to set and sync system time with time server?? servnov Linux - Newbie 6 12-03-2013 07:55 PM
Doub about `net time set` and daylight saving time Thakowbbery Linux - Software 0 10-17-2005 05:23 AM
Erm, how do I set my system date/time? vasudevadas Slackware 4 09-14-2004 03:40 PM
Setting System Time: kernel in wrong time zone warrenweiss Linux - General 7 05-15-2004 03:25 PM
how set system time by command prompt? yenonn Linux - Newbie 9 08-25-2003 06:40 PM


All times are GMT -5. The time now is 12:21 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration