LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 02-15-2014, 01:06 PM   #1
Miranden
Member
 
Registered: May 2012
Posts: 188

Rep: Reputation: 19
Set maximum CPU frequency?


I have a laptop that always overheats, and I want to set my maximum CPU frequency at something like 80 percent. However, I am not sure what utilities exist to allow me to do this. I have seen this:

http://docs.slackware.com/howtos:har...quency_scaling

But there doesn't seem to be an option to set a maximum frequency. I also don't think Laptop Mode Tools will do it.

Does anyone know how I can do this?

Thanks.
 
Old 02-15-2014, 01:17 PM   #2
genss
Member
 
Registered: Nov 2013
Posts: 179

Rep: Reputation: Disabled
other then by some tool (like i use enlightenments CpuFreq widget)

check /usr/src/`uname -r`/Documentation/cpu-freq/user-guide.txt

section 3 says:

Code:
The preferred interface is located in the sysfs filesystem. If you
mounted it at /sys, the cpufreq interface is located in a subdirectory
"cpufreq" within the cpu-device directory
(e.g. /sys/devices/system/cpu/cpu0/cpufreq/ for the first CPU).

cpuinfo_max_freq :		this file shows the maximum operating
				frequency the processor can run at(in kHz)
and a couple other things/hints
i put the kernel documentation as it is a kernel thing so if it changes in the future you know where to look
note you probably need to set it as root

also check out powertop, its a great tool for power saving
 
1 members found this post helpful.
Old 02-15-2014, 01:51 PM   #3
metaschima
Member
 
Registered: Dec 2013
Distribution: Slackware
Posts: 973

Rep: Reputation: Disabled
Have you tried other methods, such as cleaning out the fan vents using compressed air ?

If you really had to limit the CPU frequency you should use a userspace program to set the CPU frequency. Slackware already has the userspace governor enabled.

For example you can use 'cpufreq-set --cpu 0 -r --max 800' or you can cat into '/sys/devices/system/cpu/cpu0/cpufreq/scaling_set_speed'.
 
1 members found this post helpful.
Old 02-16-2014, 01:10 PM   #4
Miranden
Member
 
Registered: May 2012
Posts: 188

Original Poster
Rep: Reputation: 19
Thanks to you both. Yes, I have checked everything, and I'm sure it isn't a problem with dust. The fan vents are perfectly clear. This thing just runs hot. It also has a really loud, annoying fan, so I also always use a separate cooling mat underneath it to cut down on fan noise. AND I have an extra-large battery in it, so it is propped up at an angle which allows air flow underneath. Just take it from me: do not buy an HP Pavilion laptop.

I will use the cpufreq-set. Thanks again!
 
Old 02-16-2014, 01:51 PM   #5
TracyTiger
Member
 
Registered: Apr 2011
Location: California, USA
Distribution: Slackware
Posts: 258

Rep: Reputation: 59
Quote:
Originally Posted by Miranden View Post
It also has a really loud, annoying fan, so I also always use a separate cooling mat underneath it to cut down on fan noise.
I don't know if this is your case or not, but this is just a general note about a "cooling mat" that includes fans.

Assuming a laptop has it's air intake or exhaust opening(s) on the bottom and not the sides, you can have a situation where the "cooling mat" and the laptop are fighting each other rather than blowing the air in the same direction. That is, the "cooling mat" may actually be impeding airflow through the laptop.
 
Old 02-16-2014, 02:00 PM   #6
genss
Member
 
Registered: Nov 2013
Posts: 179

Rep: Reputation: Disabled
Quote:
Originally Posted by Miranden View Post
Just take it from me: do not buy an HP Pavilion laptop.
don't buy hp anything laptop
buy.. what was it acer or asus, its better performance, quality, price and easier maintenance
 
Old 02-16-2014, 11:33 PM   #7
Kallaste
Member
 
Registered: Nov 2011
Distribution: Slackware
Posts: 344

Rep: Reputation: 84
deleted
 
Old 02-17-2014, 05:37 AM   #8
TobiSGD
Moderator
 
Registered: Dec 2009
Location: Hanover, Germany
Distribution: Gentoo
Posts: 15,438
Blog Entries: 2

Rep: Reputation: 4001Reputation: 4001Reputation: 4001Reputation: 4001Reputation: 4001Reputation: 4001Reputation: 4001Reputation: 4001Reputation: 4001Reputation: 4001Reputation: 4001
Are you sure that the heat is even generated by the CPU? It also could be the GPU that produces the heat, for example in case of a Radeon GPU used with the free radeon drivers.
 
Old 02-19-2014, 12:57 AM   #9
zrdc28
Member
 
Registered: Dec 2007
Location: Alabama USA
Distribution: Slackware current
Posts: 248

Rep: Reputation: 40
I will agree with tobisgd that you might need to make sure that you have the correct driver for your video. On my laptop with the neauveau driver it has a real problem with overheating. Do a lspci and look at it to make sure what driver you need. Then do a lsmod to check what module is loaded.
 
Old 03-15-2014, 09:37 PM   #10
ssokolow
LQ Newbie
 
Registered: Aug 2004
Location: Canada
Posts: 24

Rep: Reputation: 16
For anyone who happens to wander in off Google, a more appropriate solution would probably be to use cpufreqd to dynamically adjust the speed limit on your CPU.

That way you can still use full speed in short bursts.

Here's the config file I use with an HP small form factor desktop PC that has the same problem.
 
1 members found this post helpful.
Old 03-15-2014, 10:56 PM   #11
Miranden
Member
 
Registered: May 2012
Posts: 188

Original Poster
Rep: Reputation: 19
Quote:
Originally Posted by TobiSGD View Post
Are you sure that the heat is even generated by the CPU? It also could be the GPU that produces the heat, for example in case of a Radeon GPU used with the free radeon drivers.
Sorry, my subscription preferences were messed up and I just saw these last few posts. I'm sure no one remembers this anymore, but to answer your question, the reason I was sure it was the cpu was because when I set the max cpu frequency under Windows, it eliminated the problem. Without it it would overheat and shut off. Thanks for the idea.

Tracy, my cooling mat is not causing the problem. The cooling mat was my response to the problem. The laptop just runs hot.

Quote:
Originally Posted by ssokolow View Post
For anyone who happens to wander in off Google, a more appropriate solution would probably be to use cpufreqd to dynamically adjust the speed limit on your CPU.

That way you can still use full speed in short bursts.

Here's the config file I use with an HP small form factor desktop PC that has the same problem.
Thanks for that. Might try it if I ever need more performance. I used the solution of cpufreq-set to limit the maximum cpu frequency to 85 percent, and that has made it cooler.

Last edited by Miranden; 03-15-2014 at 10:57 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
how to underclock AMD Phenom, set minimum CPU frequency lower than allowed m00ny Linux - Kernel 1 10-28-2013 03:15 PM
CPU governor fails to set frequency on Atom 230 Weapon S Linux - Hardware 2 03-21-2013 02:55 AM
[SOLVED] KPowerSave can't set CPU frequency policy killy9999 Linux - Laptop and Netbook 1 04-19-2011 11:03 AM
process is hanging on high cpu load even if its priority is set to the maximum yucefrizk Linux - Enterprise 16 06-23-2010 02:34 AM
cpu frequency scaling with Pentium(R) Dual-Core CPU E5200 @ 2.50GHz tramni1980 Slackware 5 08-16-2009 08:29 AM


All times are GMT -5. The time now is 08:31 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration