LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices



Reply
 
Search this Thread
Old 02-21-2012, 01:55 AM   #1
WiseDraco
Member
 
Registered: Nov 2006
Location: Europe,Latvia,Riga
Distribution: slackware,slax, exMandriva
Posts: 401

Rep: Reputation: 41
set Locale for root?


Hello again!
i there with locale problem - i set it up in /etc/profile.d/lang.csh & lang.sh set to en_US.UTF-8
now user locale reports a UTF-8, and that's is ok.
but when i su to root, and look root locale, output to command "locale " shows:
LANG=
LC_CTYPE="POSIX"
LC_NUMERIC="POSIX"
LC_TIME="POSIX"
LC_COLLATE="POSIX"
LC_MONETARY="POSIX"
LC_MESSAGES="POSIX"
LC_PAPER="POSIX"
LC_NAME="POSIX"
LC_ADDRESS="POSIX"
LC_TELEPHONE="POSIX"
LC_MEASUREMENT="POSIX"
LC_IDENTIFICATION="POSIX"
LC_ALL=


very strange to me. as so, under root i see undefined symbols in file and catalog names in cyrillic and so on.
have a two questions - i thinked, a lang definet in profile.d is system- wide lang definition? for what it is not affect to root user?
and what i can change root's locale ?
 
Old 02-21-2012, 02:07 AM   #2
T3slider
Senior Member
 
Registered: Jul 2007
Distribution: Slackware64-14.1
Posts: 2,298

Rep: Reputation: 722Reputation: 722Reputation: 722Reputation: 722Reputation: 722Reputation: 722Reputation: 722
Scripts in /etc/profile.d/ are only read by login shells. If you use `su -` instead of just `su` you should get the proper locale settings. If you want them in non-login shells as well, then you should add the same export/setenv command to root's .bashrc (or other equivalent for whatever shell you use).
 
Old 02-21-2012, 02:36 AM   #3
WiseDraco
Member
 
Registered: Nov 2006
Location: Europe,Latvia,Riga
Distribution: slackware,slax, exMandriva
Posts: 401

Original Poster
Rep: Reputation: 41
ok, thank you!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
locale: Cannot Set LC_ALL to default locale: No such file or directory. asym Linux - General 10 03-24-2013 09:35 PM
[SOLVED] How to set the system locale? catkin Slackware 6 03-06-2010 11:41 AM
"locale not supported by Xlib, locale set to C" Irad Linux - Software 3 06-25-2006 04:59 PM
locale: Cannot set LC_ALL to default locale: Invalid argument GadgetWiz Mandriva 1 04-01-2006 12:38 AM
set locale... pixelV Linux - Software 14 03-17-2003 08:34 PM


All times are GMT -5. The time now is 05:06 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration