LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 07-25-2010, 09:18 AM   #1
bassmadrigal
Member
 
Registered: Nov 2003
Location: Newport News, VA
Distribution: Slackware
Posts: 183

Rep: Reputation: 34
Set DPI Globally


I finally upgraded my laptop from Slack 12.1 to 13.1. Normally when I have upgraded in the past, I copy old scripts over, copy old configs and many other things. But this time, I decided that I wanted to start fresh. No reason to have an xorg.conf if xorg can possibly run without it without any issues. It has been rough, because I have used many of these for so long. But there have been so many different changes since I started out with this laptop back with 10.2.

Now, the biggest thing I have been trying to figure out is a way to set the dpi. With my laptop, I need it set to 72 for it to look proper. In the past I just setup an alias to startx for "startx - --dpi 72". I was originally planning on just setting up the alias again, but I would think there is a better way to do that. I did find the section in KDE settings under appearance and fonts to set the dpi, but the only options are 96 (currently the default according to xdpyinfo) or 120. I would also like to set it as default for any user logging on rather than setting it on a per-user basis. So I would like to keep it out of the users home directory.

So, to simplify, is there a way to set the dpi for X globally on the computer to 72?

Thanks
Jeremy
 
Old 07-25-2010, 11:14 AM   #2
Cheesesteak
Member
 
Registered: Jun 2008
Distribution: Slackware
Posts: 100

Rep: Reputation: 24
Place your dpi preference in the defaultserverargs line in /usr/bin/startx, which is a script.

Code:
defaultserverargs="-dpi 72"
That should do the trick.

Last edited by Cheesesteak; 07-25-2010 at 11:17 AM.
 
1 members found this post helpful.
Old 07-25-2010, 03:55 PM   #3
acummings
Member
 
Registered: Jul 2004
Distribution: Slackware
Posts: 615

Rep: Reputation: 49
FWIW, though you are using startx, someone else may use run level 4 (or, kdm)

If you use kdm (runlevel 4), you can edit /etc/kde/kdm/kdmrc. Line 468:


ServerArgsLocal=-nolisten tcp

Change it to:


ServerArgsLocal=-nolisten tcp -dpi 100
 
1 members found this post helpful.
  


Reply

Tags
dpi, global, xorg


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Want to set dpi JosephS Slackware 11 01-07-2009 07:41 PM
How do I set the DPI? JosephS Linux - Desktop 1 12-30-2008 09:48 PM
The dpi parameter: where is it set? grautu Debian 1 01-10-2006 11:44 AM
Howto set PATH globally? kinetik Linux - General 5 01-04-2006 11:41 AM
Globally set PATH for all users glock19 Red Hat 8 11-09-2003 02:25 PM


All times are GMT -5. The time now is 01:42 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration