LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   Set DPI Globally (http://www.linuxquestions.org/questions/slackware-14/set-dpi-globally-822049/)

bassmadrigal 07-25-2010 10:18 AM

Set DPI Globally
 
I finally upgraded my laptop from Slack 12.1 to 13.1. Normally when I have upgraded in the past, I copy old scripts over, copy old configs and many other things. But this time, I decided that I wanted to start fresh. No reason to have an xorg.conf if xorg can possibly run without it without any issues. It has been rough, because I have used many of these for so long. But there have been so many different changes since I started out with this laptop back with 10.2.

Now, the biggest thing I have been trying to figure out is a way to set the dpi. With my laptop, I need it set to 72 for it to look proper. In the past I just setup an alias to startx for "startx - --dpi 72". I was originally planning on just setting up the alias again, but I would think there is a better way to do that. I did find the section in KDE settings under appearance and fonts to set the dpi, but the only options are 96 (currently the default according to xdpyinfo) or 120. I would also like to set it as default for any user logging on rather than setting it on a per-user basis. So I would like to keep it out of the users home directory.

So, to simplify, is there a way to set the dpi for X globally on the computer to 72?

Thanks
Jeremy

Cheesesteak 07-25-2010 12:14 PM

Place your dpi preference in the defaultserverargs line in /usr/bin/startx, which is a script.

Code:

defaultserverargs="-dpi 72"
That should do the trick.

acummings 07-25-2010 04:55 PM

FWIW, though you are using startx, someone else may use run level 4 (or, kdm)

If you use kdm (runlevel 4), you can edit /etc/kde/kdm/kdmrc. Line 468:


ServerArgsLocal=-nolisten tcp

Change it to:


ServerArgsLocal=-nolisten tcp -dpi 100


All times are GMT -5. The time now is 10:43 PM.