LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices



Reply
 
Search this Thread
Old 12-05-2013, 03:59 PM   #1
Miranden
Member
 
Registered: May 2012
Distribution: Slackware
Posts: 205

Rep: Reputation: 19
Set a persistent background with fluxbox when I have xfce configured as default


I have xfce as my default window manager, which I set with xwmconfig. However, I also use fluxbox from time to time. I know that I can use fbsetbg to set the background in fluxbox, but I would like to have it set up so I don't have to do this every time I reboot or restart X. I thought I could accomplish this by putting

Code:
exec fbsetbg -l
in my ~/.xinitrc, but it does not work. However, I know I had it working before when I used fluxbox exclusively, and I could swear this was how I did it. Does it have something to do with the fact that fluxbox is not now the default? When I start fluxbox now, I do it with

Code:
startx /usr/bin/fluxbox
Does anyone know how I can keep the background I set in fluxbox between reboots? I would rather use the tools included with Slackware than download something else like feh. Incidentally, I don't even need different backgrounds for fluxbox and xfce--the same one will be used for both.

Help appreciated.
 
Old 12-05-2013, 04:04 PM   #2
astrogeek
Senior Member
 
Registered: Oct 2008
Distribution: Slackware [64]X{.0|.1|.2|-current} ::X>=12<=14, FreeBSD_10{.0|.1}
Posts: 2,165

Rep: Reputation: 848Reputation: 848Reputation: 848Reputation: 848Reputation: 848Reputation: 848Reputation: 848
I think you need to do that in ~/.fluxbox/startup

Code:
fbsetbg -f /path/to/background/image
*** UPDATE ***

After providing the above answer (which should be correct), I recalled that I once had difficulty getting the background image to work as expected.

Looking at my notes I found that it was due to the default theme that I had added which itself did not use a background image but prevented the one I specified from showing up.

So if you experience any difficulty getting it to work, you might temporarily disable any theme you have enabled and see if that work. If so, you can remove the background line(s) from the theme and re-enable it.

Last edited by astrogeek; 12-05-2013 at 04:38 PM.
 
2 members found this post helpful.
Old 12-05-2013, 04:54 PM   #3
Miranden
Member
 
Registered: May 2012
Distribution: Slackware
Posts: 205

Original Poster
Rep: Reputation: 19
Nope, no theme problems, it works the way you said. I guess I should have tried that, but I am sure when I had this working before it was with this command in .xinitrc. I even put it in my notes. Ah, who knows. It is working now.

Thanks, Astrogeek.
 
Old 12-05-2013, 05:14 PM   #4
astrogeek
Senior Member
 
Registered: Oct 2008
Distribution: Slackware [64]X{.0|.1|.2|-current} ::X>=12<=14, FreeBSD_10{.0|.1}
Posts: 2,165

Rep: Reputation: 848Reputation: 848Reputation: 848Reputation: 848Reputation: 848Reputation: 848Reputation: 848
Great! You are welcome!
 
Old 12-05-2013, 08:07 PM   #5
Bertman123
Member
 
Registered: Jun 2010
Distribution: Slackware 14.1 64 bit MLED with KDE
Posts: 243

Rep: Reputation: 32
Another option is to install Wally from slackbuilds.org and have it listed in the startup file - wally &.

I found that to be a better option for Fluxbox.
 
Old 12-05-2013, 10:45 PM   #6
frankbell
Guru
 
Registered: Jan 2006
Location: Virginia, USA
Distribution: Slackware, Mageia, Mint
Posts: 8,236

Rep: Reputation: 1556Reputation: 1556Reputation: 1556Reputation: 1556Reputation: 1556Reputation: 1556Reputation: 1556Reputation: 1556Reputation: 1556Reputation: 1556Reputation: 1556
Quote:
I guess I should have tried that, but I am sure when I had this working before it was with this command in .xinitrc. I even put it in my notes. Ah, who knows. It is working now.
Putting the command in .fluxbox/startup is the canonical way to execute it.

I actually have a little two-line script to tell fbsetbg to rotate the wallpaper every 30 minutes. I start the script from .fluxbox/startup; the script calls fbsetbg, which sets a wallpaper from the target directory with the random (-R) argument; fbsetbg sleeps for 30 minutes, then sets another wallpaper.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
How to set the default gateway if I configured IPv4 and IPv6 address? leericlapton Linux - Networking 1 10-26-2011 08:57 AM
Fluxbox help with default text apps background and foreground romandas Linux - Desktop 1 03-24-2007 11:32 AM
Fluxbox can't set background! humbletech99 Linux - Software 8 06-03-2006 07:58 PM
set a background permanently in fluxbox Vincent Slackware 10 01-16-2004 01:32 PM
how to set fluxbox background? Vincent Slackware 3 11-02-2003 04:43 PM


All times are GMT -5. The time now is 08:10 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration