LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   Set a persistent background with fluxbox when I have xfce configured as default (http://www.linuxquestions.org/questions/slackware-14/set-a-persistent-background-with-fluxbox-when-i-have-xfce-configured-as-default-4175487020/)

Miranden 12-05-2013 02:59 PM

Set a persistent background with fluxbox when I have xfce configured as default
 
I have xfce as my default window manager, which I set with xwmconfig. However, I also use fluxbox from time to time. I know that I can use fbsetbg to set the background in fluxbox, but I would like to have it set up so I don't have to do this every time I reboot or restart X. I thought I could accomplish this by putting

Code:

exec fbsetbg -l
in my ~/.xinitrc, but it does not work. However, I know I had it working before when I used fluxbox exclusively, and I could swear this was how I did it. Does it have something to do with the fact that fluxbox is not now the default? When I start fluxbox now, I do it with

Code:

startx /usr/bin/fluxbox
Does anyone know how I can keep the background I set in fluxbox between reboots? I would rather use the tools included with Slackware than download something else like feh. Incidentally, I don't even need different backgrounds for fluxbox and xfce--the same one will be used for both.

Help appreciated.

astrogeek 12-05-2013 03:04 PM

I think you need to do that in ~/.fluxbox/startup

Code:

fbsetbg -f /path/to/background/image
*** UPDATE ***

After providing the above answer (which should be correct), I recalled that I once had difficulty getting the background image to work as expected.

Looking at my notes I found that it was due to the default theme that I had added which itself did not use a background image but prevented the one I specified from showing up.

So if you experience any difficulty getting it to work, you might temporarily disable any theme you have enabled and see if that work. If so, you can remove the background line(s) from the theme and re-enable it.

Miranden 12-05-2013 03:54 PM

Nope, no theme problems, it works the way you said. I guess I should have tried that, but I am sure when I had this working before it was with this command in .xinitrc. I even put it in my notes. Ah, who knows. It is working now.

Thanks, Astrogeek. :)

astrogeek 12-05-2013 04:14 PM

Great! You are welcome!

Bertman123 12-05-2013 07:07 PM

Another option is to install Wally from slackbuilds.org and have it listed in the startup file - wally &.

I found that to be a better option for Fluxbox.

frankbell 12-05-2013 09:45 PM

Quote:

I guess I should have tried that, but I am sure when I had this working before it was with this command in .xinitrc. I even put it in my notes. Ah, who knows. It is working now.
Putting the command in .fluxbox/startup is the canonical way to execute it.

I actually have a little two-line script to tell fbsetbg to rotate the wallpaper every 30 minutes. I start the script from .fluxbox/startup; the script calls fbsetbg, which sets a wallpaper from the target directory with the random (-R) argument; fbsetbg sleeps for 30 minutes, then sets another wallpaper.


All times are GMT -5. The time now is 01:34 AM.