LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 01-15-2004, 01:21 PM   #1
Vincent
Member
 
Registered: Feb 2003
Location: Germany
Distribution: Slackware 9.1
Posts: 77

Rep: Reputation: 15
set a background permanently in fluxbox


I use wmsetbg in order to set a background-wallpaper. This works nicely but once I restart X the background is gone. I've tried to put a line in the ~/.fluxbox/startup file but without success.
Code:
# You can set your favourite wallpaper here if you don't want
# to do it from your style.
#
wmsetbg pics/wallies/linux-1280.jpg
#
# This sets a black background

#/usr/X11R6/bin/bsetroot -solid black
Who can help?
 
Old 01-15-2004, 01:30 PM   #2
Tinkster
Moderator
 
Registered: Apr 2002
Location: in a fallen world
Distribution: slackware by choice, others too :} ... android.
Posts: 22,978
Blog Entries: 11

Rep: Reputation: 879Reputation: 879Reputation: 879Reputation: 879Reputation: 879Reputation: 879Reputation: 879
I'm not using that feature, but seeing how
setroot was called with a fully qualified
path, maybe you want to do that with
wmsetbg, too? :)



Cheers,
Tink
 
Old 01-15-2004, 01:35 PM   #3
acid_kewpie
Moderator
 
Registered: Jun 2001
Location: UK
Distribution: Gentoo, RHEL, Fedora, Centos
Posts: 43,397

Rep: Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963
personally i'd say edit the theme, change the rootCommand entry to suit your needs.
 
Old 01-15-2004, 02:00 PM   #4
Vincent
Member
 
Registered: Feb 2003
Location: Germany
Distribution: Slackware 9.1
Posts: 77

Original Poster
Rep: Reputation: 15
I've changed the line to the full path and added the same to the root command, but it failed again.
 
Old 01-15-2004, 02:32 PM   #5
Tinkster
Moderator
 
Registered: Apr 2002
Location: in a fallen world
Distribution: slackware by choice, others too :} ... android.
Posts: 22,978
Blog Entries: 11

Rep: Reputation: 879Reputation: 879Reputation: 879Reputation: 879Reputation: 879Reputation: 879Reputation: 879
How about a fully qualified path to the picture? :)

Btw, what I do (old flux 0.1.14) is to run
bsetbg <path to images>&
from
~/.xsession ;) ... no modfied themes or anything.


Cheers,
Tink
 
Old 01-15-2004, 02:48 PM   #6
Scruff
Member
 
Registered: Oct 2002
Location: Stoughton, MA
Distribution: Gentoo x86_64 & PPC
Posts: 949

Rep: Reputation: 30
I just include the wmsetbg command at the end of my .xinitrc file like this:

# Start the window manager:
exec /usr/X11R6/bin/fluxbox &
wmsetbg custom/wallpaper/chaos.jpg

Make sure to include the '&' at the end of the exec line so the script will continue past to the next line.
 
Old 01-15-2004, 10:37 PM   #7
Vincent_Vega
Member
 
Registered: Nov 2003
Location: Jacksonville, FL
Distribution: Slackware & Arch
Posts: 825

Rep: Reputation: 31
go to the file for the style you're using (/usr/X11R6/shared/fluxbox/styles/<style_name>) and edit the rootCommand line changing the path to the pic of your choice. Worked fine for me.
**edit**
or cp the style file to another name all together and edit that one so you can keep the original like it was.

Last edited by Vincent_Vega; 01-15-2004 at 10:38 PM.
 
Old 01-15-2004, 10:43 PM   #8
Scruff
Member
 
Registered: Oct 2002
Location: Stoughton, MA
Distribution: Gentoo x86_64 & PPC
Posts: 949

Rep: Reputation: 30
Vincent Vega....
Cool nick
 
Old 01-15-2004, 10:48 PM   #9
Vincent_Vega
Member
 
Registered: Nov 2003
Location: Jacksonville, FL
Distribution: Slackware & Arch
Posts: 825

Rep: Reputation: 31
Smile

thanks!!
 
Old 01-16-2004, 05:02 AM   #10
nesware
Member
 
Registered: Jan 2004
Location: belgium
Distribution: Slackware
Posts: 117

Rep: Reputation: 15
or put the style in ~/.fluxbox/styles and edit the rootCommand there
 
Old 01-16-2004, 12:32 PM   #11
chemtraX
LQ Newbie
 
Registered: Nov 2003
Distribution: slackware 9.1
Posts: 12

Rep: Reputation: 0
fbsetbg is the replacement for bsetbg in fluxbox. you can have permenant wallpaper setting everytime you login to fluxbox. just set the rootCommand in ~/.fluxbox/init file:

Code:
*.*.rootCommand        DISPLAY:0.0  fbsetbg -l
also download and install fluxbox-generate_menu.(in my opinion) a great combination with the fbsetbg tool.

give it a try...sure it will look nice on your fluxbox desktop.

download the tools here and dont forget to read the howto.

http://www.fluxbox.org/download.php
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
How do I change the background color of xterm permanently? vxc69 Linux - Software 7 11-19-2004 02:27 PM
how to set fluxbox background? Vincent Slackware 3 11-02-2003 03:43 PM
How to set path permanently for a particular user Sifvion Slackware 14 10-16-2002 11:02 AM
How to set PATH permanently chandhru Linux - Newbie 3 09-24-2002 12:43 AM
bsetbg, set background permanently nutshell Linux - General 2 06-13-2002 03:07 AM


All times are GMT -5. The time now is 09:08 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration