LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 07-03-2013, 08:57 AM   #1
tronayne
Senior Member
 
Registered: Oct 2003
Location: Northeastern Michigan, where Carhartt is a Designer Label
Distribution: Slackware 32- & 64-bit Stable
Posts: 3,043

Rep: Reputation: 762Reputation: 762Reputation: 762Reputation: 762Reputation: 762Reputation: 762Reputation: 762
Sendmail -- What Did I Forget?


I've done a clean install of Slackware 64-bit 14.0 (fully patched) on a laptop. On all my systems, sendmail "just works;" i.e., I can
Code:
mailx -s "This is a Test Message" trona
This is a test message.
Ctrl-D
and the message gets sent, but not on this one. The sendmail is running and looks the same on the new installation as it does on all the other boxes. I don't do any configuration for sendmail (and have a couple of applications that use it to send mail to the outside world with no problems).

What the heck have I forgotten to turn on? /etc/rc.d looks like
Code:
./         rc.autofs       rc.inet1*           rc.modules-3.2.45*  rc.sendmail*      rc.yp
../        rc.bind         rc.inet1.conf       rc.mysqld           rc.serial         rc0.d/
init.d/    rc.bluetooth    rc.inet2*           rc.networkmanager   rc.snmpd          rc1.d/
rc.0@      rc.cgconfig     rc.inetd*           rc.nfsd             rc.sshd*          rc2.d/
rc.4*      rc.cgred        rc.ip_forward       rc.ntpd*            rc.syslog*        rc3.d/
rc.6*      rc.consolekit*  rc.local*           rc.pcmcia           rc.sysstat        rc4.d/
rc.K*      rc.cups*        rc.local_shutdown*  rc.php-fpm          rc.sysvinit*      rc5.d/
rc.M*      rc.dnsmasq      rc.loop*            rc.php-fpm.new      rc.tomcat*        rc6.d/
rc.S*      rc.font         rc.mcelog*          rc.postgresql*      rc.udev*
rc.acpid*  rc.fuse*        rc.messagebus*      rc.rpc              rc.wicd*
rc.alsa*   rc.gpm*         rc.modules@         rc.samba            rc.wireless*
rc.atalk   rc.httpd        rc.modules-3.2.29*  rc.saslauthd        rc.wireless.conf
 
Old 07-03-2013, 09:27 AM   #2
zhjim
Senior Member
 
Registered: Oct 2004
Distribution: Debian Squeeze x86_64
Posts: 1,446
Blog Entries: 11

Rep: Reputation: 182Reputation: 182
Check the log files of mail. Should be /var/log/mail.log. ls /var/log/mail.*. There should be four files.
 
Old 07-03-2013, 09:43 AM   #3
tronayne
Senior Member
 
Registered: Oct 2003
Location: Northeastern Michigan, where Carhartt is a Designer Label
Distribution: Slackware 32- & 64-bit Stable
Posts: 3,043

Original Poster
Rep: Reputation: 762Reputation: 762Reputation: 762Reputation: 762Reputation: 762Reputation: 762Reputation: 762
A check of /var/log/maillog shows
Code:
Jul  3 10:29:56 pita sm-mta[16481]: r61KCwbf006996: to=<trona@pita.com>, delay=1+18:16:39, xdelay=00:00:00, mailer=esmtp, pri=9300454, relay=pita.com.com., dsn=4.0.0, stat=Deferred: Connection refused by pita.com.com.
Uh-oh, where the heck is pita.com.com coming from?

pita's entry in /etc/hosts is
Code:
192.168.1.30		pita.com pita
and that is the content of /etc/HOSTNAME, looks like somebody, somewhere is adding the extra .com -- just who might that be?

Cripes.
 
Old 07-03-2013, 10:00 AM   #4
zhjim
Senior Member
 
Registered: Oct 2004
Distribution: Debian Squeeze x86_64
Posts: 1,446
Blog Entries: 11

Rep: Reputation: 182Reputation: 182
I dunno much about sendmail but maybe it needs a FQDN? With a dot at the end. Okay lets check the hostnames and alike
PHP Code:
hosntame
hostname 
-A
hostname 
-d
hostname 
-
 
Old 07-03-2013, 10:18 AM   #5
tronayne
Senior Member
 
Registered: Oct 2003
Location: Northeastern Michigan, where Carhartt is a Designer Label
Distribution: Slackware 32- & 64-bit Stable
Posts: 3,043

Original Poster
Rep: Reputation: 762Reputation: 762Reputation: 762Reputation: 762Reputation: 762Reputation: 762Reputation: 762
It looks normal to me:
Code:
    -s, --short           short host name
    -a, --alias           alias names
    -i, --ip-address      addresses for the hostname
    -f, --fqdn, --long    long host name (FQDN)
    -d, --domain          DNS domain name
    -y, --yp, --nis       NIS/YP domainname
    -F, --file            read hostname or NIS domainname from given file
and
Code:
for opt in s a i f d y
do
	print -n "hostname -${opt}: "
	hostname -${opt}
done
hostname -s: pita
hostname -a: pita 
hostname -i: 192.168.1.30 
hostname -f: pita.com
hostname -d: com
hostname -y: (none)
(that's KornShell, not BASH).

So, I dunno.
 
Old 07-03-2013, 11:04 AM   #6
Spatior
Member
 
Registered: Jun 2009
Location: México
Distribution: Suse, Debian based, CentOs
Posts: 48

Rep: Reputation: 10
Hi tronayne,

I have a similar problem to yours so I think what I have found so far may help you

pita.com.com is probably coming from $w macros, it is assigned at sendmail start from the gethostname() function to get the (local)host name

You can try to run sendmail -bt -d8.8 to see how it is resolving the DNS:
Code:
sendmail -bt -d8.8
3,0 user[at][domain.com]
It will expand and resolv the recipe string as it will normally do but showing the steps from each macro involved
I found the following book very helpful to understand how sendmail works:
http://www.diablotin.com/librairie/n...il/ch31_10.htm
adn the DNS stuff in:
http://docstore.mik.ua/orelly/networ...il/ch21_02.htm

Now, the problem I found is that when I send a mail to user [at] mydomain.com it tries to deliver to mydomain.com instead of the MX record which points to mail.mydomain.com I think it's the DNS setup which unfortunately is in another host so I cannot mess with that

I don't know if something similar is happening to you.

HTH

Last edited by Spatior; 07-03-2013 at 11:10 AM.
 
1 members found this post helpful.
Old 07-03-2013, 03:05 PM   #7
zhjim
Senior Member
 
Registered: Oct 2004
Distribution: Debian Squeeze x86_64
Posts: 1,446
Blog Entries: 11

Rep: Reputation: 182Reputation: 182
After reading the maillog output again I see that the relay option is pita.com.com. Which concludes to me that spatior has some point with the dns settings. I can't check them from outside. Dont get a MX only massive NS records.

A short search for the $w macro states that it only gets assign on version 8. Not prior to this. dunno if your other machine have another version. Doubt it if all of them are slack 14.
 
Old 07-04-2013, 05:24 AM   #8
tronayne
Senior Member
 
Registered: Oct 2003
Location: Northeastern Michigan, where Carhartt is a Designer Label
Distribution: Slackware 32- & 64-bit Stable
Posts: 3,043

Original Poster
Rep: Reputation: 762Reputation: 762Reputation: 762Reputation: 762Reputation: 762Reputation: 762Reputation: 762
Thanks for the input -- here's the output of
Code:
sendmail -bt -d8.8
ADDRESS TEST MODE (ruleset 3 NOT automatically invoked)
Enter <ruleset> <address>
> 3,0 user[at][domain.com]
canonify           input: user [ at ] [ domain . com ]
Canonify2          input: user [ at ] [ domain . com ]
Canonify2        returns: user [ at ] [ domain . com ]
canonify         returns: user [ at ] [ domain . com ]
parse              input: user [ at ] [ domain . com ]
Parse0             input: user [ at ] [ domain . com ]
Parse0           returns: user [ at ] [ domain . com ]
ParseLocal         input: user [ at ] [ domain . com ]
ParseLocal       returns: user [ at ] [ domain . com ]
Parse1             input: user [ at ] [ domain . com ]
Parse1           returns: $# local $: user [ at ] [ domain . com ]
parse            returns: $# local $: user [ at ] [ domain . com ]
>
This is identical to the output of both my servers and my work station (all of them are Slackware 14.0, the servers are 32-bit, the work station (and this laptop) are 64-bit and all four sedmails are un-fooled-around-with -- the laptop is the only one that is exhibiting this pita.com.com behavior (drat!).

All my machines are fixed-IP, with identical /etc/hosts files; i.e.,
Code:
# For loopbacking.
127.0.0.1		localhost
# For public and private OpenSRF comains
127.0.1.2       public.localhost        public
127.0.1.3       private.localhost       private
# Local servers
192.168.1.10		fubar.com fubar
192.168.1.15		InkJet
192.168.1.20		snafu.com snafu
192.168.1.30		pita.com pita
# Public servers
75.126.162.205		www.linuxquestions.org	linuxquestions.org
74.125.224.70		maps.google.com
74.125.224.111		maps.gstatic.com
So, I don't think DNS has anything to do with (and BIND is not configured nor is it running on any server); my /etc/resolv.conf (a little messy) contains:
Code:
cat /etc/resolv.conf
search com
nameserver 68.94.156.1
nameserver 68.94.157.1
# Google Free DNS Servers
#nameserver 8.8.8.8
#nameserver 8.8.4.4
# HughesNet DNS Servers
#nameserver 66.82.4.8
#nameserver 66.82.4.12
Those commented-out extras are there for the rare occasion that the first two aren't available for some reason or other; they're just-in-case. And, as I understand it, the first place we look is in /etc/hosts and, well, they're all there.

I'm not doing mailx trona@pita.com (which goes out to the world), I simply use mailx trona, which should be resolved (and is on every box but this one) to the local machine. And it ain't.

WFT.

Thanks for the input.

Last edited by tronayne; 07-04-2013 at 05:27 AM.
 
Old 07-08-2013, 02:15 AM   #9
zhjim
Senior Member
 
Registered: Oct 2004
Distribution: Debian Squeeze x86_64
Posts: 1,446
Blog Entries: 11

Rep: Reputation: 182Reputation: 182
Dunno if the output looks good. But I think that sendmail does not use your FQDN so it puts your domain (search in /etc/resolv.conf) at the end of the hostname. Coming from a little howto /etc/mail/genericsdomain should hold your FQDN. Do you have that one? What does it shown on (all) the machine(s)?
 
Old 07-08-2013, 02:19 AM   #10
zhjim
Senior Member
 
Registered: Oct 2004
Distribution: Debian Squeeze x86_64
Posts: 1,446
Blog Entries: 11

Rep: Reputation: 182Reputation: 182
Nother thing. How did you configure your sendmail?

Last edited by zhjim; 07-08-2013 at 03:46 AM.
 
Old 07-08-2013, 03:01 AM   #11
jostber
Member
 
Registered: Jul 2001
Location: Skien, Norway
Distribution: Slackware 14.0 64-bit
Posts: 228

Rep: Reputation: 41
Have you updated the sendmail.cf or sendmail.mc file?

http://www.cyberciti.biz/tips/sendma...ions-from.html
http://www.electrictoolbox.com/artic...ction-refused/
 
Old 07-08-2013, 01:44 PM   #12
tronayne
Senior Member
 
Registered: Oct 2003
Location: Northeastern Michigan, where Carhartt is a Designer Label
Distribution: Slackware 32- & 64-bit Stable
Posts: 3,043

Original Poster
Rep: Reputation: 762Reputation: 762Reputation: 762Reputation: 762Reputation: 762Reputation: 762Reputation: 762
Actually, I never configure any of the sendmail files; the norm is that it "just works" on the individual server and with a mailto link from an internal web page. No kidding, I don't configure anything on any of these boxes.

So, maybe I'll look at the configuration files and see what's what but dang if I can figure out where this additional .com is coming from given that all four machines are identical Slackware 14.0 installations (other than 32-bit versus 64-bit) with all patches applied.

Tiz a puzzlement.
 
Old 07-08-2013, 02:05 PM   #13
zhjim
Senior Member
 
Registered: Oct 2004
Distribution: Debian Squeeze x86_64
Posts: 1,446
Blog Entries: 11

Rep: Reputation: 182Reputation: 182
Hm that truly is weired. Maybe some packages did fiddle with your hosts config file or sendmail. Maybe a diff on the packages might show.
Also 32vs64 does not make a difference. But the one giving headache is the only 64bit?
 
Old 07-08-2013, 02:46 PM   #14
tronayne
Senior Member
 
Registered: Oct 2003
Location: Northeastern Michigan, where Carhartt is a Designer Label
Distribution: Slackware 32- & 64-bit Stable
Posts: 3,043

Original Poster
Rep: Reputation: 762Reputation: 762Reputation: 762Reputation: 762Reputation: 762Reputation: 762Reputation: 762
Yeah, I know that 32-bit and 64-bit are pretty much identical -- the one being a pain happens to be a 64-bit lap top (which is identical to a 64-bit desk top). There's not enough on it to make a difference (so I can just scrap it and reload Slackware and see what happens).

I mean I haven't got a clue -- never seen this before and these guys are kept identical with configuration files and patches, including the recent kernel patch on all. The two 32-bit data base servers have old Radeon cards but the 64-bit boxes have Intel graphics (and how that could make any difference I most certainly do not know).

I think I'll just do a clean install and see what that does (if anything) to make a difference. It's just goofy.
 
Old 07-08-2013, 03:20 PM   #15
zhjim
Senior Member
 
Registered: Oct 2004
Distribution: Debian Squeeze x86_64
Posts: 1,446
Blog Entries: 11

Rep: Reputation: 182Reputation: 182
Hm. Does slackware has some options for labtop installs? I know in Debian theres an option for that. Also its more for energy saving and alike but maybe theres a silent com(on) give me more power. Just kidding. Long time ago I lost track of slack.

Maybe you can just copy the files of the desktop over to the labtop? At least that rules out any configurations. Also you would need to just host.conf and alike. Grub if installed also if you dont use the same uuid for the partitions.
Could you backup the /etc directory and diff it after the installation? Maybe this will shed some light.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
I always forget to use mouse kanslabpa LinuxQuestions.org Member Intro 1 04-01-2009 07:01 AM
What should I do if I forget the su`s password??? songxuanss Linux - Security 3 09-25-2007 12:31 AM
It's over so forget it ! bigjohn General 19 12-29-2003 11:22 PM
Samba Seeming to Forget! chunkymonkey Linux - Software 4 07-21-2003 11:08 AM
what did I forget to do kenoki Linux - Networking 9 07-08-2003 09:40 AM


All times are GMT -5. The time now is 07:16 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration