LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 09-27-2007, 07:12 PM   #151
DragonM15
Member
 
Registered: Sep 2003
Location: USA
Distribution: Slackware (Multiple Versions)
Posts: 455

Rep: Reputation: 31

Also, does my server need to have support for say cram-md5 if I am trying to authenticate to that isp? Even though I have the lines:
Code:
define(`confAUTH_MECHANISMS', `EXTERNAL GSSAPI DIGEST-MD5 CRAM-MD5 LOGIN PLAIN')dnl
TRUST_AUTH_MECH(`EXTERNAL GSSAPI DIGEST-MD5 CRAM-MD5 LOGIN PLAIN')dnl
in my sendmail.mc file.

The only thing I get when I telnet to my own server is:
Code:
250-ENHANCEDSTATUSCODES
250-PIPELINING
250-8BITMIME
250-SIZE
250-DSN
250-ETRN
250-STARTTLS
250-DELIVERBY
250 HELP
I dont have ANY of the AUTH protocols that SHOULD be in there. Could this be causing the problem?

Thanks,
DragonM15

Last edited by DragonM15; 09-27-2007 at 07:13 PM.
 
Old 09-28-2007, 01:58 PM   #152
Tux-Slack
Member
 
Registered: Nov 2006
Location: Slovenia
Distribution: Slackware 13.37
Posts: 511

Rep: Reputation: 36
Because if you followed this guide you set up that the client must first run STARTTLS and then authenticate. But when you STARTTSL, AUTH isn't AUTH anymore but It's 43feq4354tg45tX or something like that, "unreadable to human eyes", because it's encrypted.
 
Old 09-29-2007, 03:35 PM   #153
DragonM15
Member
 
Registered: Sep 2003
Location: USA
Distribution: Slackware (Multiple Versions)
Posts: 455

Rep: Reputation: 31
Quote:
Originally Posted by Tux-Slack View Post
Because if you followed this guide you set up that the client must first run STARTTLS and then authenticate. But when you STARTTSL, AUTH isn't AUTH anymore but It's 43feq4354tg45tX or something like that, "unreadable to human eyes", because it's encrypted.
Ok, so my server not having the AUTH option when telnetting into it is ok? And that wouldnt have anything to do with why I cant auth with my home ISP mail server?

Thanks,
DragonM15
 
Old 03-03-2008, 01:39 PM   #154
aboterf
LQ Newbie
 
Registered: Mar 2008
Posts: 1

Rep: Reputation: 0
Setting up Sendmail with ATT Yahoo

Could you post an update to include how to setup sendmail with an ISP that requires SSL Authentication. I have ATT Yahoo DSL and their SMTP uses port 465 Secure Authentication and I'm not sure how I would modify what you have here to make it work. Thanks in advance for you help.
 
Old 03-03-2008, 05:42 PM   #155
seaelf
Member
 
Registered: Apr 2004
Location: Virginia
Distribution: Slackware 10.1 & 12.0
Posts: 66

Rep: Reputation: 16
smtp auth how not to...

Hey all---
I was pointed to this how-to last year after getting verizon dsl. Great tutorial....worked first time....but my question is this:
I am the only one using the pc...it's here at the house. I use pine for mail. It shows my user name and I have to enter password. I'm ok with this but since I am the only one using the machince, can I set it so I don't have to enter my password and user name or can I have the password saved like username is and all I'd have to do is hit enter?
Thanks---
all the best
Neil
 
Old 04-06-2008, 06:52 AM   #156
kd5de
LQ Newbie
 
Registered: May 2006
Posts: 2

Rep: Reputation: 0
openssl problem

Well I am trying to set up on a slackware 11 server with SMTP_AUTH the problem I am running into is that openssl is not requesting the FQDN. I check saslaythd and got OK I did the telnet 25 bit and sendmail is showing STARTSSL and LOGIN Plain. But I can not relay any mail through the box. I get the did not issue MAIL/EXPN/VRFY/ETRN from a box that has been relaying though a Slack 10 box that has SMPT_AUTH set up the hard way. What am I missing?
 
Old 04-23-2008, 03:51 AM   #157
Tux-Slack
Member
 
Registered: Nov 2006
Location: Slovenia
Distribution: Slackware 13.37
Posts: 511

Rep: Reputation: 36
Hello everyone,

I've followed this guide ages ago and got it working nicely, even played with it a little bit more, to got it working on two hosts and some other goodies.
But now I have a little problem at my companies SMTP server.
The server is located in Slovenia but we need to send some mails as user@xxx.ac.be (Belgium) for our client, which we can not, because all servers reject these mails. I don't know the exact reason why they are rejecting, because my boss didn't give me the root password yet so I could check it out.
But I think I know how to solve the problem. I think it would solve it if I would RELAY all mails that have host xxx.ac.be to our clients SMTP server in Belgium. I think I could do this with SMART_HOST, but the problem is if I add their SMTP server to SMART_HOST then ALL mails will be relayed over to them, which I do not want, I just want that mails with their hostname will get relayed over to their server and then sent further out. Is this doable? And how?
Thank you!

Kind regards,
Thomas
 
Old 05-19-2008, 06:49 AM   #158
honey bee
LQ Newbie
 
Registered: Jan 2006
Location: Islamabad,Pakistan
Posts: 29

Rep: Reputation: 15
Question

Hello,

What should i do, if i want to authenticate from the shadow files of sendmail virtual domains, which are created separately for each domain in /etc/vmail with the name "shadow.DomainName.com"?

I am not getting any help related to it.If anyone has any idea, please do suggest.Thank you.
 
Old 05-20-2008, 01:30 AM   #159
Tux-Slack
Member
 
Registered: Nov 2006
Location: Slovenia
Distribution: Slackware 13.37
Posts: 511

Rep: Reputation: 36
You need saslauth daemon and run it with -a shadow parameter.

Then you need to create a /etc/mail/virtusertable and put in there like:
name-you-desire@domain.com username-from-shadow
Hash it the same way as explained in this how to
this will transfer mail for one name and domain to a specific username on the server.

And then comes the part which I don't understand perfectly, you need to create /etc/mail/generics-table and the format should be:
username-from-shadow name-you-desire@domain.com

This should restrict the user from sending out mail from a different domain or name, but for some reason it doesn't work.
You need to recompile sendmail with some flags I think, but I'll check that later, just a quick reply from work.
 
Old 05-20-2008, 02:55 AM   #160
honey bee
LQ Newbie
 
Registered: Jan 2006
Location: Islamabad,Pakistan
Posts: 29

Rep: Reputation: 15
Question

Hello

Thank you for the reply, but i think you didn't understand my question.I have virtual sendmail domains created by linuxconf.Each domain has its own passwd and shadow file created on the standard format.

Running "saslauthd -a shadow", makes authentication from the default shadow file for real users and not for the virtual mail domain users.

/etc/mail/virtusertable is used for mapping e-mail addresses to user names.I just want authentication to be carried out from the domain's own shadow file.Is there any implementation for virtual domains regarding SMTP Auth or they have any other alternate for it?
 
Old 08-08-2008, 01:27 AM   #161
zzzy
LQ Newbie
 
Registered: Jun 2006
Distribution: slackware, darwin
Posts: 5
Blog Entries: 1

Rep: Reputation: 0
Quote:
Originally Posted by aboterf View Post
Could you post an update to include how to setup sendmail with an ISP that requires SSL Authentication. I have ATT Yahoo DSL and their SMTP uses port 465 Secure Authentication and I'm not sure how I would modify what you have here to make it work. Thanks in advance for you help.
After setting up the client-side auth part in the LQ AUTH SMTP HowTo, follow the instructions found in this blogger post including AP's addendum in the comments. It basically shows how to use STunnel to establish SSL encrypted connections.

Hope this helps.
 
Old 02-19-2009, 07:14 PM   #162
timnp
Member
 
Registered: Feb 2008
Location: London
Distribution: FC8, FC9, Centos 4, Centos 5, Knoppix
Posts: 52

Rep: Reputation: 16
Thanks SiegeX,

That was a really good guide. Worked fine on FC9 and CentOS 4.7
 
Old 04-02-2009, 11:03 AM   #163
lefty.crupps
Member
 
Registered: Apr 2005
Location: Minneap USA
Distribution: Debian, Mepis, Sidux
Posts: 470

Rep: Reputation: 32
Talking Worked on RHEL4-ES (Nahant Update 4)

With a few changes mostly on the m4 command to use the proper sendmail.mc file, this worked like a charm. Thank you for the fantastic HowTo.
 
Old 05-15-2009, 12:42 AM   #164
andrewfeberwee
Member
 
Registered: Feb 2007
Posts: 30

Rep: Reputation: 15
It's just not happening for me, I have been mucking about with this for a week and I still get
reject=550 5.7.1 <postmaster@liftcapital.com.au>... Relaying denied. Proper authentication required.


so heres my thing

divert(-1)
include(`/usr/share/sendmail/m4/cf.m4')
divert(0)
VERSIONID(`Sendmail Config for hatchnet 2008-05-03')
OSTYPE(`linux')
DOMAIN(`generic')
define(`ALIAS_FILE', `/etc/aliases')

LOCAL_NET_CONFIG
R$* < @ $* .$m. > $* $#esmtp $@ $2.$m $: $1 < @ $2.$m. > $3
define(`confMILTER_LOG_LEVEL',`1')
RELAY_DOMAIN_FILE(`/etc/mail/relay-domains')
FEATURE(`use_cw_file')
FEATURE(`relay_entire_domain')
FEATURE(masquerade_envelope)
FEATURE(local_procmail)
FEATURE(`access_db',`hash -T<TMPF> -o /etc/mail/access.db')dnl


define(`confAUTH_MECHANISMS', `DIGEST-MD5 CRAM-MD5 LOGIN PLAIN')dnl
TRUST_AUTH_MECH(`DIGEST-MD5 CRAM-MD5 LOGIN PLAIN')dnl
define(`confCACERT_PATH', `/etc/mail/certs')dnl
define(`confCACERT', `/etc/mail/certs/cacert.pem')dnl
define(`confSERVER_CERT', `/etc/mail/certs/sendmail.pem')dnl
define(`confSERVER_KEY', `/etc/mail/certs/sendmail.pem')dnl
define(`confCLIENT_CERT', `/etc/mail/certs/sendmail.pem')dnl
define(`confCLIENT_KEY', `/etc/mail/certs/sendmail.pem')dnl
define(`confAUTH_OPTIONS', `A p y')dnl



define(`CYRUSV2_MAILER_ARGS', `FILE /var/lib/imap/socket/lmtp')dnl
define(`confLOCAL_MAILER', `cyrusv2')
MAILER(smtp)
MAILER(procmail)
MAILER(local)
MAILER(`cyrusv2')

Any ideas would be muchly appreciated
 
Old 09-16-2009, 07:45 PM   #165
rutrow
LQ Newbie
 
Registered: Sep 2009
Distribution: Slackware
Posts: 11

Rep: Reputation: 0
General FYI...

For Slackware 13, Sendmail.conf needs to be in /etc/sasl2

Last edited by rutrow; 09-16-2009 at 07:54 PM.
 
  


Reply

Tags
att, auth, dsl, howto, sendmail, smtp, ssl, yahoo


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
DISCUSSION: Sendmail SMTP AUTH Howto SiegeX LinuxAnswers Discussion 10 09-17-2007 07:49 PM
sendmail 8.13.4-2 smtp auth nightmare kz26 Linux - Security 1 10-30-2005 01:57 PM
Sendmail SMART_HOST + SMTP AUTH Howto SiegeX Slackware 15 09-06-2004 01:42 AM
SMTP Auth for sendmail wolftechmn Linux - Networking 4 11-27-2003 01:17 PM
Sendmail / SMTP Auth cleaner416 Linux - Networking 3 10-06-2003 10:40 AM


All times are GMT -5. The time now is 11:16 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration