LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
LinkBack Search this Thread
Old 04-24-2013, 03:28 AM   #1
carlitoco
Member
 
Registered: Jan 2008
Location: Berlin
Distribution: Slackware / Arch
Posts: 130

Rep: Reputation: 15
sendmail and I


I've a full installation of Slackware and try to configure my sendmail.

If I write a testmail to my gmail account, I see the sender is my router like this:

user@shnazha.fritz.box

shanzha is right in the /etc/hosts.
But if I change, in the next testmail the sender is not changed.

I want user@mychoise.com

Last edited by carlitoco; 04-24-2013 at 03:33 AM.
 
Old 04-24-2013, 03:50 AM   #2
carlitoco
Member
 
Registered: Jan 2008
Location: Berlin
Distribution: Slackware / Arch
Posts: 130

Original Poster
Rep: Reputation: 15
Ok I changed with netconfig
/etc/hosts into:
127.0.0.1 shanzha.mydomain.com mydomain

the testmail sender is now mydomain.fritz.box

whats happened in my router with the mail ?

Last edited by carlitoco; 04-24-2013 at 04:16 AM.
 
Old 04-24-2013, 09:46 AM   #3
Richard Cranium
Senior Member
 
Registered: Apr 2009
Location: Carrollton, Texas
Distribution: Slackware64 14.1
Posts: 1,322

Rep: Reputation: 353Reputation: 353Reputation: 353Reputation: 353
You aren't going to get a lot of help unless you provide more details. Such as what sendmail configuration changes you've already made and if you have successfully configured sendmail on other systems before.
 
Old 04-24-2013, 02:13 PM   #4
volkerdi
Slackware Maintainer
 
Registered: Dec 2002
Location: Minnesota
Distribution: Slackware! :-)
Posts: 836

Rep: Reputation: 1620Reputation: 1620Reputation: 1620Reputation: 1620Reputation: 1620Reputation: 1620Reputation: 1620Reputation: 1620Reputation: 1620Reputation: 1620Reputation: 1620
Quote:
Ok I changed with netconfig
/etc/hosts into:
127.0.0.1 shanzha.mydomain.com mydomain

the testmail sender is now mydomain.fritz.box
Well, first of all, that's not correct /etc/hosts syntax above having "mydomain" as the host name as well as "shanzha"[.mydomain.com]. But none of that should really matter for configuring sendmail for outgoing mail anyway. If I understand correctly, you want to be able to set the domain that is applied to outgoing mail. To do that, you need to use the masquerade macro in the "local info" section of your /etc/mail/sendmail.cf:

Code:
# who I masquerade as (null for no masquerading) (see also $=M)
DMmychoise.com
 
1 members found this post helpful.
Old 04-25-2013, 08:24 AM   #5
carlitoco
Member
 
Registered: Jan 2008
Location: Berlin
Distribution: Slackware / Arch
Posts: 130

Original Poster
Rep: Reputation: 15
Okay thank you so far.

In my opinion it's urgent to configure tls-sasl authentication.
My "red wire" to build a self-signed cert.

Code:
bash-4.2$ tree
.
|-- cacert.pem
|-- certs
|-- crl
|-- index.txt
|-- index.txt.attr
|-- index.txt.old
|-- newcert.pem
|-- newcerts
|   `-- 01.pem
|-- newreq.pem
|-- openssl.cnf
|-- openssl.cnf~
|-- private
|   `-- cakey.pem
|-- serial
|-- serial.old
`-- tmp.pem

4 directories, 13 files
in the sendmail.cm it's different named
CA.cert.pem = ? cacert.pem
smtp.cert.pem = ? 01.pem
smtp.key.pem = ? cakey.pem

Is this right ?

Last edited by carlitoco; 04-25-2013 at 08:27 AM.
 
Old 04-26-2013, 04:05 AM   #6
carlitoco
Member
 
Registered: Jan 2008
Location: Berlin
Distribution: Slackware / Arch
Posts: 130

Original Poster
Rep: Reputation: 15
Hey I started my rc.sendmail and rc.saslauth deamons but don't see the imap service at port 143

I configured my sendmail like this and build the certs.

As firewall, I checked the open ports with and without, I use Alien Bobs generator


Why I don't see the service, the last time I set up sendmail's been too long.
 
Old 04-26-2013, 07:49 PM   #7
Richard Cranium
Senior Member
 
Registered: Apr 2009
Location: Carrollton, Texas
Distribution: Slackware64 14.1
Posts: 1,322

Rep: Reputation: 353Reputation: 353Reputation: 353Reputation: 353
sendmail is not imap

If you want imap, you should start imapd.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Sendmail M4 configuration base directory /usr/share/sendmail-cf was not found eliassal Linux - Server 15 11-04-2010 01:09 AM
Sendmail ignores aliases with sendmail daemon stopped phavn Solaris / OpenSolaris 1 12-01-2008 02:50 PM
m4 sendmail.mc > sendmail.cf generate unwanted result on OpenSolaris johncsl82 Solaris / OpenSolaris 1 09-08-2008 11:25 PM
sendmail is not working & on $prompt the cmd sendmail hangs Pavan mahoorker Linux - Software 1 04-04-2006 03:57 PM
Sendmail - RunAsUser=sendmail:mail/What files to i have to change ForumKid Linux - Security 45 01-18-2002 11:47 AM


All times are GMT -5. The time now is 01:11 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration