LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 05-01-2011, 06:24 PM   #1
dimm0k
Member
 
Registered: May 2008
Location: Brooklyn ZOO
Distribution: Slackware64 14.0
Posts: 389

Rep: Reputation: 23
Segmentation faults during upgrade from 13.1 to 13.37


Just finished the upgrade from 13.1 to 13.37 using the script mentioned in the docs to "upgradepkg --install-new" through all of the directories except kdei. When I initiated the script, I redirected the output as follows:

upgrade.sh > install.log

Doing so outputted some messages to the console about segmentation faults, but after checking the install.log I did not find any problems. The outputted messages were similar throughout and were as follows:

Code:
install/doinst.sh: line 25: 1521 Segmentation fault  usr/bin/update-mime-database usr/share/mime >/dev/null 2>&1
install/doinst.sh: line 25: 2243 Segmentation fault  usr/bin/update-mime-database usr/share/mime >/dev/null 2>&1
install/doinst.sh: line 8: 7211 Segmentation fault  /usr/bin/update-mime-database /usr/share/mime >/dev/null 2>&1
install/doinst.sh: line 8: 7917 Segmentation fault  /usr/bin/update-mime-database /usr/share/mime >/dev/null 2>&1
install/doinst.sh: line 4: 32335 Segmentation fault  /usr/bin/update-mime-database ./usr/share/mime >/dev/null 2>&1
install/doinst.sh: line 4: 32577 Segmentation fault  /usr/bin/update-mime-database ./usr/share/mime >/dev/null 2>&1
install/doinst.sh: line 8: 9589 Segmentation fault  /usr/bin/update-mime-database ./usr/share/mime >/dev/null 2>&1
install/doinst.sh: line 8: 9829 Segmentation fault  /usr/bin/update-mime-database ./usr/share/mime >/dev/null 2>&1
Is this anything to worry about?

Last edited by dimm0k; 05-01-2011 at 06:26 PM.
 
Old 05-01-2011, 07:15 PM   #2
dive
Senior Member
 
Registered: Aug 2003
Location: UK
Distribution: Slackware
Posts: 3,211

Rep: Reputation: 292Reputation: 292Reputation: 292
I wouldn't check if it still segfaults when you run it manually. It could be a sign of a corrupt package or binary.

Try grabbing a fresh shared-mime-info package from a mirror and see if it fixes it.

That app isn't system critical but you do want the mime database updated from time to time. Normally it runs at boot in rc.M

Last edited by dive; 05-01-2011 at 07:16 PM.
 
1 members found this post helpful.
Old 05-01-2011, 07:49 PM   #3
dimm0k
Member
 
Registered: May 2008
Location: Brooklyn ZOO
Distribution: Slackware64 14.0
Posts: 389

Original Poster
Rep: Reputation: 23
Thank you for the fast response! Perhaps the upgrade process attempted to use the mime package from 13.1 before it was upgraded to 13.37. Re-running that command as listed in the messages produced no errors this time around.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Segmentation faults in C Haku72 Programming 6 11-19-2009 06:23 PM
Segmentation faults winterhunter Linux - Software 5 10-14-2005 03:06 AM
Some help with segmentation faults? captainslushie Linux - Software 5 06-23-2005 02:59 PM
Segmentation Faults ryankask Mandriva 2 06-13-2005 07:10 PM
Segmentation Faults? DoomsdayChef Linux - Newbie 2 10-18-2003 08:18 AM


All times are GMT -5. The time now is 05:53 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration