LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices



Reply
 
Search this Thread
Old 03-09-2007, 09:41 PM   #1
gonrosie
LQ Newbie
 
Registered: Mar 2007
Posts: 27

Rep: Reputation: 15
Seeing blank screen after updating kernel


Hello there, first sorry for my bad english, its not my mother tongue..

Well, i've installed slackware 11.0 few days ago and i've noticed that if I want to use my RTL8139 and Marvell net adapters I have to upgrad to kernel 2.6, well, i looked up this site and found out an excellent guide for doing this ( http://www.linuxquestions.org/linux/...Slackware_10_1 )
I followed it step by step and everything went just fine except one little thing is when finally I typed 'lilo' to initialize it , it showed my an msg that goes something like that: "warning: master boot and system map are not on the same disk", well, I kind of ignored that just for its being a simple warning and typed finally 'reboot' and then lilo popped up, I chose my new kernel from the menu and unfortunately I had nothing on my screen, a totally blank screen but I heard my hard-drive is working so I realized that the booting process is happening but it doesn't show me nothing, while it was a black screen , I waited it to boot completely (just by hearing my hard-drive) and tried to log-in as root (while I see nothing on my screen).. well, I heard my hard-drive works again so I realized that it DOES work but it just shows me nothing.. well, I typed on my console (again, while I see a blank screen) a 'startx' and for my surprise it opened up my kde (from the new kernel, and it even made a cool sounds at the beginning so all the kernel compiling at the beginning was quite successful) so I realized that maybe there is some problem with my kernel modules so in the kde KConsole i typed 'xconfig' while im in /usr/src/linux-2.6.20.1 and I chose all the modules that I thought that might help me figure it out (for example frame-buffer stuff and this kind of things), after closing the 'xconfig' i typed:
1) make
2) make modules
3) make modules_install
well, it made all this compiling process and then I tried to reboot.. and unfortunately while im still trying to boot it from the new kernel I still see a blank screen and hear that my hard-drive is booting it out :\

please help me because im kind of desperate already :\
I think im missing some part while im trying to update the kernel (I mean im missing some step from the steps i wrote above, after doing changed in the xconfig I mean).

Thanks,
Gonroise.
 
Old 03-09-2007, 09:57 PM   #2
masonm
Senior Member
 
Registered: Mar 2003
Location: Following the white rabbit
Distribution: Slackware64 13.37 Android 4.0
Posts: 2,248

Rep: Reputation: 46
Did you make sure to include frame buffer support? Also, what does your lilo.conf file look like?
 
Old 03-09-2007, 11:16 PM   #3
bioe007
Member
 
Registered: Apr 2006
Location: lynnwood, wa - usa
Distribution: archlinux
Posts: 654

Rep: Reputation: 30
I think masonm is right,

I have experienced this problem myself when building kernels and forgetting to change the vga mode in lilo.

the quick and dirty answer is just change lilo.conf:

vga= XXX # XXX = some number
vga= normal

During your kernel configuration:
If you want a nice framebuffer and pengy during boot up you either have to build in framebuffer support (Y) or create an initrd if you want fb as modular (M).

Last edited by bioe007; 03-09-2007 at 11:20 PM.
 
Old 03-10-2007, 12:10 AM   #4
gonrosie
LQ Newbie
 
Registered: Mar 2007
Posts: 27

Original Poster
Rep: Reputation: 15
I did include the frame buffer support but my question is: after im including this, and after exiting the menuconfig, what command should I type? only these 3 ones that I mentioned? or maybere there is something more?


my lilo.conf looks like this:

# Slack NEW begins
image = /boot/vmlinuz-2.6.10
root = /dev/hdb1
label = Slack_2.6.10
read-only
# Slack NEW ends
# Slack OLD begins
image = /boot/vmlinuz-old
root = /dev/hdb1
label = Slack_OLD
read-only
# Slack OLD

and the vga is set to normal..

thanks again,
gonroise
 
Old 03-10-2007, 12:15 AM   #5
gonrosie
LQ Newbie
 
Registered: Mar 2007
Posts: 27

Original Poster
Rep: Reputation: 15
mmmm and I actually didn't really understand what should I put in the lilo.conf file? (the dirty way u talked about). It would be great if you'll show me an example of your file or something like that..
 
Old 03-10-2007, 01:31 AM   #6
bioe007
Member
 
Registered: Apr 2006
Location: lynnwood, wa - usa
Distribution: archlinux
Posts: 654

Rep: Reputation: 30
per your request...
Code:
# LILO configuration file
# generated by 'liloconfig'
#
# Start LILO global section

boot = /dev/hda
message = /boot/boot_message.txt
prompt
timeout = 1200

# Override dangerous defaults that rewrite the partition table:
change-rules
  reset
# VESA framebuffer console @ 1024x768x256
vga = 791
# End LILO global section

# Linux bootable partition config begins
image = /boot/bzImage-2.6.19.1f
  root = /dev/hda4
  label = Test2.6.19.1f
  read-only
image = /boot/bzImage-2.6.20
  root = /dev/hda4
  label = Test2.6.20
  read-only
image = /boot/vmlinuz
  root = /dev/hda4
  label = Slack-Huge26
  read-only
# Linux bootable partition config ends

# Windows bootable partition config begins
other = /dev/hda2
  label = Windows
  table = /dev/hda
# Windows bootable partition config ends
I'm a bit confused.. So did you recompile and you made sure framebuffer support was compiled in?

there are a few options you need under framebuffer support, here is what I have:

Code:
#
# Graphics support
#
CONFIG_FIRMWARE_EDID=y
CONFIG_FB=y
CONFIG_FB_DDC=y
CONFIG_FB_CFB_FILLRECT=y
CONFIG_FB_CFB_COPYAREA=y
CONFIG_FB_CFB_IMAGEBLIT=y
CONFIG_FB_MODE_HELPERS=y
CONFIG_FB_TILEBLITTING=y
CONFIG_FB_VGA16=y
CONFIG_FB_VESA=y
CONFIG_FB_INTEL=y
CONFIG_FB_INTEL_I2C=y
CONFIG_FB_RADEON=y
CONFIG_FB_RADEON_I2C=y

#
# Console display driver support
#
CONFIG_VGA_CONSOLE=y
CONFIG_VGACON_SOFT_SCROLLBACK=y
CONFIG_VGACON_SOFT_SCROLLBACK_SIZE=512
CONFIG_VIDEO_SELECT=y
CONFIG_DUMMY_CONSOLE=y
CONFIG_FRAMEBUFFER_CONSOLE=y
CONFIG_FONT_8x8=y
CONFIG_FONT_8x16=y

#
# Logo configuration
#
CONFIG_LOGO=y
CONFIG_LOGO_LINUX_CLUT224=y
that is the best I can do..

I'd be lying to you if I said anymore than "I kept trying until it worked"

if you're still getting a black screen with vga=normal then ??? maybe its not your framebuffer thats screwed up?

you could try just commenting out the global vga line altogether
 
Old 03-10-2007, 08:12 PM   #7
gonrosie
LQ Newbie
 
Registered: Mar 2007
Posts: 27

Original Poster
Rep: Reputation: 15
mmm well, it quite worked but still only when the vga (in the lilo.confg) is set to normal even though I chose all the frame buffer options in the kernel config but when I type 'make intall' or 'lilo' I get this strange warning that I can't figure out:

root@darkstar:/usr/src/linux-2.6.20.1# make install
sh /usr/src/linux-2.6.20.1/arch/i386/boot/install.sh 2.6.20.1 arch/i386/boot/bzImage System.map "/boot"
Warning: The boot sector and map file are on different disks.
Added New_Linux *
Added Old_Linux
Added Windows


so maybe the problem starts with that :\
 
Old 03-10-2007, 08:37 PM   #8
bioe007
Member
 
Registered: Apr 2006
Location: lynnwood, wa - usa
Distribution: archlinux
Posts: 654

Rep: Reputation: 30
dude.. I'm sooo sorry. I didnt catch this before, I was kind of assuming you were following a guide:

Code:
$make oldconfig    # just restores your previous .config
$make bzImage      # makes the kernel image
$make modules      # makes the modules
$su 
Password: .....
#make modules_install   # installs the modules
#cp arch/i386/boot/bzImage /boot/bzImage-2.X.Y.Z     # copies your newly created image to /boot
#cp System.map /boot/System.map-2.X.Y.Z              # same w/System.map .. X.Y.Z is kernel version number (really your choice)
#ln -s /boot/System.map-2.X.Y.Z /boot/System.map     # link new system.map to old one
#vi lilo.conf           # edit lilo.conf
#/sbin/lilo             # run lilo (hopefully no errors)
#
i use these commands _every_ time I build a new kernel. For a more in-depth look at kernel compiling check the link in my sig.

again, I am sorry I didn't catch that lilo error before.

btw- the X.Y.Z thing is purely optional, I always do kernel version number and because it sometimes takes a few tries to get it right some alpha suffix to keep them ordered in my head. (this is reflected in my lilo.conf where 2.6.19.1f )

hope this helps!


-ack- I keep thinking of other things to ask: how are your partitions & HDs set up?

is the MBR where lilo is installed on the same disk as your /boot directory?

if you have a separate partition for /boot do you fully specify the path in lilo.conf?

Last edited by bioe007; 03-10-2007 at 08:43 PM.
 
Old 03-10-2007, 08:55 PM   #9
gonrosie
LQ Newbie
 
Registered: Mar 2007
Posts: 27

Original Poster
Rep: Reputation: 15
I followed these steps man and I loaded the new kernel but unfortunately only when vga=normal, and I still dunno why :\

my partitions goes something like that:
/dev/hda1 - an NTFS (40GB)
/dev/hda2 - FAT32 (40GB)
/dev/hdb1 - ex2fs (12GB)
and another swap partitions that is about 1.5GB

well, I haven't really chose where to install lilo besides of choosing 'MBR' at the slackware installation but I guess its not on the same disk as the /boot directory.
How can I fully specify the path in lilo.conf?


mmm I got another problem popped out.. afer compiling this kernel and loading it up I can't reach the NTFS hard-drive, even though I chose the modules for the ntfs and compiled them but I can't see nothing in the /fat-c folder.. even when I try to do: mount /dev/hda1 /fat-c , it writes me something like that: ntfs: unknown filesystem.. plz help me ;\

thanks again,
gonroise.
 
Old 03-10-2007, 09:31 PM   #10
bioe007
Member
 
Registered: Apr 2006
Location: lynnwood, wa - usa
Distribution: archlinux
Posts: 654

Rep: Reputation: 30
Quote:
ntfs: unknown filesystem..
that means you are missing ntfs support in your kernel. I'd re-run your xconfig or menuconfig and double check the fs support. keep in mind that if you are just:

make xconfig

w/o first running 'make oldconfig' then you'll lose your previous setup and have to reset all your options. I had a # of kernel panics before I figured this out.

do you get the same error from /sbin/lilo ??

as far as the boot path you didn't post that part of your lilo.conf, but something like:

boot=/dev/hdb1 <or> boot=/dev/hdb

I think should do the trick.

Last edited by bioe007; 03-10-2007 at 10:02 PM.
 
Old 03-10-2007, 10:27 PM   #11
masonm
Senior Member
 
Registered: Mar 2003
Location: Following the white rabbit
Distribution: Slackware64 13.37 Android 4.0
Posts: 2,248

Rep: Reputation: 46
Are you sure you did all the compile steps?

make menuconfig (or xconfig)
make modules
make modules_install
make install


As you're installing Lilo to the MBR I don't think the warning about the map being on a different disk is anything to worry about. I'm sure that's not causing your problem.

It appears that you've either not compiled and installed the modules or you've misconfigured the kernel.
 
Old 03-11-2007, 07:01 AM   #12
gonrosie
LQ Newbie
 
Registered: Mar 2007
Posts: 27

Original Poster
Rep: Reputation: 15
mm I did these steps:

make
make install
make modules
make modules_install

in the same order as I wrote them.. after i leave the menuconfig do I have to do 'make oldconfig' too? I never did that.. I chose all the ntfs support (first I tried as a module and it didn't work and after that I just put an asterisk on it and it didn't work too) and then I hit 'exit' and clicked on yes to save the changes and after that I typed all the steps that I wrote above without any 'make oldconfig', do u think its necessary? if so, then why?
 
Old 03-11-2007, 07:04 AM   #13
gonrosie
LQ Newbie
 
Registered: Mar 2007
Posts: 27

Original Poster
Rep: Reputation: 15
I dont get the same problem running /sbin/lilo (and that's quite weird), the same problem I got running /sbin/lilo is this warning about the system map that I already mentioned.. the lilo sees the /dev/hda1 perfectly withuot any problems but when I try to mount the /dev/hda1 to some folder it shows me that thing that the ntfs is an unknown filesystem.
 
Old 03-11-2007, 05:22 PM   #14
gonrosie
LQ Newbie
 
Registered: Mar 2007
Posts: 27

Original Poster
Rep: Reputation: 15
anyone? plz.. im kind of desperate already
 
Old 03-11-2007, 05:49 PM   #15
bioe007
Member
 
Registered: Apr 2006
Location: lynnwood, wa - usa
Distribution: archlinux
Posts: 654

Rep: Reputation: 30
Quote:
and then I hit 'exit' and clicked on yes to save the changes and after that I typed all the steps that I wrote above without any 'make oldconfig', do u think its necessary? if so, then why?
i find that if I don't 'make oldconfig' before runnning make xconfig all my previous settings are lost. ergo if I want to change just a few options then I run make oldconfig to read in what I last did, then run 'make xconfig' to adjust.

I know nothing of 'make install' I suspect it just copies the bzImage and system.map and creates the link for you. either way i think the error from lilo is gone because of the make install command.

so, before skipping prblem #1 - is that fb working now?

I did some more reading, you can try this:

Code:
# LILO configuration file
# generated by 'liloconfig'
#
# Start LILO global section

boot = /dev/hda
message = /boot/boot_message.txt
prompt
timeout = 400

# Override dangerous defaults that rewrite the partition table:
change-rules
  reset
# End LILO global section

# Linux bootable partition config begins
image = /boot/bzImage-2.6.20
  root = /dev/hda4
  label = Current2.6.20
  vga = 791       # note vga option is now for each kernel
  read-only
image = /boot/bzImage-2.6.19.1f
  root = /dev/hda4
  vga=extended    # note vga option is now for each kernel
  label = Test2.6.19.1f
  read-only
image = /boot/vmlinuz
  root = /dev/hda4
  label = Slack-Huge26
  read-only
# Linux bootable partition config ends

# Windows bootable partition config begins
other = /dev/hda2
  label = Windows
  table = /dev/hda
# Windows bootable partition config ends
that helped me, turns out you can not 'append="vga=<anything>"' - but each image can have its own vga= argument.

problem2
can you show your fstab and or mount command using for ntfs?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
New kernel blank screen Pier Slackware 4 01-20-2006 04:54 AM
Blank Screen after Kernel Compile Clojster Slackware 6 10-10-2004 05:04 AM
Blank screen after the kernel compiling imrel Slackware 1 10-04-2004 10:28 PM
Kernel 2.6.6 boots to blank screen sharpie Linux - General 4 06-19-2004 09:54 AM
StartX causes blank screen, new kernel Eyecannon Linux - Newbie 6 09-14-2002 04:19 PM


All times are GMT -5. The time now is 10:52 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration