LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices



Reply
 
Search this Thread
Old 08-28-2006, 11:51 PM   #1
LocoMojo
Member
 
Registered: Oct 2004
Distribution: Slackware 12
Posts: 165

Rep: Reputation: 30
Second key doesn't type


I'm at a loss here as I can't figure out this strange problem. You see, when I go to a terminal (ctrl+alt+F2-F6) or when I boot into runlevel 3 and I start typing, the second character never appears until I type it again.

In other words, if I go to type "less file.txt" I get "lss file.txt". In order to get it to work right I have to type "leess file.txt".

This happens at every prompt and it is very annoying. It doesn't happen if I use a virtual term such as Konsole.

Any ideas? This just started out of the blue.

Oh by the way, I get the following from dmesg which I've never noticed before:

Quote:
Trying to move old root to /initrd ... <6>input: AT Translated Set 2 keyboard as /class/input/input0
That's one line, not two separate lines.

Then I also get:

Quote:
mice: PS/2 mouse device common for all mice
And later on a separate line:

Quote:
input: ImPS/2 Generic Wheel Mouse as /class/input/input1
What's going on?

Thanks in advance.

LocoMojo
Slackware current
 
Old 08-30-2006, 11:03 AM   #2
drkstr
Senior Member
 
Registered: Feb 2006
Location: Seattle, WA: USA
Distribution: Slackware 11.0
Posts: 1,191

Rep: Reputation: 45
What kernel version?

...drkstr
 
Old 08-30-2006, 01:55 PM   #3
LocoMojo
Member
 
Registered: Oct 2004
Distribution: Slackware 12
Posts: 165

Original Poster
Rep: Reputation: 30
Quote:
Originally Posted by drkstr
What kernel version?

...drkstr
Hello drkstr,

I'm using 2.6.17.8 which I compiled myself. I suppose I could try Pat's 2.6.17.11 to see if that helps.

I found that if at the prompt I press the space key 10 or 15 times then backspace to the beginning of the prompt the problem goes away for a while, but it does come back later.

Really weird, but it's enough to drive me nuts because I keep getting errors due to the second letter missing from my commands.

I also found that the problem doesn't seem to affect root, but I don't log into root often enough or long enough to see if the problem appears. Could be a configuration thing for my user? I'm just not sure where to begin looking.

LocoMojo
 
Old 08-30-2006, 09:41 PM   #4
drkstr
Senior Member
 
Registered: Feb 2006
Location: Seattle, WA: USA
Distribution: Slackware 11.0
Posts: 1,191

Rep: Reputation: 45
I belive there was a similar bug on the earlier 2.6.17. kernels. Try upgrading and see if this fixes it.

regards,
...drkstr
 
Old 09-04-2006, 10:22 AM   #5
LocoMojo
Member
 
Registered: Oct 2004
Distribution: Slackware 12
Posts: 165

Original Poster
Rep: Reputation: 30
Quote:
Originally Posted by drkstr
I belive there was a similar bug on the earlier 2.6.17. kernels. Try upgrading and see if this fixes it.

regards,
...drkstr
Sorry it took so long for me to reply as I've gotten busy.

Just upgraded to 2.6.17.11...no change

LocoMojo
 
Old 09-04-2006, 06:31 PM   #6
regis_n_bits
Member
 
Registered: Mar 2006
Distribution: Slackware64 14.1 (kernel 3.14.4)
Posts: 83

Rep: Reputation: Disabled
LocoMojo,

You say that the problem doesn't appear when logged in as the root user. What happens when you try to open a subshell (i.e. enter '/bin/bash')? Have you also tried creating a new user, temporarily, and seeing if the problem exists for them?

I'm wondering if this may be due to a misconfigured .bashrc or .bash_profile for your main account.

There is also the /etc/profile and /etc/inputrc files. If you have been updating your Slack to the current version, then these files should be updated. You would see files called /etc/inputrc.new and /etc/profile.new present. These files should replace your old files.
 
Old 09-04-2006, 09:48 PM   #7
LocoMojo
Member
 
Registered: Oct 2004
Distribution: Slackware 12
Posts: 165

Original Poster
Rep: Reputation: 30
Quote:
Originally Posted by regis_n_bits
LocoMojo,

You say that the problem doesn't appear when logged in as the root user. What happens when you try to open a subshell (i.e. enter '/bin/bash')? Have you also tried creating a new user, temporarily, and seeing if the problem exists for them?

I'm wondering if this may be due to a misconfigured .bashrc or .bash_profile for your main account.

There is also the /etc/profile and /etc/inputrc files. If you have been updating your Slack to the current version, then these files should be updated. You would see files called /etc/inputrc.new and /etc/profile.new present. These files should replace your old files.
Hello R 'n B,

Thanks for your reply.

Interesting...the problem seems to go away when I open a subshell. What do you suppose that would mean?

My .bashrc and .bash_profile files are fine, I think. I haven't changed them much in a long while and I commented out the two changes I've made within the last 3 months, but still had the problem. I also tried removing my .bashrc file and then logging in again and still had the problem. I've updated my /etc/inputrc and /etc/profile files as well.

By the way, I just added a temporary new user and this new user has the same problem.

What should I do now?

LocoMojo
 
Old 09-05-2006, 03:46 PM   #8
tobyl
Member
 
Registered: Apr 2003
Location: uk
Distribution: slackware current
Posts: 743

Rep: Reputation: 51
Probably a really stupid idea, but have you tried a different keyboard?

tobyl
 
Old 09-05-2006, 06:11 PM   #9
regis_n_bits
Member
 
Registered: Mar 2006
Distribution: Slackware64 14.1 (kernel 3.14.4)
Posts: 83

Rep: Reputation: Disabled
LocoMojo,

If the keyboard problem disappears when you are in a sub-shell, then this eliminates it being a hardware problem.
Quote:
Interesting...the problem seems to go away when I open a subshell. What do you suppose that would mean?

My .bashrc and .bash_profile files are fine, I think. I haven't changed them much in a long while and I commented out the two changes I've made within the last 3 months, but still had the problem. I also tried removing my .bashrc file and then logging in again and still had the problem. I've updated my /etc/inputrc and /etc/profile files as well.
If I remember correctly the .bashrc file is used upon opening each new sub-shell, and the .bash_profile is used only once (right after the login). You might want to try removing the .bash_profile for your account. So the problem might be in your .bash_profile.

As a last resort, if root is still working OK, then try copying over the .bash* files from root's home directory. Then apply your modifications one at a time to these files.
 
Old 09-05-2006, 06:24 PM   #10
tobyl
Member
 
Registered: Apr 2003
Location: uk
Distribution: slackware current
Posts: 743

Rep: Reputation: 51
but surely the new user test eliminates the .bash_profile possibility?

tobyl
 
Old 09-05-2006, 06:36 PM   #11
regis_n_bits
Member
 
Registered: Mar 2006
Distribution: Slackware64 14.1 (kernel 3.14.4)
Posts: 83

Rep: Reputation: Disabled
That's true, unless he has been modifying the /etc/skel/.bash_profile. If his .bash_profile was copied from this file, then all of his users will have the same problem.
But root user, being created first before there are any files in the /etc/skel directory, will probably have a different looking .bash_profile.

There is also another file called /etc/screenrc, that deals with the display on the console. But I have never tried modifying that file, so I am not 100% sure what this file does.
 
Old 09-05-2006, 11:15 PM   #12
LocoMojo
Member
 
Registered: Oct 2004
Distribution: Slackware 12
Posts: 165

Original Poster
Rep: Reputation: 30
Hello R 'n B and tobyl,

Thanks to the both of you for your replys.

Quote:
If the keyboard problem disappears when you are in a sub-shell, then this eliminates it being a hardware problem.
I agree, it isn't a hardware problem since the root account works fine.

Quote:
If I remember correctly the .bashrc file is used upon opening each new sub-shell, and the .bash_profile is used only once (right after the login). You might want to try removing the .bash_profile for your account. So the problem might be in your .bash_profile.
Both the root's and user's .bash_profile files are identical, unmodified since day one.

Just in case, I removed my user's .bash_profile file and the problem remains.

Quote:
As a last resort, if root is still working OK, then try copying over the .bash* files from root's home directory. Then apply your modifications one at a time to these files.
This makes a whole lot of sense and I'm kicking myself for not thinking of it earlier. However, after trying this...the problem still remains

I'm at my wits end, I can't figure this one out. It can't be a permissions thing because if it were then I wouldn't be able to type at all with my user...not just the second character at every prompt.

I don't have this problem in a virtual console such as Konsole or Yakuake. What is the difference between the root/user use of the console and the root/user use of the virtual console as far as typing goes? Could this be a problem with the console font? I've never messed with it though.

Thanks much for your help!

LocoMojo
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Cant type to enter Half Life:Counter Strike CD-KEY with Wine /home/kyle Linux - Games 13 02-15-2007 02:57 PM
Too long on shift key. Now I cannot type. suguru Suse/Novell 1 07-09-2006 09:49 AM
installing redhat 8.0 when text login in I cannot type password?? I type root scrist Linux - General 4 04-22-2006 03:20 AM
SSH unknown key type homestead1000 Linux - Software 1 01-13-2005 12:24 PM
What key to press in order to type symbols? windz Linux - General 0 02-10-2004 07:03 AM


All times are GMT -5. The time now is 12:28 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration