LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (http://www.linuxquestions.org/questions/slackware-14/)
-   -   SeaMonkey forgets the magnification (zoom) when it opens a new tab. (http://www.linuxquestions.org/questions/slackware-14/seamonkey-forgets-the-magnification-zoom-when-it-opens-a-new-tab-898300/)

stf92 08-19-2011 11:34 AM

SeaMonkey forgets the magnification (zoom) when it opens a new tab.
 
To users of SeaMonkey, hello:

Every time I want to change the magnification to 110, I must do View>Text Zoom>Other and write the figure in the box. I'm getting a bit tired of this. However, having looked into Edit>Preferences I have not been able to find anything. But there must be a way of setting the magnification once and for all.

The help is useless, as it is a mere restatement of the the pull-down menus entries names, something that the name already implies. Furthermore, each time I open a new tab I must reset the magnification to 110 (a not predefined value in SeaMonkey). How do I make this web browser to remember the magnification?

frankbell 08-20-2011 07:36 PM

My Opera does the same thing. I will keep magnification within the same tab, but revert to default in a new one. Opera, though, gives me a preferences dialog for setting the default zoom at intervals of 10 percentage points.

I found this about Firefox (I had "seamonkey," not "firefox" in the search string). It might be worth a look:

http://maketecheasier.com/28-coolest...cks/2008/08/21

I haven't tested it.

stf92 08-21-2011 04:03 AM

It's not only the magnification, but the spell checking too. I wonder: have you tried to contact the Opera people? When I have done this with regard to SeaMonkey its been useless.

GazL 08-21-2011 05:31 AM

I've reported bugs to Opera before and they got fixed within a release or two. Whether that was anything to do with my report though I have no idea as they don't respond to bug reporters personally.

For seamonkey you could try this workaround:

type about:config in the location bar.
enter "zoom" in the filter
double click zoom.minpercent and change the value to your desired value.

It's not perfect as after doing this you won't be able to shrink anything past that value, but it will force your zoom to remain in the range you specify.


It sounds like what you're actually wanting is a "zoom.initialPercent" config option. I don't know how open the Mozilla guys are to feature requests having not dealt with them myself, but if the idea makes sense and there's a usage case for it (And in this case I think it does, and there is), I don't see why they wouldn't be open to suggestions.

Just remember that you are making a request, be polite, explain clearly what you'd like and why you think it's useful, and whatever you do don't demand that they add your feature: that really pisses-off developers and they're likely not to implement your request just out of spite!

frankbell 08-21-2011 08:39 PM

When I use zoom, it's because something on the page is too small for me to read. I don't use it regularly.

Accordingly, for my usage, the existing behavior is a feature not a bug, as I do not want new tabs zoomed.

stf92 08-21-2011 09:05 PM

I understand. It's just the opposite of my present case. But you've made me see what I can do. I can tailor /etc/xorg.conf to lower resolution, which will automatically reder everything magnified. The virtual screen will go off the physical screen borders but its the only solution I can think of.


All times are GMT -5. The time now is 08:07 AM.