LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
LinkBack Search this Thread
Old 03-08-2005, 07:47 PM   #1
encore
LQ Newbie
 
Registered: Mar 2005
Distribution: Slack
Posts: 24

Rep: Reputation: 15
Angry screensaver doesnt work


HELP!!!!!!!!!!!!!!!!!!!!!!!!!!!1
 
Old 03-09-2005, 04:11 AM   #2
Seppel
Member
 
Registered: Aug 2003
Location: Germany
Distribution: Frugalware (everywhere), Ubuntu (notebook only), Tomato (router)
Posts: 73

Rep: Reputation: 15
Hi encore,

could you be a little more specific about what doesn't work? What screensaver you are using, which desktop environment, and what specifically doesn't work (nothing happens, blank screen, graphical errors, wrong colors, whatever). That would help a lot getting your problem solved.

Greetings,

Seppel
 
Old 03-09-2005, 07:51 PM   #3
encore
LQ Newbie
 
Registered: Mar 2005
Distribution: Slack
Posts: 24

Original Poster
Rep: Reputation: 15
KDE 3.3 using slack and blackscreen.... no matter which opengl ss i chose
boooo
dont know y

Last edited by encore; 03-09-2005 at 07:54 PM.
 
Old 03-09-2005, 08:33 PM   #4
Brian1
Guru
 
Registered: Jan 2003
Location: Seymour, Indiana
Distribution: Distribution: RHEL 5 with Pieces of this and that. Kernel 2.6.23.1, KDE 3.5.8 and KDE 4.0 beta, Plu
Posts: 5,697

Rep: Reputation: 61
I haven't spent the time to see where KDE 3.3 kills screensaver on my FC3 system. I have tried other screensaver RPM's and even compiled the source to no avail. It somehow just does not work. I have no problem on my desktop, but it has never been formatted in 2 years. I started with Redhat 8 on it and just upgrade from redhat 8 to redhat 9 to FC1 to FC2 to FC3. Why it still works there I have no idea. But it does not work on my notebook. It is a fresh install of FC3.

To get the full use of xscreensaver back is goto your Configure Desktop > Screensavers.
Uncheck everything. Consider it disabled here.
Now goto a terminal screen and type ' xscreensaver & '.
When it appears click on the settings tab and select the screensaver you want, time for it to appear and time it resets.
Now close.
Now in the time you set it at it should come up and run the screensaver.

Now if you want to get back into it you will need to type ' xscreensaver-demo '. Make changes and close.

I haven't figure out where to put it to autostart on every reboot. I know /etc/rc.local does not work since X is not up when that script is run. Putting certain items in /usr/bin/startkde just cause major conflicts.

I usually start it manually. I created a script called /home/<username>/xscreensaver.sh
Contents of script
Code:
#!/bin/sh
#
# Starting Up XscreenSaver
xscreensaver &
Then I created a softlink to the Desktop. I can click on it and it starts up. I don't hit the settings button here. After 5 secs or so it dissappears. Note you need to make the script executable. Either can do properties on the script from the desktop and set permissions. Or at a terminal type chmod +x xscreensaver.sh

I haven't tried it but I believe one can copy the script to /home/<username>/.kde/autostart directory. If you give it a try let me know.

Let me know how well it works for you.

Brian1
" Google the Linux way @ http://www.google.com/linux "
 
Old 03-09-2005, 09:19 PM   #5
mcd
Member
 
Registered: Aug 2003
Location: Boulder, CO
Distribution: Slackware, RHEL, CentOS
Posts: 825

Rep: Reputation: 33
or you could put it in ~/.xinitrc, or perhaps /etc/rc.d/rc.local

putting xscreensaver & in either of those should start it automatically at boot (or when X starts).
 
Old 03-10-2005, 03:06 AM   #6
Seppel
Member
 
Registered: Aug 2003
Location: Germany
Distribution: Frugalware (everywhere), Ubuntu (notebook only), Tomato (router)
Posts: 73

Rep: Reputation: 15
Are you using Slackware 10.1? If you do, try the following:

1. Add the user(s) that are allowed to use screensavers to the "shadow" group
2. Remove XScreensaver 4.19, install XScreensaver 4.16 (from Slack 10.0) instead

Don't ask why, I didn't understand why it has to be the "shadow" group. I just found this solution on this site and it worked for me.
It seems to be a bug in XScreensaver 4.19 that causes problems with KDE. If this solution doesn't work, please tell us and we'll look further :-)

Greetings,

Seppel
 
Old 04-08-2005, 07:47 AM   #7
PCrichton
LQ Newbie
 
Registered: Apr 2005
Location: New Jersey,US
Distribution: Slackware
Posts: 2

Rep: Reputation: 0
Both /etc/shadow and xscreensaver need be memebers of the shadow group so that xscreensaver can read the password data. Without it xscreensaver will not be able to lock and you would see something like this when starting it.

xscreensaver: couldn't get password of "pcrichton"
xscreensaver: couldn't get password of "root"
xscreensaver: 08:31:14: locking is disabled (error getting password).
xscreensaver: 08:31:14: does xscreensaver need to be setuid? consult the manual.

Ensure that both /etc/shadow and xscreensaver are members of the shadow group and that xscreensaver has setgid (group sticky bit)

-rw-r----- 1 root shadow 629 2005-03-31 00:50 /etc/shadow
-rwxr-s--x 1 root shadow 209372 2005-01-21 00:17 /usr/X11R6/bin/xscreensaver


Hope this helps.
 
Old 04-09-2005, 05:39 PM   #8
mesaverde
LQ Newbie
 
Registered: Apr 2005
Posts: 5

Rep: Reputation: 0
How to start xscreensaver

You can start xscreensaver automatically in KDE by:


1: Switch off KDE's screen saver.
Open the ``Control Center'' and select the ``Look and Feel / Screensaver'' page. Turn off the ``Enable Screensaver'' checkbox.

2: Find your Autostart directory.
Open the ``Look and Feel / Desktop / Paths'' page, and see what your ``Autostart'' directory is set to
It will probably be ~/.kde3/Autostart/ or something similar.

3: Make xscreensaver be an Autostart program.
Create a file in your autostart directory called xscreensaver.desktop that contains the following five lines:

[Desktop Entry]
Exec=xscreensaver
Name=XScreensaver
Type=Application
X-KDE-StartupNotify=false

(This is excerpted from http://www.jwz.org/xscreensaver/man1.html#10)
 
Old 04-09-2005, 05:45 PM   #9
gbonvehi
Senior Member
 
Registered: Jun 2004
Location: Argentina (SR, LP)
Distribution: Slackware
Posts: 3,145

Rep: Reputation: 51
Instead of putting the user in the shadow group, you should chown root:bin /usr/X11R6/bin/xscreensaver and be sure your user is on the bin group since this seems to be a bug in the packages (a bad group for the xscreensaver binary).
 
Old 04-10-2005, 02:29 PM   #10
PCrichton
LQ Newbie
 
Registered: Apr 2005
Location: New Jersey,US
Distribution: Slackware
Posts: 2

Rep: Reputation: 0
Actually, using the shadow group is the better solution. Xscreensaver must have access to the password hash to be able use locking. That means xscreensaver must run with the effective uid or gid of the /etc/shadow file (the suid or sgid sticky bits).

If you use suid, then xscreensaver has read/write access to /etc/shadow. Xscreensaver only needs read access, there is no need for write access. Over granting of prvilage is never a good idea. In addition, xscreensaver would also have privilage enough to access anything in the system with the uid of root. Not good .

By using the shadow group and sgid, access is limited to read only for only /etc/shadow and /etc/gshadow (the only two files in the group). This grants only the privilage it needs and no more .
 
Old 09-21-2005, 04:43 PM   #11
Riddick
Member
 
Registered: May 2004
Location: Rome, Italy
Distribution: slackware-current
Posts: 454

Rep: Reputation: 30
PCrichton - your answer was very useful, thanks,
setting the group to shadow did it!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
KDE Screensaver won't work (Redhat 8) Rimmer Linux - Distributions 14 03-18-2008 03:59 PM
Why doesnt my USB mouse doesnt work? barkha Linux - Hardware 2 08-16-2005 11:31 AM
screensaver password doesnt work doralsoral Linux - Software 1 07-13-2004 04:42 PM
screensaver wont work Longinus Linux - Newbie 1 02-18-2004 05:25 PM
KDE - screensaver doesn't work nigham Linux - Software 5 10-07-2003 09:29 AM


All times are GMT -5. The time now is 09:58 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration