LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 06-21-2013, 08:54 AM   #1
JackHair
Member
 
Registered: Aug 2009
Location: Netherlands
Distribution: OpenSuse 13.1
Posts: 80

Rep: Reputation: 16
Screenblanker


Hello,

The last week I've been trying to disable the screen going blank. I've found several suggestions via google, but none seem to work.
What I've tried:
Disabled KDE screensaver.
added consoleblank=0 kernel option to lilo.conf
Change rc.M to: setterm -blank 0 -powersave off -powerdown 0 &
Added a script to kde-startup with:
Code:
#!/bin/sh
xset -dpms &
xset s noblank &
xset s off &
Tried both at boot and pre-boot.

But my screen keeps going blank when I watch something on Youtube, or while having a skype call.
How do I disable this?!

Last edited by JackHair; 06-21-2013 at 08:55 AM. Reason: typo
 
Old 06-21-2013, 09:02 AM   #2
zakame
Member
 
Registered: Apr 2012
Distribution: Debian, Ubuntu, Slackware
Posts: 121

Rep: Reputation: 42
What Slackware/KDE version are you using? If it is 14.0 or later you should disable power management (e.g. by unchecking the checkbox in the KDE Battery Monitor dialog.)
 
2 members found this post helpful.
Old 06-21-2013, 09:10 AM   #3
JackHair
Member
 
Registered: Aug 2009
Location: Netherlands
Distribution: OpenSuse 13.1
Posts: 80

Original Poster
Rep: Reputation: 16
Quote:
Originally Posted by zakame View Post
What Slackware/KDE version are you using? If it is 14.0 or later you should disable power management (e.g. by unchecking the checkbox in the KDE Battery Monitor dialog.)
Sorry, I'm on Slackware64 14.0 with kde 4.10.4.

Omg, thanks. I been looking at the wrong place. I didn't look at power management. I just turned of the screensaver at the Display&monitor settings. I hope I can do my stuff now without the screen blanking on me!
 
Old 06-21-2013, 09:13 AM   #4
zakame
Member
 
Registered: Apr 2012
Distribution: Debian, Ubuntu, Slackware
Posts: 121

Rep: Reputation: 42
Hehe, no worries. I was puzzling that too for some time before it dawned on me that KDE is doing screensaving as part of its power management.
 
Old 06-21-2013, 09:14 AM   #5
digger95
Member
 
Registered: Oct 2007
Location: Indiana, PA
Distribution: Slackware 14
Posts: 330

Rep: Reputation: 45
I had the same issue and it drove me bonkers because it prevented me from watching Netflix. Turning power management off didn't solve my issue for whatever reason. I ended up turning power management 'on' then changing 'dim display' and 'switch off display' to their maximum settings of 360 minutes.
 
Old 06-21-2013, 09:40 AM   #6
mrclisdue
Senior Member
 
Registered: Dec 2005
Distribution: Slackware -current, 14.1
Posts: 1,047

Rep: Reputation: 170Reputation: 170
Quote:
Originally Posted by JackHair View Post
Code:
#!/bin/sh
xset -dpms &
xset s noblank &
xset s off &
Tho' the issue is solved, there is another setting (affecting the screensaver) that *finally* worked for me in the past:

Code:
xset s noexpose
from 'man xset'

Quote:
The 'expose' flag sets the preference to allow window
exposures (the server can freely discard window contents),
while 'noexpose' sets the preference to disable screen saver
unless the server can regenerate the screens without causing
exposure events.
cheers,
 
1 members found this post helpful.
Old 06-21-2013, 01:50 PM   #7
JackHair
Member
 
Registered: Aug 2009
Location: Netherlands
Distribution: OpenSuse 13.1
Posts: 80

Original Poster
Rep: Reputation: 16
Quote:
Originally Posted by digger95 View Post
I had the same issue and it drove me bonkers because it prevented me from watching Netflix. Turning power management off didn't solve my issue for whatever reason. I ended up turning power management 'on' then changing 'dim display' and 'switch off display' to their maximum settings of 360 minutes.
It drove me nuts too. How not looking at the right place can affect us lol. It does work for me though to turn power management off, gladly.

Quote:
Originally Posted by mrclisdue View Post
Tho' the issue is solved, there is another setting (affecting the screensaver) that *finally* worked for me in the past:

Code:
xset s noexpose
from 'man xset'

cheers,
Thanks for the tip.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



All times are GMT -5. The time now is 05:19 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration