LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 03-18-2005, 09:08 PM   #1
chocloman
Member
 
Registered: Mar 2005
Location: Lima, Peru, South america
Distribution: slackware
Posts: 35

Rep: Reputation: 15
screen resolution 800x600


Hi slackers!, as a newbie i 'm quite annoyed at the way screen resolution is customized in slackware. I mean that when I run kde the default resolution is 1024 x 768 so that the app's fonts are too small to read. Well I solved this problem choosing my desired resolution in the control panel : 800x600 and everything is oK.
My questions is : Is there any way to choose 800x600 from the X before running "startx" (KDE is my default window manager)? . Do I need to touch again the xconfig file?

Thanks in advance
 
Old 03-18-2005, 09:28 PM   #2
xowl
Member
 
Registered: Jan 2005
Distribution: Slackware current (and others)
Posts: 188

Rep: Reputation: 30
U may want tor edit the file /etc/X11/xorg.conf, and change

Section "Screen"
Identifier "Screen 1"
Device "VESA Framebuffer"
Monitor "My Monitor"
DefaultDepth 16

Subsection "Display"
Depth 8
Modes "1280x1024" "1024x768" "800x600" "640x480"
EndSubsection
Subsection "Display"
Depth 16
Modes "1280x1024" "1024x768" "800x600" "640x480"
EndSubsection
Subsection "Display"
Depth 24
Modes "1280x1024" "1024x768" "800x600" "640x480"
EndSubsection
Subsection "Display"
Depth 32
Modes "1280x1024" "1024x768" "800x600" "640x480"
EndSubsection
EndSection



to





Section "Screen"
Identifier "Screen 1"
Device "VESA Framebuffer"
Monitor "My Monitor"
DefaultDepth 16

Subsection "Display"
Depth 8
Modes "800x600" "640x480"
EndSubsection
Subsection "Display"
Depth 16
Modes "800x600" "640x480"
EndSubsection
Subsection "Display"
Depth 24
Modes "800x600" "640x480"
EndSubsection
Subsection "Display"
Depth 32
Modes "800x600" "640x480"
EndSubsection
EndSection



Luck
 
Old 03-19-2005, 05:51 AM   #3
killerbob
Member
 
Registered: Oct 2004
Location: Ottawa, ON
Distribution: Slackware
Posts: 662

Rep: Reputation: 30
You don't have to disable the higher resolutions to have it choose 800x600 by default. All that matters is that 800x600 is the first in the list of available resolutions.

Incidentally, you know that you can increase the font size, instead of decreasing the resolution? I'm in much the same boat as you are, in that I found the fonts were far too small in Firefox. So I went into Firefox's setup, and set the minimum font size to 14point, and the problem was solved. Likewise, you're sacrificing an awful lot of workspace on your desktop by decreasing the resolution, when I think the real solution you're looking for is to increase the font size. In KDE's control centre, it's under Appearance > Fonts.

The only reason I can see where you actually need to decrease the resolution, or disable a higher resolution is if your monitor doesn't support the higher resolution. Or more importantly, if your monitor doesn't support a decent refresh rate at that resolution. My monitor will go up to 1920x1440, but I keep it at 1600x1200, because it's only 75Hz at 1920x1440, and refresh rates below 80Hz give me a headache.
 
Old 03-19-2005, 07:12 AM   #4
uberNUT69
Member
 
Registered: Jan 2005
Location: Tasmania
Distribution: Xen Debian Lenny/Sid
Posts: 578

Rep: Reputation: 30
List your screen resolutions in X
eg. I use:
SubSection "Display"
Depth 24
Modes "1280x1024" "1024x768" "800x600" "640x480"
in one of my Screen sections in /etc/X11/XF86Config-4
This allows me to use Ctrl+Alr+Numpad'+' or Ctrl+Alr+Numpad'-' to select a resolution I want.

There are also a lot of GUI apps that allow Ctrl+'+' or Ctrl+'-' for text zooming.
eg. Firefox,etc
and other apps that have similar settings.

ie. Keep the high res and just text zoom some apps for readability

Choosing the resolution at X login is unnecessary

You could also change the fonts you use (75dpi vs 100dpi)
 
Old 03-19-2005, 09:41 AM   #5
chocloman
Member
 
Registered: Mar 2005
Location: Lima, Peru, South america
Distribution: slackware
Posts: 35

Original Poster
Rep: Reputation: 15
wow!! good points

well , Thanks guys I really appreciate your advices , so I donīt need to disable higher resolutions in my slack box and instead of that I just need to increase the size of the fonts. It's a new approach to me ...I 'm going to try both of them.

Viva slackware!!!!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Fedora Core 2: Screen Resolution can not change from "800X600" to "1024X 768" suhaimi_sj Fedora - Installation 18 12-17-2009 03:29 AM
Can't get a better resolution than 800X600 on debian bharath144 Linux - General 4 03-12-2006 10:23 AM
Why can't you get a higher screen resolution than 800x600 on SUSE? yekrahs Suse/Novell 11 02-09-2006 04:58 PM
Can't change screen resolution past 800x600 (Debian Sarge) Virp00 Linux - Newbie 1 03-05-2005 04:46 PM
The X window is running only in 800x600 resolution abbasali Linux - Hardware 4 04-20-2004 01:12 AM


All times are GMT -5. The time now is 09:25 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration