LinuxQuestions.org
Did you know LQ has a Linux Hardware Compatibility List?
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices



Reply
 
Search this Thread
Old 04-27-2010, 05:09 AM   #1
Josh000
Member
 
Registered: Aug 2009
Distribution: Slackware 13 64bit
Posts: 534

Rep: Reputation: 35
Screen keeps turning off after 10 minutes


HI, I have actually done a bit of searching on this, but the suggested solutions either don't work or are not applicable to my setup.

First, I changed the setterm link in /etc/rc.d/rc.M to be setterm -blank 0 -powersave off -powerdown 0

and have xset s off in my fluxbox startup file.

Nevertheless, the screen goes blank after 10 minutes. I can't figure out what is causing it and how to stop it.
 
Old 04-27-2010, 05:13 AM   #2
stuart_cherrington
Member
 
Registered: Aug 2008
Location: Get back in your Cube Unix Boy!
Distribution: rh5, oel5, debian etch, solaris
Posts: 228

Rep: Reputation: 36
Question: Is it the screen which goes blank or does the 'physical' terminal actually power down?
 
Old 04-27-2010, 05:41 AM   #3
dive
Senior Member
 
Registered: Aug 2003
Location: UK
Distribution: Slackware
Posts: 3,211

Rep: Reputation: 293Reputation: 293Reputation: 293
The setterm line is only for consoles. You could try commenting out completely though. As for xset try 'xset -dpms'. Run xset alone to see options.

Oh yeah and make sure xscreensaver daemon isn't running.

Last edited by dive; 04-28-2010 at 04:35 AM.
 
Old 04-27-2010, 07:02 AM   #4
H_TeXMeX_H
Guru
 
Registered: Oct 2005
Location: $RANDOM
Distribution: slackware64
Posts: 12,928
Blog Entries: 2

Rep: Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269
Add this to the monitor section of '/etc/X11/xorg.conf'

Code:
Option "DPMS" "0"
or instead of "0" use "false".
 
Old 04-27-2010, 07:22 AM   #5
Josh000
Member
 
Registered: Aug 2009
Distribution: Slackware 13 64bit
Posts: 534

Original Poster
Rep: Reputation: 35
It isnt dpms related. My screen does not actually turn off, it turns blank.
 
Old 04-27-2010, 07:49 AM   #6
H_TeXMeX_H
Guru
 
Registered: Oct 2005
Location: $RANDOM
Distribution: slackware64
Posts: 12,928
Blog Entries: 2

Rep: Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269
Actually, DPMS first blanks the screen, then turns it off.

If it happens when X is running, turn off DPMS in xorg.conf (restart X of course).

If it happens on the console, see 'rc.M' and do what you did above.

There are no other ways to control the screen blanking, the solution is one of the above.
 
Old 04-28-2010, 02:31 AM   #7
propofol
Member
 
Registered: Nov 2007
Location: Seattle
Distribution: Debian Wheezy & Jessie; Ubuntu
Posts: 298

Rep: Reputation: 55
Not sure if this will help, but I had a similar problem with my debian lenny system. This code which I found on the internet seems to fixed the problem:

~/.xinitrc
Code:
xset -dpms     // This *should* turn off the dpms power management stuff
xset s noblank // This should turn off screen blanking
xset s off     // This turns off the screen saver

xscreensaver &
exec startkde
Regards,
Stefan
 
Old 04-29-2010, 01:29 AM   #8
Josh000
Member
 
Registered: Aug 2009
Distribution: Slackware 13 64bit
Posts: 534

Original Poster
Rep: Reputation: 35
OK, I have tried xset s off and xset -dpms and it still goes blank after 10 minutes.

If it is dpsm, why isn't xset -dpms working?
 
Old 04-29-2010, 08:31 AM   #9
H_TeXMeX_H
Guru
 
Registered: Oct 2005
Location: $RANDOM
Distribution: slackware64
Posts: 12,928
Blog Entries: 2

Rep: Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269
Just tell me if it doesn't work if doesn't work if you add that option to xorg.conf like I said, have you tried it ?
 
Old 04-29-2010, 07:47 PM   #10
Josh000
Member
 
Registered: Aug 2009
Distribution: Slackware 13 64bit
Posts: 534

Original Poster
Rep: Reputation: 35
No, it didn't work. I didn't have an xorg.conf file and created it, just with the line you gave.

I would prefer anyway to be able to disable it per user and not just system wide if that is possible
 
Old 04-30-2010, 06:39 AM   #11
H_TeXMeX_H
Guru
 
Registered: Oct 2005
Location: $RANDOM
Distribution: slackware64
Posts: 12,928
Blog Entries: 2

Rep: Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269
Any screensaver set to run ?
 
Old 04-30-2010, 07:14 PM   #12
Josh000
Member
 
Registered: Aug 2009
Distribution: Slackware 13 64bit
Posts: 534

Original Poster
Rep: Reputation: 35
No, no screensavers are even installed.
 
Old 05-02-2010, 03:38 PM   #13
Josh000
Member
 
Registered: Aug 2009
Distribution: Slackware 13 64bit
Posts: 534

Original Poster
Rep: Reputation: 35
OK, the culprit was the screensaver, when i do xset s off and xset s noblank the problem disappears

I put these commands in my .fluxbox/startup file, however they don't seem to be loaded as xset q shows them still to be at default settings.

I run tint2 fine from the startup file, so why would the xset commands not load from there?

It seems to be the correct approach going by here

Last edited by Josh000; 05-02-2010 at 03:42 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Turning off Screen Blanking Slick666 Linux - Desktop 11 07-12-2008 04:15 PM
disable screen turning off alenD Linux - Newbie 1 03-29-2008 05:43 AM
Etch and turning off screen saver knobby67 Debian 2 02-22-2007 09:04 AM
System Turning Off Monitor After A Few Minutes linux216 Linux - Software 5 03-07-2006 08:46 PM
auto turning off monitor after 15 minutes idle? webazoid Linux - Software 1 07-10-2004 09:41 AM


All times are GMT -5. The time now is 08:20 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration